Email Marketing for WooCommerce by Omnisend: known security problems
4 known security problems reported for this WordPress plugin, with the affected versions, the fix and what to do.
Updated
In short
There are 4 known security problems on this page. Each one has a fixed version. Updating to version 1.19.1 or newer covers every fixed problem listed here.
Based on public reports. Check the plugin’s changelog. Watchfox AI may be wrong.
Get an email when your site is affected: install Watchfox AI (free)
Someone could do things on your site they should not be allowed to
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 1.19.0
- Fixed in
- 1.19.1
- What to do
- If your site has an affected version, update Email Marketing for WooCommerce by Omnisend to version 1.19.1 or newer.
- Official ID
- CVE-2026-57632
- Report title
- Email Marketing for WooCommerce by Omnisend <= 1.19.0 - Missing Authorization
- First reported
- Sources
- Wordfence, seen
A stranger could take over your site as an admin
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 1.18.0
- Fixed in
- 1.18.1
- What to do
- If your site has an affected version, update Email Marketing for WooCommerce by Omnisend to version 1.18.1 or newer.
- Official ID
- CVE-2026-42668
- Report title
- Omnisend for WooCommerce <= 1.18.0 - Unauthenticated Omnisend Account Takeover via Predictable Connect Token
- First reported
- Sources
- Wordfence, seen
Someone could trick a logged-in admin into changing settings without knowing
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 1.14.3
- Fixed in
- 1.14.4
- What to do
- If your site has an affected version, update Email Marketing for WooCommerce by Omnisend to version 1.14.4 or newer.
- Official ID
- CVE-2024-32101
- Report title
- Email Marketing for WooCommerce by Omnisend <= 1.14.3 - Cross-Site Request Forgery
- First reported
- Sources
- Wordfence, seen
Someone could see private information they should not see
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 1.13.8
- Fixed in
- 1.13.9
- What to do
- If your site has an affected version, update Email Marketing for WooCommerce by Omnisend to version 1.13.9 or newer.
- Official ID
- CVE-2023-47244
- Report title
- Email Marketing for WooCommerce by Omnisend <= 1.13.8 - Sensitive Information Exposure
- First reported
- Sources
- Wordfence, seen
Where this comes from
We collect these reports from public security sources and rewrite them in plain words. Each problem shows its sources and the date we first saw it. This page never says whether your own site is affected: only a check of your site’s versions can tell.
Get an email when your site is affected.
Install Watchfox AI once. It checks your plugins and themes against this list every day, for free.
Install Watchfox AI (free)