PPWP – Password Protect Pages: known security problems
12 known security problems reported for this WordPress plugin, with the affected versions, the fix and what to do.
Updated
In short
There are 12 known security problems on this page. Each one has a fixed version. Updating to version 1.9.27 or newer covers every fixed problem listed here.
Based on public reports. Check the plugin’s changelog. Watchfox AI may be wrong.
Get an email when your site is affected: install Watchfox AI (free)
A stranger could plant harmful code that runs for your visitors or admins
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 1.9.26
- Fixed in
- 1.9.27
- What to do
- If your site has an affected version, update PPWP – Password Protect Pages to version 1.9.27 or newer.
- Official ID
- CVE-2026-116520
- Report title
- PPWP <= 1.9.26 - Unauthenticated Stored Cross-Site Scripting via '[ppwp]' Shortcode 'desc_below_form' Attribute via Placeholder Marker Collision
- First reported
- Sources
- Wordfence, seen
Someone with a contributor account on your site could plant harmful code that runs for your visitors or admins (up to and including 1.9.21)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 1.9.21
- Fixed in
- 1.9.22
- What to do
- If your site has an affected version, update PPWP – Password Protect Pages to version 1.9.22 or newer.
- Official ID
- CVE-2025-9878
- Report title
- Password Protect WordPress Lite <= 1.9.21 - Authenticated (Contributor+) Stored Cross-Site Scripting
- First reported
- Sources
- Wordfence, seen
Someone with a contributor account on your site could in some setups, take over your site
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 1.9.18
- Fixed in
- 1.9.19
- What to do
- If your site has an affected version, update PPWP – Password Protect Pages to version 1.9.19 or newer.
- Official ID
- CVE-2026-0551
- Report title
- PPWP – Password Protect Pages <= 1.9.18 - Authenticated (Contributor+) PHP Object Injection via post_protection_roles
- First reported
- Sources
- Wordfence, seen
Someone with a contributor account on your site could use it to harm your site (up to and including 1.9.15)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 1.9.15
- Fixed in
- 1.9.16
- What to do
- If your site has an affected version, update PPWP – Password Protect Pages to version 1.9.16 or newer.
- Official ID
- CVE-2025-11729
- Report title
- PPWP: Password Protect Pages, Posts & Full or Partial Content <= 1.9.15 - Improper Authorization To Authenticated (Contributor+) Master Password Exposure
- First reported
- Sources
- Wordfence, seen
Someone with a contributor account on your site could use it to harm your site (up to and including 1.9.20)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 1.9.20
- Fixed in
- 1.9.21
- What to do
- If your site has an affected version, update PPWP – Password Protect Pages to version 1.9.21 or newer.
- Official ID
- CVE-2025-10005
- Report title
- Password Protect WordPress Lite <= 1.9.20 - Insecure Direct Object Reference to Authenticated (Contributor+) Password Protected Post Password Update
- First reported
- Sources
- Wordfence, seen
Someone with a contributor account on your site could plant harmful code that runs for your visitors or admins (up to and including 1.9.21) (2)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 1.9.21
- Fixed in
- 1.9.22
- What to do
- If your site has an affected version, update PPWP – Password Protect Pages to version 1.9.22 or newer.
- Official ID
- CVE-2026-3639
- Report title
- PPWP – Password Protect Pages <= 1.9.21 - Authenticated (Contributor+) Stored Cross-Site Scripting via Shortcode Attributes
- First reported
- Sources
- Wordfence, seen
Someone with a contributor account on your site could use it to harm your site (up to and including 1.9.19)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 1.9.19
- Fixed in
- 1.9.20
- What to do
- If your site has an affected version, update PPWP – Password Protect Pages to version 1.9.20 or newer.
- Official ID
- CVE-2026-57634
- Report title
- PPWP – Password Protect Pages <= 1.9.19 - Authenticated (Contributor+) Insecure Direct Object Reference
- First reported
- Sources
- Wordfence, seen
Someone could do things on your site they should not be allowed to
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 1.9.15
- Fixed in
- 1.9.16
- What to do
- If your site has an affected version, update PPWP – Password Protect Pages to version 1.9.16 or newer.
- Official ID
- CVE-2026-32562
- Report title
- PPWP – Password Protect Pages <= 1.9.15 - Missing Authorization
- First reported
- Sources
- Wordfence, seen
Anyone with an account on your site, even a basic one could use it to harm your site
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 1.9.10
- Fixed in
- 1.9.11
- What to do
- If your site has an affected version, update PPWP – Password Protect Pages to version 1.9.11 or newer.
- Official ID
- CVE-2025-5998
- Report title
- PPWP – Password Protect Pages <= 1.9.10 - Authenticated (Subscriber+) Content Exposure via REST API
- First reported
- Sources
- Wordfence, seen
A stranger could see private information they should not see
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 1.9.5
- Fixed in
- 1.9.6
- What to do
- If your site has an affected version, update PPWP – Password Protect Pages to version 1.9.6 or newer.
- Official ID
- CVE-2024-11280
- Report title
- PPWP – Password Protect Pages <= 1.9.5 - Unauthenticated Content Restriction Bypass to Sensitive Information Exposure
- First reported
- Sources
- Wordfence, seen
Someone could use it to harm your site
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 1.8.9
- Fixed in
- 1.9.0
- What to do
- If your site has an affected version, update PPWP – Password Protect Pages to version 1.9.0 or newer.
- Official ID
- CVE-2024-0620
- Report title
- PPWP – Password Protect Pages <= 1.8.9 - Protection Mechanism Bypass
- First reported
- Sources
- Wordfence, seen
Someone with a contributor account on your site could plant harmful code that runs for your visitors or admins (up to and including 1.8.5)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 1.8.5
- Fixed in
- 1.8.6
- What to do
- If your site has an affected version, update PPWP – Password Protect Pages to version 1.8.6 or newer.
- Official ID
- CVE-2022-4626
- Report title
- PPWP – WordPress Password Protect Page <= 1.8.5 - Authenticated (Contributor+) Stored Cross-Site Scripting via Shortcode
- First reported
- Sources
- Wordfence, seen
Where this comes from
We collect these reports from public security sources and rewrite them in plain words. Each problem shows its sources and the date we first saw it. This page never says whether your own site is affected: only a check of your site’s versions can tell.
Get an email when your site is affected.
Install Watchfox AI once. It checks your plugins and themes against this list every day, for free.
Install Watchfox AI (free)