Password Protected: known security problems
7 known security problems reported for this WordPress plugin, with the affected versions, the fix and what to do.
Updated
In short
There are 7 known security problems on this page. Each one has a fixed version. Updating to version 2.8.5 or newer covers every fixed problem listed here.
Based on public reports. Check the plugin’s changelog. Watchfox AI may be wrong.
Get an email when your site is affected: install Watchfox AI (free)
Anyone with an account on your site, even a basic one could plant harmful code that runs for your visitors or admins
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.8.4
- Fixed in
- 2.8.5
- What to do
- If your site has an affected version, update Password Protected to version 2.8.5 or newer.
- Official ID
- CVE-2026-93293
- Report title
- Password Protected <= 2.8.4 - Authenticated (Subscriber+) Stored Cross-Site Scripting via Freemius purchase_completed Handler
- First reported
- Sources
- Wordfence, seen
A stranger could use it to harm your site (up to and including 2.8.3)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.8.3
- Fixed in
- 2.8.4
- What to do
- If your site has an affected version, update Password Protected to version 2.8.4 or newer.
- Official ID
- CVE-2026-14943
- Report title
- Password Protected <= 2.8.3 - Unauthenticated Information Exposure
- First reported
- Sources
- Wordfence, seen
A stranger could use it to harm your site (up to and including 2.7.11)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.7.11
- Fixed in
- 2.7.12
- What to do
- If your site has an affected version, update Password Protected to version 2.7.12 or newer.
- Official ID
- CVE-2025-11244
- Report title
- Password Protected <= 2.7.11 - Unauthenticated Authorization Bypass via IP Address Spoofing
- First reported
- Sources
- Wordfence, seen
A stranger could see private information they should not see
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.7.7
- Fixed in
- 2.7.8
- What to do
- If your site has an affected version, update Password Protected to version 2.7.8 or newer.
- Official ID
- CVE-2025-3453
- Report title
- Password Protected – Password Protect your WordPress Site, Pages, & WooCommerce Products <= 2.7.7 - Unauthenticated Sensitive Information Exposure
- First reported
- Sources
- Wordfence, seen
Someone could see private information they should not see
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.6.6
- Fixed in
- 2.6.7
- What to do
- If your site has an affected version, update Password Protected to version 2.6.7 or newer.
- Official ID
- CVE-2024-0437
- Report title
- Password Protected – Ultimate Plugin to Password Protect Your WordPress Content with Ease <= 2.6.6 - Missing Authorization to Sensitive Information Exposure
- First reported
- Sources
- Wordfence, seen
Someone could plant harmful code that runs for your visitors or admins
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.6.6
- Fixed in
- 2.6.7
- What to do
- If your site has an affected version, update Password Protected to version 2.6.7 or newer.
- Official ID
- CVE-2024-0656
- Report title
- Password Protected <= 2.6.6 - Authenticated (Admin+) Stored Cross-Site Scripting
- First reported
- Sources
- Wordfence, seen
Someone who already has an admin account could plant harmful code that runs for your visitors or admins
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.6.2
- Fixed in
- 2.6.3
- What to do
- If your site has an affected version, update Password Protected to version 2.6.3 or newer.
- Official ID
- CVE-2023-32580
- Report title
- Password Protected <= 2.6.2 - Authenticated (Administrator+) Stored Cross-Site Scripting
- First reported
- Sources
- Wordfence, seen
Where this comes from
We collect these reports from public security sources and rewrite them in plain words. Each problem shows its sources and the date we first saw it. This page never says whether your own site is affected: only a check of your site’s versions can tell.
Get an email when your site is affected.
Install Watchfox AI once. It checks your plugins and themes against this list every day, for free.
Install Watchfox AI (free)