PDF Poster: known security problems
5 known security problems reported for this WordPress plugin, with the affected versions, the fix and what to do.
Updated
In short
There are 5 known security problems on this page. Each one has a fixed version. Updating to version 2.5.0 or newer covers every fixed problem listed here.
Based on public reports. Check the plugin’s changelog. Watchfox AI may be wrong.
Get an email when your site is affected: install Watchfox AI (free)
Someone could do things on your site they should not be allowed to (up to and including 2.4.1)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.4.1
- Fixed in
- 2.5.0
- What to do
- If your site has an affected version, update PDF Poster to version 2.5.0 or newer.
- Official ID
- CVE-2026-27416
- Report title
- PDF Poster – Display PDF Files with Custom Viewer <= 2.4.1 - Missing Authorization
- First reported
- Sources
- Wordfence, seen
Someone could plant harmful code that runs for your visitors or admins (up to and including 2.2.0)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.2.0
- Fixed in
- 2.3.1
- What to do
- If your site has an affected version, update PDF Poster to version 2.3.1 or newer.
- Official ID
- CVE-2024-13362
- Report title
- Freemius <= 2.10.1 - Reflected DOM-Based Cross-Site Scripting via url Parameter
- First reported
- Sources
- Wordfence, seen
Someone could do things on your site they should not be allowed to (up to and including 2.4.0)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.4.0
- Fixed in
- 2.4.1
- What to do
- If your site has an affected version, update PDF Poster to version 2.4.1 or newer.
- Official ID
- CVE-2026-32416
- Report title
- PDF Poster <= 2.4.0 - Missing Authorization
- First reported
- Sources
- Wordfence, seen
Someone could use it to harm your site
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.1.21
- Fixed in
- 2.1.22
- What to do
- If your site has an affected version, update PDF Poster to version 2.1.22 or newer.
- Official ID
- CVE-2024-4367
- Report title
- PDF.js < 4.2.67 - Arbitrary JavaScript Execution
- First reported
- Sources
- Wordfence, seen
Someone could plant harmful code that runs for your visitors or admins (up to and including 2.1.17)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.1.17
- Fixed in
- 2.1.18
- What to do
- If your site has an affected version, update PDF Poster to version 2.1.18 or newer.
- Official ID
- CVE-2024-23508
- Report title
- PDF Poster - PDF Embedder Plugin for WordPress <= 2.1.17 - Reflected Cross-Site Scripting
- First reported
- Sources
- Wordfence, seen
Where this comes from
We collect these reports from public security sources and rewrite them in plain words. Each problem shows its sources and the date we first saw it. This page never says whether your own site is affected: only a check of your site’s versions can tell.
Get an email when your site is affected.
Install Watchfox AI once. It checks your plugins and themes against this list every day, for free.
Install Watchfox AI (free)