Piotnet Addons For Elementor: known security problems
11 known security problems reported for this WordPress plugin, with the affected versions, the fix and what to do.
Updated
In short
There are 11 known security problems on this page. 8 of them have a fixed version. Updating to version 2.4.33 or newer covers every fixed problem listed here.
Based on public reports. Check the plugin’s changelog. Watchfox AI may be wrong.
Get an email when your site is affected: install Watchfox AI (free)
Someone with a contributor account on your site could read or delete private files on your server
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 7.1.71
- Fixed in
- No fixed version yet
- What to do
- There is no fixed version yet. If your site uses it, think about turning it off or replacing it until a fix comes out.
- Official ID
- CVE-2026-39754
- Report title
- Piotnet Addons For Elementor <= 7.1.71 - Authenticated (Contributor+) Arbitrary File Read
- First reported
- Sources
- Wordfence, seen
Someone with a contributor account on your site could plant harmful code that runs for your visitors or admins (up to and including 2.4.36)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.4.36
- Fixed in
- No fixed version yet
- What to do
- There is no fixed version yet. If your site uses it, think about turning it off or replacing it until a fix comes out.
- Official ID
- CVE-2024-13650
- Report title
- Piotnet Addons For Elementor <= 2.4.36 - Authenticated (Contributor+) Stored Cross-Site Scripting
- First reported
- Sources
- Wordfence, seen
Someone with a contributor account on your site could plant harmful code that runs for your visitors or admins (up to and including 2.4.36) (2)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.4.36
- Fixed in
- No fixed version yet
- What to do
- There is no fixed version yet. If your site uses it, think about turning it off or replacing it until a fix comes out.
- Official ID
- CVE-2025-32197
- Report title
- Piotnet Addons For Elementor <= 2.4.36 - Authenticated (Contributor+) Stored Cross-Site Scripting
- First reported
- Sources
- Wordfence, seen
Someone with a contributor account on your site could use it to harm your site
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.4.32
- Fixed in
- 2.4.33
- What to do
- If your site has an affected version, update Piotnet Addons For Elementor to version 2.4.33 or newer.
- Official ID
- CVE-2024-10775
- Report title
- Piotnet Addons For Elementor <= 2.4.32 - Authenticated (Contributor+) Post Disclosure
- First reported
- Sources
- Wordfence, seen
Someone with a contributor account on your site could plant harmful code that runs for your visitors or admins (up to and including 2.4.31)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.4.31
- Fixed in
- 2.4.32
- What to do
- If your site has an affected version, update Piotnet Addons For Elementor to version 2.4.32 or newer.
- Official ID
- CVE-2025-22333
- Report title
- Piotnet Addons For Elementor <= 2.4.31 - Authenticated (Contributor+) Stored Cross-Site Scripting
- First reported
- Sources
- Wordfence, seen
Someone with a contributor account on your site could plant harmful code that runs for your visitors or admins (up to and including 2.4.30)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.4.30
- Fixed in
- 2.4.31
- What to do
- If your site has an affected version, update Piotnet Addons For Elementor to version 2.4.31 or newer.
- Official ID
- CVE-2024-5502
- Report title
- Piotnet Addons For Elementor <= 2.4.30 - Authenticated (Contributor+) Stored Cross-Site Scripting via Multiple Widgets
- First reported
- Sources
- Wordfence, seen
A stranger could see private information they should not see
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.4.29
- Fixed in
- 2.4.30
- What to do
- If your site has an affected version, update Piotnet Addons For Elementor to version 2.4.30 or newer.
- Official ID
- CVE-2024-5614
- Report title
- Piotnet Addons For Elementor <= 2.4.29 - Unauthenticated Sensitive Information Exposure
- First reported
- Sources
- Wordfence, seen
Someone with a contributor account on your site could plant harmful code that runs for your visitors or admins (up to and including 2.4.28)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.4.28
- Fixed in
- 2.4.29
- What to do
- If your site has an affected version, update Piotnet Addons For Elementor to version 2.4.29 or newer.
- Official ID
- CVE-2024-4262
- Report title
- Piotnet Addons For Elementor <= 2.4.28 - Authenticated (Contributor+) Stored Cross-Site Scripting via Multiple Widget Attributes
- First reported
- Sources
- Wordfence, seen
Someone with a contributor account on your site could plant harmful code that runs for your visitors or admins (up to and including 2.4.26)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.4.26
- Fixed in
- 2.4.28
- What to do
- If your site has an affected version, update Piotnet Addons For Elementor to version 2.4.28 or newer.
- Official ID
- CVE-2024-4432
- Report title
- Piotnet Addons For Elementor <= 2.4.26 - Authenticated (Contributor+) Stored Cross-Site Scripting via Multiple Widgets
- First reported
- Sources
- Wordfence, seen
Someone with a contributor account on your site could plant harmful code that runs for your visitors or admins (up to and including 2.4.27)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.4.27
- Fixed in
- 2.4.28
- What to do
- If your site has an affected version, update Piotnet Addons For Elementor to version 2.4.28 or newer.
- Official ID
- CVE-2024-33630
- Report title
- Piotnet Addons For Elementor <= 2.4.27 - Authenticated (Contributor+) Stored Cross-Site Scripting
- First reported
- Sources
- Wordfence, seen
Someone with a contributor account on your site could plant harmful code that runs for your visitors or admins (up to and including 2.4.25)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.4.25
- Fixed in
- 2.4.26
- What to do
- If your site has an affected version, update Piotnet Addons For Elementor to version 2.4.26 or newer.
- Official ID
- CVE-2024-29934
- Report title
- Piotnet Addons For Elementor <= 2.4.25 - Authenticated (Contributor+) Stored Cross-Site Scripting
- First reported
- Sources
- Wordfence, seen
Where this comes from
We collect these reports from public security sources and rewrite them in plain words. Each problem shows its sources and the date we first saw it. This page never says whether your own site is affected: only a check of your site’s versions can tell.
Get an email when your site is affected.
Install Watchfox AI once. It checks your plugins and themes against this list every day, for free.
Install Watchfox AI (free)