Popup builder with Gamification, Multi-Step Popups, Page-Level Targeting, and WooCommerce Triggers: known security problems
7 known security problems reported for this WordPress plugin, with the affected versions, the fix and what to do.
Updated
In short
There are 7 known security problems on this page. Each one has a fixed version. Updating to version 2.2.1 or newer covers every fixed problem listed here.
Based on public reports. Check the plugin’s changelog. Watchfox AI may be wrong.
Get an email when your site is affected: install Watchfox AI (free)
Someone could do things on your site they should not be allowed to
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.2.0
- Fixed in
- 2.2.1
- What to do
- If your site has an affected version, update Popup builder with Gamification, Multi-Step Popups, Page-Level Targeting, and WooCommerce Triggers to version 2.2.1 or newer.
- Official ID
- CVE-2025-14895
- Report title
- PopupKit <= 2.2.0 - Missing Authorization to Sensitive Information Disclosure and Data Deletion
- First reported
- Sources
- Wordfence, seen
A stranger could read or change the data in your site’s database (up to and including 2.2.0)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.2.0
- Fixed in
- 2.2.1
- What to do
- If your site has an affected version, update Popup builder with Gamification, Multi-Step Popups, Page-Level Targeting, and WooCommerce Triggers to version 2.2.1 or newer.
- Official ID
- CVE-2025-13192
- Report title
- Popup builder with Gamification <= 2.2.0 - Unauthenticated SQL Injection via Multiple REST API Endpoints
- First reported
- Sources
- Wordfence, seen
Anyone with an account on your site, even a basic one could do things on your site they should not be allowed to
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.2.0
- Fixed in
- 2.2.1
- What to do
- If your site has an affected version, update Popup builder with Gamification, Multi-Step Popups, Page-Level Targeting, and WooCommerce Triggers to version 2.2.1 or newer.
- Official ID
- CVE-2025-14441
- Report title
- Popupkit <= 2.2.0 - Missing Authorization to Authenticated (Subscriber+) Arbitrary Subscriber Data Deletion
- First reported
- Sources
- Wordfence, seen
Anyone with an account on your site, even a basic one could use it to harm your site
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.1.5
- Fixed in
- 2.2.1
- What to do
- If your site has an affected version, update Popup builder with Gamification, Multi-Step Popups, Page-Level Targeting, and WooCommerce Triggers to version 2.2.1 or newer.
- Official ID
- CVE-2025-69026
- Report title
- PopupKit <= 2.1.5 - Authenticated (Subscriber+) Information Exposure
- First reported
- Sources
- Wordfence, seen
Anyone with an account on your site, even a basic one could read or change the data in your site’s database
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.1.5
- Fixed in
- 2.2.0
- What to do
- If your site has an affected version, update Popup builder with Gamification, Multi-Step Popups, Page-Level Targeting, and WooCommerce Triggers to version 2.2.0 or newer.
- Official ID
- CVE-2025-14314
- Report title
- PopupKit <= 2.1.5 - Authenticated (Subscriber+) SQL Injection
- First reported
- Sources
- Wordfence, seen
A stranger could make your server visit other addresses on their behalf
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.1.4
- Fixed in
- 2.1.5
- What to do
- If your site has an affected version, update Popup builder with Gamification, Multi-Step Popups, Page-Level Targeting, and WooCommerce Triggers to version 2.1.5 or newer.
- Official ID
- CVE-2025-10861
- Report title
- Popup builder with Gamification, Multi-Step Popups, Page-Level Targeting, and WooCommerce Triggers <= 2.1.4 - Unauthenticated Server-Side Request Forgery
- First reported
- Sources
- Wordfence, seen
A stranger could read or change the data in your site’s database (up to and including 2.1.3)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.1.3
- Fixed in
- 2.1.4
- What to do
- If your site has an affected version, update Popup builder with Gamification, Multi-Step Popups, Page-Level Targeting, and WooCommerce Triggers to version 2.1.4 or newer.
- Official ID
- CVE-2025-10862
- Report title
- Popup builder with Gamification, Multi-Step Popups, Page-Level Targeting, and WooCommerce Triggers <= 2.1.3 - Unauthenticated SQL Injection via 'id'
- First reported
- Sources
- Wordfence, seen
Where this comes from
We collect these reports from public security sources and rewrite them in plain words. Each problem shows its sources and the date we first saw it. This page never says whether your own site is affected: only a check of your site’s versions can tell.
Get an email when your site is affected.
Install Watchfox AI once. It checks your plugins and themes against this list every day, for free.
Install Watchfox AI (free)