Smart Post: known security problems
8 known security problems reported for this WordPress plugin, with the affected versions, the fix and what to do.
Updated
In short
There are 8 known security problems on this page. Each one has a fixed version. Updating to version 4.0.10 or newer covers every fixed problem listed here.
Based on public reports. Check the plugin’s changelog. Watchfox AI may be wrong.
Get an email when your site is affected: install Watchfox AI (free)
Anyone with an account on your site, even a basic one could plant harmful code that runs for your visitors or admins
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 4.0.9
- Fixed in
- 4.0.10
- What to do
- If your site has an affected version, update Smart Post to version 4.0.10 or newer.
- Official ID
- CVE-2026-119160
- Report title
- Smart Post <= 4.0.9 - Authenticated (Subscriber+) Stored Cross-Site Scripting via User display_name via Author Filter block
- First reported
- Sources
- Wordfence, seen
Someone with a contributor account on your site could use it to harm your site
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- From 4.0.0 up to and including 4.0.7
- Fixed in
- 4.0.8
- What to do
- If your site has an affected version, update Smart Post to version 4.0.8 or newer.
- Official ID
- CVE-2026-78150
- Report title
- Smart Post – Post Grid, Post Carousel, Post Slider Gutenberg Blocks for Blog & News 4.0.0 - 4.0.7 - Authenticated (Contributor+) Insecure Direct Object Reference
- First reported
- Sources
- Wordfence, seen
A stranger could use it to harm your site
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- From 4.0.0 up to and including 4.0.7
- Fixed in
- 4.0.8
- What to do
- If your site has an affected version, update Smart Post to version 4.0.8 or newer.
- Official ID
- CVE-2026-78149
- Report title
- Smart Post – Post Grid, Post Carousel, Post Slider Gutenberg Blocks for Blog & News 4.0.0 - 4.0.7 - Unauthenticated Password-Protected Post Content Disclosure
- First reported
- Sources
- Wordfence, seen
Someone who already has an admin account could in some setups, take over your site
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 3.0.12
- Fixed in
- 3.0.13
- What to do
- If your site has an affected version, update Smart Post to version 3.0.13 or newer.
- Official ID
- CVE-2026-3017
- Report title
- Smart Post Show – Post Grid, Post Carousel & Slider, and List Category Posts <= 3.0.12 - Authenticated (Administrator+) PHP Object Injection
- First reported
- Sources
- Wordfence, seen
Someone with an editor account on your site could plant harmful code that runs for your visitors or admins (up to and including 3.0.0)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 3.0.0
- Fixed in
- 3.0.1
- What to do
- If your site has an affected version, update Smart Post to version 3.0.1 or newer.
- Official ID
- CVE-2024-8187
- Report title
- Smart Post Show <= 3.0.0 - Authenticated (Editor+) Stored Cross-Site Scripting via Pagination Color
- First reported
- Sources
- Wordfence, seen
Someone with an editor account on your site could plant harmful code that runs for your visitors or admins (up to and including 2.4.27)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.4.27
- Fixed in
- 2.4.28
- What to do
- If your site has an affected version, update Smart Post to version 2.4.28 or newer.
- Official ID
- CVE-2024-3996
- Report title
- Post Grid, Post Carousel, & List Category Posts <= 2.4.27 - Authenticated (Editor+) Stored Cross-Site Scripting
- First reported
- Sources
- Wordfence, seen
Someone with a contributor account on your site could plant harmful code that runs for your visitors or admins
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.4.18
- Fixed in
- 2.4.19
- What to do
- If your site has an affected version, update Smart Post to version 2.4.19 or newer.
- Official ID
- CVE-2023-0097
- Report title
- Post Grid, Post Carousel, & List Category Posts <= 2.4.18 - Authenticated (Contributor+) Stored Cross-Site Scripting via Shortcode
- First reported
- Sources
- Wordfence, seen
Someone could use it to harm your site
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Before 2.3.5
- Fixed in
- 2.3.5
- What to do
- If your site has an affected version, update Smart Post to version 2.3.5 or newer.
- Report title
- Post Carousel < 2.3.5 - Missing Capabilities Check
- First reported
- Sources
- Wordfence, seen
Where this comes from
We collect these reports from public security sources and rewrite them in plain words. Each problem shows its sources and the date we first saw it. This page never says whether your own site is affected: only a check of your site’s versions can tell.
Get an email when your site is affected.
Install Watchfox AI once. It checks your plugins and themes against this list every day, for free.
Install Watchfox AI (free)