Post Duplicator: known security problems
10 known security problems reported for this WordPress plugin, with the affected versions, the fix and what to do.
Updated
In short
There are 10 known security problems on this page. Each one has a fixed version. Updating to version 3.0.15 or newer covers every fixed problem listed here.
Based on public reports. Check the plugin’s changelog. Watchfox AI may be wrong.
Get an email when your site is affected: install Watchfox AI (free)
Someone with a contributor account on your site could do things on your site they should not be allowed to (up to and including 3.0.11)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 3.0.11
- Fixed in
- 3.0.12
- What to do
- If your site has an affected version, update Post Duplicator to version 3.0.12 or newer.
- Official ID
- CVE-2026-4244
- Report title
- Post Duplicator <= 3.0.11 - Missing Authorization to Authenticated (Contributor+) Post Duplication with Arbitrary Author Attribution
- First reported
- Sources
- Wordfence, seen
Someone with a contributor account on your site could use it to harm your site (up to and including 3.0.11)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 3.0.11
- Fixed in
- 3.0.12
- What to do
- If your site has an affected version, update Post Duplicator to version 3.0.12 or newer.
- Official ID
- CVE-2026-4245
- Report title
- Post Duplicator <= 3.0.11 - Authorization Bypass to Authenticated (Contributor+) Post Duplication
- First reported
- Sources
- Wordfence, seen
Someone with a contributor account on your site could in some setups, take over your site (before 3.0.15)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Before 3.0.15
- Fixed in
- 3.0.15
- What to do
- If your site has an affected version, update Post Duplicator to version 3.0.15 or newer.
- Official ID
- CVE-2026-10749
- Report title
- Post Duplicator < 3.0.15 - Authenticated (Contributor+) PHP Object Injection
- First reported
- Sources
- Wordfence, seen
Someone with a contributor account on your site could in some setups, take over your site (up to and including 3.0.10)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 3.0.10
- Fixed in
- 3.0.11
- What to do
- If your site has an affected version, update Post Duplicator to version 3.0.11 or newer.
- Official ID
- CVE-2026-39474
- Report title
- Post Duplicator <= 3.0.10 - Authenticated (Contributor+) PHP Object Injection
- First reported
- Sources
- Wordfence, seen
Someone with a contributor account on your site could do things on your site they should not be allowed to (up to and including 3.0.8)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 3.0.8
- Fixed in
- 3.0.9
- What to do
- If your site has an affected version, update Post Duplicator to version 3.0.9 or newer.
- Official ID
- CVE-2026-2301
- Report title
- Post Duplicator <= 3.0.8 - Missing Authorization to Authenticated (Contributor+) Protected Post Meta Insertion via 'customMetaData' Parameter
- First reported
- Sources
- Wordfence, seen
Someone could do things on your site they should not be allowed to (up to and including 2.35)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.35
- Fixed in
- 2.36
- What to do
- If your site has an affected version, update Post Duplicator to version 2.36 or newer.
- Official ID
- CVE-2025-24736
- Report title
- Post Duplicator <= 2.35 - Missing Authorization
- First reported
- Sources
- Wordfence, seen
Someone with a contributor account on your site could use it to harm your site (up to and including 2.36)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.36
- Fixed in
- 2.37
- What to do
- If your site has an affected version, update Post Duplicator to version 2.37 or newer.
- Official ID
- CVE-2024-12472
- Report title
- Post Duplicator <= 2.36 - Authenticated (Contributor+) Protected Post Disclosure
- First reported
- Sources
- Wordfence, seen
Someone could do things on your site they should not be allowed to (up to and including 2.31)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.31
- Fixed in
- 2.32
- What to do
- If your site has an affected version, update Post Duplicator to version 2.32 or newer.
- Official ID
- CVE-2023-49835
- Report title
- Post Duplicator <= 2.31 - Missing Authorization via mtphr_duplicate_post
- First reported
- Sources
- Wordfence, seen
Someone could plant harmful code that runs for your visitors or admins (before 2.24)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Before 2.24
- Fixed in
- 2.24
- What to do
- If your site has an affected version, update Post Duplicator to version 2.24 or newer.
- Official ID
- CVE-2021-33852
- Report title
- Post Duplicator <= 2.23 - Cross-Site Scripting
- First reported
- Sources
- Wordfence, seen
Someone could plant harmful code that runs for your visitors or admins (up to and including 2.16)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.16
- Fixed in
- 2.17
- What to do
- If your site has an affected version, update Post Duplicator to version 2.17 or newer.
- Official ID
- CVE-2016-15027
- Report title
- Post Duplicator <= 2.16 - Reflected Cross-Site Scripting
- First reported
- Sources
- Wordfence, seen
Where this comes from
We collect these reports from public security sources and rewrite them in plain words. Each problem shows its sources and the date we first saw it. This page never says whether your own site is affected: only a check of your site’s versions can tell.
Get an email when your site is affected.
Install Watchfox AI once. It checks your plugins and themes against this list every day, for free.
Install Watchfox AI (free)