EN ES
Start free

Payment Plugins for PayPal WooCommerce: known security problems

5 known security problems reported for this WordPress plugin, with the affected versions, the fix and what to do.

Updated

In short

There are 5 known security problems on this page. Each one has a fixed version. Updating to version 2.0.27 or newer covers every fixed problem listed here.

Based on public reports. Check the plugin’s changelog. Watchfox AI may be wrong.

Get an email when your site is affected: install Watchfox AI (free)

This week

A stranger could use it to harm your site (up to and including 2.0.26)

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 2.0.26
Fixed in
2.0.27
What to do
If your site has an affected version, update Payment Plugins for PayPal WooCommerce to version 2.0.27 or newer.
Official ID
CVE-2026-80342
Report title
Payment Plugins for PayPal WooCommerce <= 2.0.26 - Unauthenticated Insecure Direct Object Reference
First reported
Sources
This week

Someone could do things on your site they should not be allowed to (up to and including 2.0.25)

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 2.0.25
Fixed in
2.0.26
What to do
If your site has an affected version, update Payment Plugins for PayPal WooCommerce to version 2.0.26 or newer.
Official ID
CVE-2026-80341
Report title
Payment Plugins for PayPal WooCommerce <= 2.0.25 - Missing Authorization
First reported
Sources
This week

A stranger could use it to harm your site (up to and including 2.0.25)

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 2.0.25
Fixed in
2.0.26
What to do
If your site has an affected version, update Payment Plugins for PayPal WooCommerce to version 2.0.26 or newer.
Official ID
CVE-2026-80340
Report title
Payment Plugins for PayPal WooCommerce <= 2.0.25 - Unauthenticated Information Exposure
First reported
Sources
This week

Someone could use it to harm your site

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 2.0.19
Fixed in
2.0.20
What to do
If your site has an affected version, update Payment Plugins for PayPal WooCommerce to version 2.0.20 or newer.
Official ID
CVE-2026-13399
Report title
Payment Plugins for PayPal WooCommerce <= 2.0.19 - Uanuthenticated Payment Bypass
First reported
Sources
This week

Someone could do things on your site they should not be allowed to (up to and including 2.0.13)

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 2.0.13
Fixed in
2.0.14
What to do
If your site has an affected version, update Payment Plugins for PayPal WooCommerce to version 2.0.14 or newer.
Official ID
CVE-2026-39643
Report title
Payment Plugins for PayPal WooCommerce <= 2.0.13 - Missing Authorization
First reported
Sources

Where this comes from

We collect these reports from public security sources and rewrite them in plain words. Each problem shows its sources and the date we first saw it. This page never says whether your own site is affected: only a check of your site’s versions can tell.

All plugins and themes

Get an email when your site is affected.

Install Watchfox AI once. It checks your plugins and themes against this list every day, for free.

Install Watchfox AI (free)