Quads Ads Manager for Google AdSense: known security problems
9 known security problems reported for this WordPress plugin, with the affected versions, the fix and what to do.
Updated
In short
There are 9 known security problems on this page. Each one has a fixed version. Updating to version 3.0.5 or newer covers every fixed problem listed here.
Based on public reports. Check the plugin’s changelog. Watchfox AI may be wrong.
Get an email when your site is affected: install Watchfox AI (free)
Anyone with an account on your site, even a basic one could use it to harm your site
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- From 3.0.4 up to and including 3.0.4
- Fixed in
- 3.0.5
- What to do
- If your site has an affected version, update Quads Ads Manager for Google AdSense to version 3.0.5 or newer.
- Official ID
- CVE-2026-89050
- Report title
- Quads Ads Manager for Google AdSense 3.0.4 - Authenticated (Subscriber+) Payment Bypass to Unpaid Ad Placement Acquisition
- First reported
- Sources
- Wordfence, seen
Someone could do things on your site they should not be allowed to (up to and including 3.0.3)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 3.0.3
- Fixed in
- 3.0.4
- What to do
- If your site has an affected version, update Quads Ads Manager for Google AdSense to version 3.0.4 or newer.
- Official ID
- CVE-2026-57335
- Report title
- Quads Ads Manager for Google AdSense <= 3.0.3 - Missing Authorization
- First reported
- Sources
- Wordfence, seen
A stranger could use it to harm your site
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 3.0.3
- Fixed in
- 3.0.4
- What to do
- If your site has an affected version, update Quads Ads Manager for Google AdSense to version 3.0.4 or newer.
- Official ID
- CVE-2026-54824
- Report title
- Quads Ads Manager for Google AdSense <= 3.0.3 - Unauthenticated Information Exposure
- First reported
- Sources
- Wordfence, seen
Someone could do things on your site they should not be allowed to (up to and including 3.0.2)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 3.0.2
- Fixed in
- 3.0.3
- What to do
- If your site has an affected version, update Quads Ads Manager for Google AdSense to version 3.0.3 or newer.
- Official ID
- CVE-2026-42744
- Report title
- Quads Ads Manager for Google AdSense <= 3.0.2 - Missing Authorization
- First reported
- Sources
- Wordfence, seen
Someone could do things on your site they should not be allowed to (up to and including 3.0.2) (2)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 3.0.2
- Fixed in
- 3.0.3
- What to do
- If your site has an affected version, update Quads Ads Manager for Google AdSense to version 3.0.3 or newer.
- Official ID
- CVE-2026-42732
- Report title
- Quads Ads Manager for Google AdSense <= 3.0.2 - Missing Authorization
- First reported
- Sources
- Wordfence, seen
Someone with a contributor account on your site could plant harmful code that runs for your visitors or admins
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.0.98.1
- Fixed in
- 2.0.99
- What to do
- If your site has an affected version, update Quads Ads Manager for Google AdSense to version 2.0.99 or newer.
- Official ID
- CVE-2026-2595
- Report title
- Quads Ads Manager for Google AdSense <= 2.0.98.1 - Authenticated (Contributor+) Stored Cross-Site Scripting via Multiple Ad Metadata Parameters
- First reported
- Sources
- Wordfence, seen
A stranger could read or change the data in your site’s database
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.0.87.1
- Fixed in
- 2.0.88
- What to do
- If your site has an affected version, update Quads Ads Manager for Google AdSense to version 2.0.88 or newer.
- Official ID
- CVE-2025-30876
- Report title
- Ads by WPQuads <= 2.0.87.1 - Unauthenticated SQL Injection
- First reported
- Sources
- Wordfence, seen
Someone could do things on your site they should not be allowed to (up to and including 2.0.87.1)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.0.87.1
- Fixed in
- 2.0.88
- What to do
- If your site has an affected version, update Quads Ads Manager for Google AdSense to version 2.0.88 or newer.
- Official ID
- CVE-2025-30855
- Report title
- Ads by WPQuads <= 2.0.87.1 - Missing Authorization
- First reported
- Sources
- Wordfence, seen
Someone could do things on your site they should not be allowed to (up to and including 2.0.84)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.0.84
- Fixed in
- 2.0.85
- What to do
- If your site has an affected version, update Quads Ads Manager for Google AdSense to version 2.0.85 or newer.
- Official ID
- CVE-2024-47317
- Report title
- Ads by WPQuads – Adsense Ads, Banner Ads, Popup Ads <= 2.0.84 - Missing Authorization
- First reported
- Sources
- Wordfence, seen
Where this comes from
We collect these reports from public security sources and rewrite them in plain words. Each problem shows its sources and the date we first saw it. This page never says whether your own site is affected: only a check of your site’s versions can tell.
Get an email when your site is affected.
Install Watchfox AI once. It checks your plugins and themes against this list every day, for free.
Install Watchfox AI (free)