Responsive Starter Templates: known security problems
10 known security problems reported for this WordPress plugin, with the affected versions, the fix and what to do.
Updated
In short
There are 10 known security problems on this page. Each one has a fixed version. Updating to version 3.5.4 or newer covers every fixed problem listed here.
Based on public reports. Check the plugin’s changelog. Watchfox AI may be wrong.
Get an email when your site is affected: install Watchfox AI (free)
Someone with a contributor account on your site could plant harmful code that runs for your visitors or admins
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 3.5.3
- Fixed in
- 3.5.4
- What to do
- If your site has an affected version, update Responsive Starter Templates to version 3.5.4 or newer.
- Official ID
- CVE-2026-15795
- Report title
- Responsive Plus <= 3.5.3 - Authenticated (Contributor+) Stored Cross-Site Scripting via Shortcode Attributes
- First reported
- Sources
- Wordfence, seen
A stranger could use it to harm your site
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Before 3.4.3
- Fixed in
- 3.4.3
- What to do
- If your site has an affected version, update Responsive Starter Templates to version 3.4.3 or newer.
- Official ID
- CVE-2025-15488
- Report title
- Responsive Plus – Elementor Templates & Starter Sites < 3.4.3 - Unauthenticated Arbitrary Code Execution
- First reported
- Sources
- Wordfence, seen
Someone could trick a logged-in admin into changing settings without knowing
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 3.2.2
- Fixed in
- 3.2.3
- What to do
- If your site has an affected version, update Responsive Starter Templates to version 3.2.3 or newer.
- Official ID
- CVE-2025-49856
- Report title
- Responsive Plus <= 3.2.2 - Cross-Site Request Forgery to Settings Update
- First reported
- Sources
- Wordfence, seen
Someone could do things on your site they should not be allowed to (up to and including 3.2.0)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 3.2.0
- Fixed in
- 3.2.1
- What to do
- If your site has an affected version, update Responsive Starter Templates to version 3.2.1 or newer.
- Official ID
- CVE-2025-48335
- Report title
- Responsive Plus <= 3.2.0 - Missing Authorization
- First reported
- Sources
- Wordfence, seen
Someone could do things on your site they should not be allowed to (up to and including 3.1.9)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 3.1.9
- Fixed in
- 3.2.0
- What to do
- If your site has an affected version, update Responsive Starter Templates to version 3.2.0 or newer.
- Official ID
- CVE-2025-47486
- Report title
- Gutenberg & Elementor Templates Importer For Responsive <= 3.1.9 - Missing Authorization
- First reported
- Sources
- Wordfence, seen
Someone with a contributor account on your site could make your server visit other addresses on their behalf
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 3.1.4
- Fixed in
- 3.1.5
- What to do
- If your site has an affected version, update Responsive Starter Templates to version 3.1.5 or newer.
- Official ID
- CVE-2024-13834
- Report title
- Responsive Plus – Starter Templates, Advanced Features and Customizer Settings for Responsive Theme <= 3.1.4 - Authenticated (Contributor+) Blind Server-Side Request Forgery via remote_request
- First reported
- Sources
- Wordfence, seen
Someone with an author account on your site could plant harmful code that runs for your visitors or admins
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 3.0.5
- Fixed in
- 3.0.6
- What to do
- If your site has an affected version, update Responsive Starter Templates to version 3.0.6 or newer.
- Official ID
- CVE-2024-5222
- Report title
- Responsive Addons – Starter Templates, Advanced Features and Customizer Settings for Responsive Theme. <= 3.0.5 - Authenticated (Author+) Stored Cross-Site Scripting
- First reported
- Sources
- Wordfence, seen
Someone could plant harmful code that runs for your visitors or admins (up to and including 2.6.8)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.6.8
- Fixed in
- 2.6.9
- What to do
- If your site has an affected version, update Responsive Starter Templates to version 2.6.9 or newer.
- Report title
- Responsive Starter Templates – Elementor & WordPress Templates <= 2.6.8 - Authenticated (Admin+) Stored Cross-Site Scripting
- First reported
- Sources
- Wordfence, seen
Someone could plant harmful code that runs for your visitors or admins (up to and including 2.6.8) (2)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.6.8
- Fixed in
- 2.6.9
- What to do
- If your site has an affected version, update Responsive Starter Templates to version 2.6.9 or newer.
- Report title
- Responsive Starter Templates – Elementor & WordPress Templates <= 2.6.8 - Authenticated (Admin+) Stored Cross-Site Scripting
- First reported
- Sources
- Wordfence, seen
Someone could use it to harm your site
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Before 2.2.6
- Fixed in
- 2.2.7
- What to do
- If your site has an affected version, update Responsive Starter Templates to version 2.2.7 or newer.
- Official ID
- CVE-2020-12073
- Report title
- Responsive Ready Sites Importer <= 2.2.6 - Unprotected AJAX Actions
- First reported
- Sources
- Wordfence, seen
Where this comes from
We collect these reports from public security sources and rewrite them in plain words. Each problem shows its sources and the date we first saw it. This page never says whether your own site is affected: only a check of your site’s versions can tell.
Get an email when your site is affected.
Install Watchfox AI once. It checks your plugins and themes against this list every day, for free.
Install Watchfox AI (free)