Social Sharing Plugin – Sassy Social Share: known security problems
12 known security problems reported for this WordPress plugin, with the affected versions, the fix and what to do.
Updated
In short
There are 12 known security problems on this page. 11 of them have a fixed version. Updating to version 3.3.76 or newer covers every fixed problem listed here.
Based on public reports. Check the plugin’s changelog. Watchfox AI may be wrong.
Get an email when your site is affected: install Watchfox AI (free)
A stranger could plant harmful code that runs for your visitors or admins
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 3.3.79
- Fixed in
- No fixed version yet
- What to do
- There is no fixed version yet. If your site uses it, think about turning it off or replacing it until a fix comes out.
- Official ID
- CVE-2026-94170
- Report title
- Social Sharing Plugin – Sassy Social Share <= 3.3.79 - Unauthenticated Stored Cross-Site Scripting
- First reported
- Sources
- Wordfence, seen
Someone could plant harmful code that runs for your visitors or admins (up to and including 3.3.75)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 3.3.75
- Fixed in
- 3.3.76
- What to do
- If your site has an affected version, update Social Sharing Plugin – Sassy Social Share to version 3.3.76 or newer.
- Official ID
- CVE-2025-5528
- Report title
- Social Sharing Plugin – Sassy Social Share <= 3.3.75 - Reflected Cross-Site Scripting via 'heateor_mastodon_share' Parameter
- First reported
- Sources
- Wordfence, seen
Someone could send your visitors from your site to a harmful site
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 3.3.73
- Fixed in
- 3.3.74
- What to do
- If your site has an affected version, update Social Sharing Plugin – Sassy Social Share to version 3.3.74 or newer.
- Official ID
- CVE-2025-39404
- Report title
- Sassy Social Share <= 3.3.73 - Open Redirect
- First reported
- Sources
- Wordfence, seen
Someone could plant harmful code that runs for your visitors or admins (up to and including 3.3.69)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 3.3.69
- Fixed in
- 3.3.70
- What to do
- If your site has an affected version, update Social Sharing Plugin – Sassy Social Share to version 3.3.70 or newer.
- Official ID
- CVE-2024-11252
- Report title
- Social Sharing Plugin – Sassy Social Share <= 3.3.69 - Reflected Cross-Site Scripting via heateor_mastodon_share Parameter
- First reported
- Sources
- Wordfence, seen
Someone who already has an admin account could plant harmful code that runs for your visitors or admins
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 3.3.62
- Fixed in
- 3.3.63
- What to do
- If your site has an affected version, update Social Sharing Plugin – Sassy Social Share to version 3.3.63 or newer.
- Official ID
- CVE-2024-4924
- Report title
- Sassy Social Share <= 3.3.62 - Authenticated (Administrator+) Stored Cross-Site Scripting
- First reported
- Sources
- Wordfence, seen
Someone with a contributor account on your site could plant harmful code that runs for your visitors or admins (up to and including 3.3.60)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 3.3.60
- Fixed in
- 3.3.61
- What to do
- If your site has an affected version, update Social Sharing Plugin – Sassy Social Share to version 3.3.61 or newer.
- Official ID
- CVE-2024-2159
- Report title
- Sassy Social Share <= 3.3.60 - Authenticated (Contributor+) Stored Cross-Site Scripting via Shortcode
- First reported
- Sources
- Wordfence, seen
Someone with a contributor account on your site could plant harmful code that runs for your visitors or admins (up to and including 3.3.58)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 3.3.58
- Fixed in
- 3.3.59
- What to do
- If your site has an affected version, update Social Sharing Plugin – Sassy Social Share to version 3.3.59 or newer.
- Official ID
- CVE-2024-1989
- Report title
- Social Sharing Plugin – Sassy Social Share <= 3.3.58 - Authenticated (Contributor+) Stored Cross-Site Scripting via Shortcode
- First reported
- Sources
- Wordfence, seen
Someone with a contributor account on your site could plant harmful code that runs for your visitors or admins (up to and including 3.3.56)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 3.3.56
- Fixed in
- 3.3.57
- What to do
- If your site has an affected version, update Social Sharing Plugin – Sassy Social Share to version 3.3.57 or newer.
- Official ID
- CVE-2024-1448
- Report title
- Sassy Social Share <= 3.3.56 - Authenticated (Contributor+) Stored Cross-Site Scripting
- First reported
- Sources
- Wordfence, seen
Someone with a contributor account on your site could plant harmful code that runs for your visitors or admins (up to and including 3.3.44)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 3.3.44
- Fixed in
- 3.3.45
- What to do
- If your site has an affected version, update Social Sharing Plugin – Sassy Social Share to version 3.3.45 or newer.
- Official ID
- CVE-2022-4451
- Report title
- Sassy Social Share <= 3.3.44 - Authenticated (Contributor+) Stored Cross-Site Scripting
- First reported
- Sources
- Wordfence, seen
Someone could plant harmful code that runs for your visitors or admins (up to and including 3.3.3)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 3.3.3
- Fixed in
- 3.3.4
- What to do
- If your site has an affected version, update Social Sharing Plugin – Sassy Social Share to version 3.3.4 or newer.
- Official ID
- CVE-2022-4971
- Report title
- Sassy Social Share <= 3.3.3 - Reflected Cross-Site Scripting
- First reported
- Sources
- Wordfence, seen
Someone could plant harmful code that runs for your visitors or admins (before 3.3.40)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Before 3.3.40
- Fixed in
- 3.3.40
- What to do
- If your site has an affected version, update Social Sharing Plugin – Sassy Social Share to version 3.3.40 or newer.
- Official ID
- CVE-2021-24746
- Report title
- Sassy Social Share <= 3.3.39 - Reflected Cross-Site Scripting
- First reported
- Sources
- Wordfence, seen
Someone could use it to harm your site
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- From 3.3.23 up to and including 3.3.23
- Fixed in
- 3.3.24
- What to do
- If your site has an affected version, update Social Sharing Plugin – Sassy Social Share to version 3.3.24 or newer.
- Official ID
- CVE-2021-39321
- Report title
- Sassy Social Share 3.3.23 - Object Injection
- First reported
- Sources
- Wordfence, seen
Where this comes from
We collect these reports from public security sources and rewrite them in plain words. Each problem shows its sources and the date we first saw it. This page never says whether your own site is affected: only a check of your site’s versions can tell.
Get an email when your site is affected.
Install Watchfox AI once. It checks your plugins and themes against this list every day, for free.
Install Watchfox AI (free)