ShopEngine – All-in-One Elementor WooCommerce Builder with eCommerce Templates & Woo Widgets: known security problems
7 known security problems reported for this WordPress plugin, with the affected versions, the fix and what to do.
Updated
In short
There are 7 known security problems on this page. Each one has a fixed version. Updating to version 4.9.6 or newer covers every fixed problem listed here.
Based on public reports. Check the plugin’s changelog. Watchfox AI may be wrong.
Get an email when your site is affected: install Watchfox AI (free)
Someone with a contributor account on your site could plant harmful code that runs for your visitors or admins
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 4.9.5
- Fixed in
- 4.9.6
- What to do
- If your site has an affected version, update ShopEngine – All-in-One Elementor WooCommerce Builder with eCommerce Templates & Woo Widgets to version 4.9.6 or newer.
- Official ID
- CVE-2026-85575
- Report title
- The ShopEngine Elementor WooCommerce Builder Addon – All in One WooCommerce Solution with eCommerce Templates & Woo Widgets <= 4.9.5 - Authenticated (Contributor+) Stored Cross-Site Scripting via 'shopengine_product_title_header_size' Parameter
- First reported
- Sources
- Wordfence, seen
Someone with a shop manager account on your site could take over your site as an admin
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 4.9.4
- Fixed in
- 4.9.5
- What to do
- If your site has an affected version, update ShopEngine – All-in-One Elementor WooCommerce Builder with eCommerce Templates & Woo Widgets to version 4.9.5 or newer.
- Official ID
- CVE-2026-75971
- Report title
- ShopEngine Elementor WooCommerce Builder Addon <= 4.9.4 - Authenticated (Shop Manager+) Privilege Escalation to WXR Import '<wp_option>' Nodes
- First reported
- Sources
- Wordfence, seen
Someone could trick a logged-in admin into changing settings without knowing (up to and including 4.9.2)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 4.9.2
- Fixed in
- 4.9.3
- What to do
- If your site has an affected version, update ShopEngine – All-in-One Elementor WooCommerce Builder with eCommerce Templates & Woo Widgets to version 4.9.3 or newer.
- Official ID
- CVE-2026-19088
- Report title
- ShopEngine <= 4.9.2 - Cross-Site Request Forgery
- First reported
- Sources
- Wordfence, seen
Someone could trick a logged-in admin into changing settings without knowing (up to and including 4.8.5)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 4.8.5
- Fixed in
- 4.8.6
- What to do
- If your site has an affected version, update ShopEngine – All-in-One Elementor WooCommerce Builder with eCommerce Templates & Woo Widgets to version 4.8.6 or newer.
- Official ID
- CVE-2025-12358
- Report title
- ShopEngine <= 4.8.5 - Cross-Site Request Forgery to Wishlist Manipulation
- First reported
- Sources
- Wordfence, seen
Someone with an editor account on your site could use it to harm your site (up to and including 4.8.4)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 4.8.4
- Fixed in
- 4.8.5
- What to do
- If your site has an affected version, update ShopEngine – All-in-One Elementor WooCommerce Builder with eCommerce Templates & Woo Widgets to version 4.8.5 or newer.
- Official ID
- CVE-2025-11888
- Report title
- ShopEngine Elementor WooCommerce Builder Addon – All in One WooCommerce Solution <= 4.8.4 - Incorrect Authorization to Authenticated (Editor+) License Status Update
- First reported
- Sources
- Wordfence, seen
Someone with an editor account on your site could use it to harm your site (up to and including 4.8.3)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 4.8.3
- Fixed in
- 4.8.4
- What to do
- If your site has an affected version, update ShopEngine – All-in-One Elementor WooCommerce Builder with eCommerce Templates & Woo Widgets to version 4.8.4 or newer.
- Official ID
- CVE-2025-10173
- Report title
- ShopEngine Elementor WooCommerce Builder Addon – All in One WooCommerce Solution <= 4.8.3 - Insufficient Authorization to Authenticated (Editor+) Settings Update
- First reported
- Sources
- Wordfence, seen
Someone could trick a logged-in admin into changing settings without knowing (up to and including 4.1.1)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 4.1.1
- Fixed in
- 4.1.2
- What to do
- If your site has an affected version, update ShopEngine – All-in-One Elementor WooCommerce Builder with eCommerce Templates & Woo Widgets to version 4.1.2 or newer.
- Official ID
- CVE-2022-45371
- Report title
- ShopEngine <= 4.1.1 - Cross-Site Request Forgery via get_product
- First reported
- Sources
- Wordfence, seen
Where this comes from
We collect these reports from public security sources and rewrite them in plain words. Each problem shows its sources and the date we first saw it. This page never says whether your own site is affected: only a check of your site’s versions can tell.
Get an email when your site is affected.
Install Watchfox AI once. It checks your plugins and themes against this list every day, for free.
Install Watchfox AI (free)