Simple Job Board: known security problems
13 known security problems reported for this WordPress plugin, with the affected versions, the fix and what to do.
Updated
In short
There are 13 known security problems on this page. Each one has a fixed version. Updating to version 2.13.8 or newer covers every fixed problem listed here.
Based on public reports. Check the plugin’s changelog. Watchfox AI may be wrong.
Get an email when your site is affected: install Watchfox AI (free)
A stranger could see private information they should not see
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.13.7
- Fixed in
- 2.13.8
- What to do
- If your site has an affected version, update Simple Job Board to version 2.13.8 or newer.
- Official ID
- CVE-2025-59579
- Report title
- Simple Job Board <= 2.13.7 - Unauthenticated Sensitive Information Exposure
- First reported
- Sources
- Wordfence, seen
A stranger could use it to harm your site
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.12.5
- Fixed in
- 2.12.16
- What to do
- If your site has an affected version, update Simple Job Board to version 2.12.16 or newer.
- Official ID
- CVE-2024-7762
- Report title
- Simple Job Board <= 2.12.5 - Unauthenticated Resumes Download
- First reported
- Sources
- Wordfence, seen
Someone with an editor account on your site could in some setups, take over your site
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.12.3
- Fixed in
- 2.12.4
- What to do
- If your site has an affected version, update Simple Job Board to version 2.12.4 or newer.
- Official ID
- CVE-2024-7351
- Report title
- Simple Job Board <= 2.12.3 - Authenticated (Editor+) PHP Object Injection
- First reported
- Sources
- Wordfence, seen
Someone who already has an admin account could plant harmful code that runs for your visitors or admins
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.12.1
- Fixed in
- 2.12.2
- What to do
- If your site has an affected version, update Simple Job Board to version 2.12.2 or newer.
- Official ID
- CVE-2024-7761
- Report title
- Simple Job Board <= 2.12.1 - Authenticated (Administrator+) Stored Cross-Site Scripting
- First reported
- Sources
- Wordfence, seen
A stranger could in some setups, take over your site
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.11.0
- Fixed in
- 2.11.1
- What to do
- If your site has an affected version, update Simple Job Board to version 2.11.1 or newer.
- Official ID
- CVE-2024-1813
- Report title
- Simple Job Board <= 2.11.0 - Unauthenticated PHP Object Injection via Job Application Fields
- First reported
- Sources
- Wordfence, seen
A stranger could do things on your site they should not be allowed to
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.10.8
- Fixed in
- 2.11.0
- What to do
- If your site has an affected version, update Simple Job Board to version 2.11.0 or newer.
- Official ID
- CVE-2024-0593
- Report title
- Simple Job Board <= 2.10.8 - Missing Authorization to Unauthenticated Information Disclosure
- First reported
- Sources
- Wordfence, seen
Someone could trick a logged-in admin into changing settings without knowing (up to and including 2.10.6)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.10.6
- Fixed in
- 2.10.7
- What to do
- If your site has an affected version, update Simple Job Board to version 2.10.7 or newer.
- Official ID
- CVE-2023-52122
- Report title
- Simple Job Board <= 2.10.6 - Cross-Site Request Forgery
- First reported
- Sources
- Wordfence, seen
Someone could do things on your site they should not be allowed to
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.10.5
- Fixed in
- 2.10.6
- What to do
- If your site has an affected version, update Simple Job Board to version 2.10.6 or newer.
- Official ID
- CVE-2023-47188
- Report title
- Simple Job Board <= 2.10.5 - Missing Authorization
- First reported
- Sources
- Wordfence, seen
Someone could trick a logged-in admin into changing settings without knowing (up to and including 2.10.3)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.10.3
- Fixed in
- 2.10.4
- What to do
- If your site has an affected version, update Simple Job Board to version 2.10.4 or newer.
- Official ID
- CVE-2023-29440
- Report title
- Simple Job Board <= 2.10.3 - Cross-Site Request Forgery via sjb_save_settings_section
- First reported
- Sources
- Wordfence, seen
Someone could use it to harm your site
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.9.6
- Fixed in
- 2.9.10
- What to do
- If your site has an affected version, update Simple Job Board to version 2.9.10 or newer.
- Official ID
- CVE-2022-2558
- Report title
- Simple Job Board <= 2.9.6 - Information Disclosure
- First reported
- Sources
- Wordfence, seen
Someone could read or delete private files on your server
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.9.3
- Fixed in
- 2.9.4
- What to do
- If your site has an affected version, update Simple Job Board to version 2.9.4 or newer.
- Official ID
- CVE-2020-35749
- Report title
- Simple Job Board <= 2.9.3 - Local File Inclusion
- First reported
- Sources
- Wordfence, seen
Someone could plant harmful code that runs for your visitors or admins (up to and including 2.9.4)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.9.4
- Fixed in
- 2.9.5
- What to do
- If your site has an affected version, update Simple Job Board to version 2.9.5 or newer.
- Official ID
- CVE-2021-39328
- Report title
- Simple Job Board <= 2.9.4 Authenticated Stored Cross-Site Scripting
- First reported
- Sources
- Wordfence, seen
Someone could plant harmful code that runs for your visitors or admins (before 2.4.4)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Before 2.4.4
- Fixed in
- 2.4.4
- What to do
- If your site has an affected version, update Simple Job Board to version 2.4.4 or newer.
- Official ID
- CVE-2017-18498
- Report title
- Simple Job Board <= 2.4.4 - Reflected Cross-Site Scripting
- First reported
- Sources
- Wordfence, seen
Where this comes from
We collect these reports from public security sources and rewrite them in plain words. Each problem shows its sources and the date we first saw it. This page never says whether your own site is affected: only a check of your site’s versions can tell.
Get an email when your site is affected.
Install Watchfox AI once. It checks your plugins and themes against this list every day, for free.
Install Watchfox AI (free)