Page Builder by SiteOrigin: known security problems
12 known security problems reported for this WordPress plugin, with the affected versions, the fix and what to do.
Updated
In short
There are 12 known security problems on this page. Each one has a fixed version. Updating to version 2.38.0 or newer covers every fixed problem listed here.
Based on public reports. Check the plugin’s changelog. Watchfox AI may be wrong.
Get an email when your site is affected: install Watchfox AI (free)
Someone with a contributor account on your site could plant harmful code that runs for your visitors or admins (before 2.38.0)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Before 2.38.0
- Fixed in
- 2.38.0
- What to do
- If your site has an affected version, update Page Builder by SiteOrigin to version 2.38.0 or newer.
- Official ID
- CVE-2026-110506
- Report title
- Page Builder by SiteOrigin < 2.38.0 - Authenticated (Contributor+) Stored Cross-Site Scripting
- First reported
- Sources
- Wordfence, seen
Someone with a contributor account on your site could use it to harm your site
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Before 2.38.0
- Fixed in
- 2.38.0
- What to do
- If your site has an affected version, update Page Builder by SiteOrigin to version 2.38.0 or newer.
- Official ID
- CVE-2026-110507
- Report title
- Page Builder by SiteOrigin < 2.38.0 - Authenticated (Contributor+) Information Exposure
- First reported
- Sources
- Wordfence, seen
Someone with an editor account on your site could in some setups, take over your site
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.36.0
- Fixed in
- 2.36.1
- What to do
- If your site has an affected version, update Page Builder by SiteOrigin to version 2.36.1 or newer.
- Official ID
- CVE-2026-97256
- Report title
- Page Builder by SiteOrigin <= 2.36.0 - Authenticated (Editor+) PHP Object Injection
- First reported
- Sources
- Wordfence, seen
Someone with a contributor account on your site could plant harmful code that runs for your visitors or admins (up to and including 2.34.3)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.34.3
- Fixed in
- 2.34.4
- What to do
- If your site has an affected version, update Page Builder by SiteOrigin to version 2.34.4 or newer.
- Official ID
- CVE-2026-13295
- Report title
- Page Builder by SiteOrigin <= 2.34.3 - Authenticated (Contributor+) Stored Cross-Site Scripting via panels_data Parameter
- First reported
- Sources
- Wordfence, seen
Someone with a contributor account on your site could read or delete private files on your server
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.33.5
- Fixed in
- 2.34.0
- What to do
- If your site has an affected version, update Page Builder by SiteOrigin to version 2.34.0 or newer.
- Official ID
- CVE-2026-2448
- Report title
- Page Builder by SiteOrigin <= 2.33.5 - Authenticated (Contributor+) Local File Inclusion
- First reported
- Sources
- Wordfence, seen
Someone with a contributor account on your site could plant harmful code that runs for your visitors or admins (up to and including 2.31.4)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.31.4
- Fixed in
- 2.31.5
- What to do
- If your site has an affected version, update Page Builder by SiteOrigin to version 2.31.5 or newer.
- Official ID
- CVE-2025-1459
- Report title
- Page Builder by SiteOrigin <= 2.31.4 - Authenticated (Contributor+) Stored Cross-Site Scripting
- First reported
- Sources
- Wordfence, seen
Someone with a contributor account on your site could plant harmful code that runs for your visitors or admins (up to and including 2.31.0)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.31.0
- Fixed in
- 2.31.1
- What to do
- If your site has an affected version, update Page Builder by SiteOrigin to version 2.31.1 or newer.
- Official ID
- CVE-2024-12240
- Report title
- Page Builder by SiteOrigin <= 2.31.0 - Authenticated (Contributor+) Stored Cross-Site Scripting via Row Label Parameter
- First reported
- Sources
- Wordfence, seen
Someone with a contributor account on your site could plant harmful code that runs for your visitors or admins (up to and including 2.29.15)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.29.15
- Fixed in
- 2.29.16
- What to do
- If your site has an affected version, update Page Builder by SiteOrigin to version 2.29.16 or newer.
- Official ID
- CVE-2024-4361
- Report title
- Page Builder by SiteOrigin <= 2.29.15 - Authenticated (Contributor+) Stored Cross-Site Scripting via 'siteorigin_widget' Shortcode
- First reported
- Sources
- Wordfence, seen
Someone with a contributor account on your site could plant harmful code that runs for your visitors or admins (up to and including 2.29.6)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.29.6
- Fixed in
- 2.29.7
- What to do
- If your site has an affected version, update Page Builder by SiteOrigin to version 2.29.7 or newer.
- Official ID
- CVE-2024-2202
- Report title
- Page Builder by SiteOrigin <= 2.29.6 - Authenticated (Contributor+) Stored Cross-Site Scripting via Legacy Image Widget
- First reported
- Sources
- Wordfence, seen
Someone could plant harmful code that runs for your visitors or admins (before 2.10.16)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Before 2.10.16
- Fixed in
- 2.10.16
- What to do
- If your site has an affected version, update Page Builder by SiteOrigin to version 2.10.16 or newer.
- Official ID
- CVE-2020-13643
- Report title
- Page Builder by SiteOrigin <= 2.10.15 - Cross-Site Request Forgery to Reflected Cross-Site Scripting
- First reported
- Sources
- Wordfence, seen
Someone could plant harmful code that runs for your visitors or admins (up to and including 2.10.15)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.10.15
- Fixed in
- 2.10.16
- What to do
- If your site has an affected version, update Page Builder by SiteOrigin to version 2.10.16 or newer.
- Official ID
- CVE-2020-13642
- Report title
- Page Builder by SiteOrigin <= 2.10.15 - Cross-Site Request Forgery to Reflected Cross-Site Scripting
- First reported
- Sources
- Wordfence, seen
Someone could plant harmful code that runs for your visitors or admins (before 2.0.5)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Before 2.0.5
- Fixed in
- 2.0.5
- What to do
- If your site has an affected version, update Page Builder by SiteOrigin to version 2.0.5 or newer.
- Report title
- Page Builder by SiteOrigin < 2.0.5 - Reflected Cross-Site Scripting
- First reported
- Sources
- Wordfence, seen
Where this comes from
We collect these reports from public security sources and rewrite them in plain words. Each problem shows its sources and the date we first saw it. This page never says whether your own site is affected: only a check of your site’s versions can tell.
Get an email when your site is affected.
Install Watchfox AI once. It checks your plugins and themes against this list every day, for free.
Install Watchfox AI (free)