Affiliate Program Suite: known security problems
8 known security problems reported for this WordPress plugin, with the affected versions, the fix and what to do.
Updated
In short
There are 8 known security problems on this page. Each one has a fixed version. Updating to version 1.2.11 or newer covers every fixed problem listed here.
Based on public reports. Check the plugin’s changelog. Watchfox AI may be wrong.
Get an email when your site is affected: install Watchfox AI (free)
A stranger could plant harmful code that runs for your visitors or admins (up to and including 1.2.10)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 1.2.10
- Fixed in
- 1.2.11
- What to do
- If your site has an affected version, update Affiliate Program Suite to version 1.2.11 or newer.
- Official ID
- CVE-2026-82224
- Report title
- Affiliate Program Suite — SliceWP Affiliates <= 1.2.10 - Unauthenticated Stored Cross-Site Scripting
- First reported
- Sources
- Wordfence, seen
A stranger could plant harmful code that runs for your visitors or admins (up to and including 1.2.6)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 1.2.6
- Fixed in
- 1.2.7
- What to do
- If your site has an affected version, update Affiliate Program Suite to version 1.2.7 or newer.
- Official ID
- CVE-2026-42653
- Report title
- Affiliate Program Suite — SliceWP Affiliates <= 1.2.6 - Unauthenticated Stored Cross-Site Scripting
- First reported
- Sources
- Wordfence, seen
Someone with a contributor account on your site could plant harmful code that runs for your visitors or admins
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 1.2.7
- Fixed in
- 1.2.8
- What to do
- If your site has an affected version, update Affiliate Program Suite to version 1.2.8 or newer.
- Official ID
- CVE-2026-6672
- Report title
- Affiliate Program Suite <= 1.2.7 - Authenticated (Contributor+) Stored Cross-Site Scripting via slicewp_affiliate_url Shortcode
- First reported
- Sources
- Wordfence, seen
Someone could plant harmful code that runs for your visitors or admins (up to and including 1.1.23)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 1.1.23
- Fixed in
- 1.1.24
- What to do
- If your site has an affected version, update Affiliate Program Suite to version 1.1.24 or newer.
- Official ID
- CVE-2024-12454
- Report title
- Affiliate Program Suite — SliceWP Affiliates <= 1.1.23 - Cross-Site Request Forgery to Reflected Cross-Site Scripting
- First reported
- Sources
- Wordfence, seen
Someone could plant harmful code that runs for your visitors or admins (up to and including 1.1.18)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 1.1.18
- Fixed in
- 1.1.19
- What to do
- If your site has an affected version, update Affiliate Program Suite to version 1.1.19 or newer.
- Official ID
- CVE-2024-47388
- Report title
- SliceWP <= 1.1.18 - Reflected Cross-Site Scripting
- First reported
- Sources
- Wordfence, seen
Someone could plant harmful code that runs for your visitors or admins (up to and including 1.1.20)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 1.1.20
- Fixed in
- 1.1.21
- What to do
- If your site has an affected version, update Affiliate Program Suite to version 1.1.21 or newer.
- Official ID
- CVE-2024-8714
- Report title
- WordPress Affiliates Plugin — SliceWP Affiliates <= 1.1.20 - Reflected Cross-Site Scripting
- First reported
- Sources
- Wordfence, seen
Someone could plant harmful code that runs for your visitors or admins (up to and including 1.1.10)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 1.1.10
- Fixed in
- 1.1.11
- What to do
- If your site has an affected version, update Affiliate Program Suite to version 1.1.11 or newer.
- Official ID
- CVE-2024-34413
- Report title
- WordPress Affiliates Plugin — SliceWP Affiliates <= 1.1.10 - Authenticated (Admin+) Stored Cross-Site Scripting
- First reported
- Sources
- Wordfence, seen
Someone could plant harmful code that runs for your visitors or admins (up to and including 1.0.45)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 1.0.45
- Fixed in
- 1.0.46
- What to do
- If your site has an affected version, update Affiliate Program Suite to version 1.0.46 or newer.
- Report title
- WordPress Affiliates Plugin — SliceWP Affiliates <= 1.0.45 - Cross-Site Scripting
- First reported
- Sources
- Wordfence, seen
Where this comes from
We collect these reports from public security sources and rewrite them in plain words. Each problem shows its sources and the date we first saw it. This page never says whether your own site is affected: only a check of your site’s versions can tell.
Get an email when your site is affected.
Install Watchfox AI once. It checks your plugins and themes against this list every day, for free.
Install Watchfox AI (free)