EN ES
Start free

Stackable – Page Builder Gutenberg Blocks: known security problems

9 known security problems reported for this WordPress plugin, with the affected versions, the fix and what to do.

Updated

In short

There are 9 known security problems on this page. Each one has a fixed version. Updating to version 3.19.6 or newer covers every fixed problem listed here.

Based on public reports. Check the plugin’s changelog. Watchfox AI may be wrong.

Get an email when your site is affected: install Watchfox AI (free)

This week

Someone with an author account on your site could plant harmful code that runs for your visitors or admins

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 3.19.5
Fixed in
3.19.6
What to do
If your site has an affected version, update Stackable – Page Builder Gutenberg Blocks to version 3.19.6 or newer.
Official ID
CVE-2025-47500
Report title
Stackable <= 3.19.5 - Authenticated (Author+) Stored Cross-Site Scripting
First reported
Sources
This week

Someone with a contributor account on your site could see private information they should not see

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 3.18.1
Fixed in
3.19.0
What to do
If your site has an affected version, update Stackable – Page Builder Gutenberg Blocks to version 3.19.0 or newer.
Official ID
CVE-2025-60095
Report title
Stackable <= 3.18.1 - Authenticated (Contributor+) Sensitive Information Exposure
First reported
Sources
This week

Someone could do things on your site they should not be allowed to (up to and including 3.18.1)

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 3.18.1
Fixed in
3.19.0
What to do
If your site has an affected version, update Stackable – Page Builder Gutenberg Blocks to version 3.19.0 or newer.
Official ID
CVE-2025-60094
Report title
Stackable <= 3.18.1 - Missing Authorization
First reported
Sources
This week

Someone with a contributor account on your site could plant harmful code that runs for your visitors or admins (up to and including 3.13.11)

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 3.13.11
Fixed in
3.13.12
What to do
If your site has an affected version, update Stackable – Page Builder Gutenberg Blocks to version 3.13.12 or newer.
Official ID
CVE-2024-12117
Report title
Stackable – Page Builder Gutenberg Blocks <= 3.13.11 - Authenticated (Contributor+) Stored Cross-Site Scripting
First reported
Sources
This week

A stranger could use it to harm your site

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 3.13.6
Fixed in
3.13.7
What to do
If your site has an affected version, update Stackable – Page Builder Gutenberg Blocks to version 3.13.7 or newer.
Official ID
CVE-2024-8760
Report title
Stackable – Page Builder Gutenberg Blocks <= 3.13.6 - Unauthenticated CSS Injection
First reported
Sources
This week

Someone with a contributor account on your site could plant harmful code that runs for your visitors or admins (up to and including 3.13.1)

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 3.13.1
Fixed in
3.13.2
What to do
If your site has an affected version, update Stackable – Page Builder Gutenberg Blocks to version 3.13.2 or newer.
Official ID
CVE-2024-6296
Report title
Stackable – Page Builder Gutenberg Blocks <= 3.13.1 - Authenticated (Contributor+) DOM-Based Stored Cross-Site Scripting
First reported
Sources
This week

Someone with a contributor account on your site could plant harmful code that runs for your visitors or admins (up to and including 3.12.11)

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 3.12.11
Fixed in
3.12.12
What to do
If your site has an affected version, update Stackable – Page Builder Gutenberg Blocks to version 3.12.12 or newer.
Official ID
CVE-2024-2039
Report title
Stackable – Page Builder Gutenberg Blocks <= 3.12.11 - Authenticated(Contributor+) Stored Cross-Site Scripting via Posts Block
First reported
Sources
This week

Someone could plant harmful code that runs for your visitors or admins

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • From 0.1 up to and including 3.9.0
Fixed in
3.9.1
What to do
If your site has an affected version, update Stackable – Page Builder Gutenberg Blocks to version 3.9.1 or newer.
Official ID
CVE-2023-33999
Report title
Freemius SDK <= 2.5.9 - Reflected Cross-Site Scripting via fs_request_get
First reported
Sources
This week

Someone could do things on your site they should not be allowed to (before 3.1.5)

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Before 3.1.5
Fixed in
3.1.5
What to do
If your site has an affected version, update Stackable – Page Builder Gutenberg Blocks to version 3.1.5 or newer.
Official ID
CVE-2022-4974
Report title
Freemius SDK <= 2.4.2 - Missing Authorization Checks
First reported
Sources

Where this comes from

We collect these reports from public security sources and rewrite them in plain words. Each problem shows its sources and the date we first saw it. This page never says whether your own site is affected: only a check of your site’s versions can tell.

All plugins and themes

Get an email when your site is affected.

Install Watchfox AI once. It checks your plugins and themes against this list every day, for free.

Install Watchfox AI (free)