EN ES
Start free

Stratum Widgets for Elementor: known security problems

6 known security problems reported for this WordPress plugin, with the affected versions, the fix and what to do.

Updated

In short

There are 6 known security problems on this page. Each one has a fixed version. Updating to version 1.6.2 or newer covers every fixed problem listed here.

Based on public reports. Check the plugin’s changelog. Watchfox AI may be wrong.

Get an email when your site is affected: install Watchfox AI (free)

This week

Someone could do things on your site they should not be allowed to

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 1.6.1
Fixed in
1.6.2
What to do
If your site has an affected version, update Stratum Widgets for Elementor to version 1.6.2 or newer.
Official ID
CVE-2025-69013
Report title
Stratum Widgets for Elementor <= 1.6.1 - Missing Authorization
First reported
Sources
This week

Someone with a contributor account on your site could plant harmful code that runs for your visitors or admins (up to and including 1.6.0)

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 1.6.0
Fixed in
1.6.1
What to do
If your site has an affected version, update Stratum Widgets for Elementor to version 1.6.1 or newer.
Official ID
CVE-2025-7845
Report title
Stratum – Elementor Widgets <= 1.6.0 - Authenticated (Contributor+) Stored Cross-Site Scripting via Advanced Google Maps and Image Hotspot Widgets
First reported
Sources
This week

Someone with a contributor account on your site could plant harmful code that runs for your visitors or admins (up to and including 1.4.7)

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 1.4.7
Fixed in
1.5.0
What to do
If your site has an affected version, update Stratum Widgets for Elementor to version 1.5.0 or newer.
Official ID
CVE-2024-13642
Report title
Stratum – Elementor Widgets <= 1.4.7 - Authenticated (Contributor+) Stored Cross-Site Scripting Vulnerability via Image Hotspot Widget
First reported
Sources
This week

Someone with a contributor account on your site could see private information they should not see

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 1.4.4
Fixed in
1.4.5
What to do
If your site has an affected version, update Stratum Widgets for Elementor to version 1.4.5 or newer.
Official ID
CVE-2024-10316
Report title
Stratum – Elementor Widgets <= 1.4.4 - Authenticated (Contributor+) Sensitive Information Exposure via Elementor Templates
First reported
Sources
This week

Someone with a contributor account on your site could plant harmful code that runs for your visitors or admins (up to and including 1.4.1)

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 1.4.1
Fixed in
1.4.2
What to do
If your site has an affected version, update Stratum Widgets for Elementor to version 1.4.2 or newer.
Official ID
CVE-2024-5611
Report title
Stratum – Elementor Widgets <= 1.4.1 - Authenticated (Contributor+) Stored Cross-Site Scripting via Countdown Widget
First reported
Sources
This week

Someone with a contributor account on your site could plant harmful code that runs for your visitors or admins (up to and including 1.3.15)

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 1.3.15
Fixed in
1.3.16
What to do
If your site has an affected version, update Stratum Widgets for Elementor to version 1.3.16 or newer.
Official ID
CVE-2024-29914
Report title
Stratum <= 1.3.15 - Authenticated (Contributor+) Stored Cross-Site Scripting
First reported
Sources

Where this comes from

We collect these reports from public security sources and rewrite them in plain words. Each problem shows its sources and the date we first saw it. This page never says whether your own site is affected: only a check of your site’s versions can tell.

All plugins and themes

Get an email when your site is affected.

Install Watchfox AI once. It checks your plugins and themes against this list every day, for free.

Install Watchfox AI (free)