Structured Content (JSON-LD) #wpsc: known security problems
10 known security problems reported for this WordPress plugin, with the affected versions, the fix and what to do.
Updated
In short
There are 10 known security problems on this page. 9 of them have a fixed version. Updating to version 1.7.0 or newer covers every fixed problem listed here.
Based on public reports. Check the plugin’s changelog. Watchfox AI may be wrong.
Get an email when your site is affected: install Watchfox AI (free)
Someone with a contributor account on your site could plant harmful code that runs for your visitors or admins (up to and including 1.7.0)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 1.7.0
- Fixed in
- No fixed version yet
- What to do
- There is no fixed version yet. If your site uses it, think about turning it off or replacing it until a fix comes out.
- Official ID
- CVE-2026-57763
- Report title
- Structured Content (JSON-LD) #wpsc <= 1.7.0 - Authenticated (Contributor+) Stored Cross-Site Scripting
- First reported
- Sources
- Wordfence, seen
Someone with a contributor account on your site could plant harmful code that runs for your visitors or admins (up to and including 1.6.4)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 1.6.4
- Fixed in
- 1.7.0
- What to do
- If your site has an affected version, update Structured Content (JSON-LD) #wpsc to version 1.7.0 or newer.
- Official ID
- CVE-2025-3414
- Report title
- Structured Content (JSON-LD) #wpsc <= 1.6.4 - Authenticated (Contributor+) Stored Cross-Site Scripting via FAQ Block
- First reported
- Sources
- Wordfence, seen
Someone with a contributor account on your site could plant harmful code that runs for your visitors or admins (up to and including 1.6.4) (2)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 1.6.4
- Fixed in
- 1.7.0
- What to do
- If your site has an affected version, update Structured Content (JSON-LD) #wpsc to version 1.7.0 or newer.
- Official ID
- CVE-2025-4608
- Report title
- Structured Content <= 1.6.4 - Authenticated (Contributor+) Stored Cross-Site Scripting via sc_fs_local_business Shortcode
- First reported
- Sources
- Wordfence, seen
Someone with a contributor account on your site could plant harmful code that runs for your visitors or admins (up to and including 1.6.3)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 1.6.3
- Fixed in
- 1.6.4
- What to do
- If your site has an affected version, update Structured Content (JSON-LD) #wpsc to version 1.6.4 or newer.
- Official ID
- CVE-2025-30918
- Report title
- Structured Content <= 1.6.3 - Authenticated (Contributor+) Stored Cross-Site Scripting
- First reported
- Sources
- Wordfence, seen
Someone with a contributor account on your site could plant harmful code that runs for your visitors or admins (up to and including 1.6.3) (2)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 1.6.3
- Fixed in
- 1.6.4
- What to do
- If your site has an affected version, update Structured Content (JSON-LD) #wpsc to version 1.6.4 or newer.
- Official ID
- CVE-2025-0512
- Report title
- Structured Content (JSON-LD) #wpsc <= 1.6.3 - Authenticated (Contributor+) Stored Cross-Site Scripting via sc_fs_local_business Shortcode
- First reported
- Sources
- Wordfence, seen
Someone with a contributor account on your site could plant harmful code that runs for your visitors or admins (up to and including 1.6.2)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 1.6.2
- Fixed in
- 1.6.3
- What to do
- If your site has an affected version, update Structured Content (JSON-LD) #wpsc to version 1.6.3 or newer.
- Official ID
- CVE-2024-43307
- Report title
- Structured Content <= 1.6.2 - Authenticated (Contributor+) Stored Cross-Site Scripting
- First reported
- Sources
- Wordfence, seen
Someone with a contributor account on your site could plant harmful code that runs for your visitors or admins (up to and including 1.6.1)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 1.6.1
- Fixed in
- 1.6.2
- What to do
- If your site has an affected version, update Structured Content (JSON-LD) #wpsc to version 1.6.2 or newer.
- Official ID
- CVE-2024-24839
- Report title
- Structured Content <= 1.6.1 - Authenticated (Contributor+) Stored Cross-Site Scripting via Classic Editor Shortcode
- First reported
- Sources
- Wordfence, seen
Someone with a contributor account on your site could in some setups, take over your site
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 1.5.3
- Fixed in
- 1.6.0
- What to do
- If your site has an affected version, update Structured Content (JSON-LD) #wpsc to version 1.6.0 or newer.
- Official ID
- CVE-2023-49819
- Report title
- Structured Content <= 1.5.3 - Authenticated (Contributor+) PHP Object Injection
- First reported
- Sources
- Wordfence, seen
Someone with a contributor account on your site could plant harmful code that runs for your visitors or admins (up to and including 1.5.3)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 1.5.3
- Fixed in
- 1.6.0
- What to do
- If your site has an affected version, update Structured Content (JSON-LD) #wpsc to version 1.6.0 or newer.
- Official ID
- CVE-2023-49820
- Report title
- Structured Content <= 1.5.3 - Authenticated (Contributor+) Stored Cross-Site Scripting
- First reported
- Sources
- Wordfence, seen
Someone with a contributor account on your site could plant harmful code that runs for your visitors or admins (up to and including 1.5.0)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 1.5.0
- Fixed in
- 1.5.1
- What to do
- If your site has an affected version, update Structured Content (JSON-LD) #wpsc to version 1.5.1 or newer.
- Official ID
- CVE-2022-4715
- Report title
- Structured Content <= 1.5.0 - Authenticated (Contributor+) Stored Cross-Site Scripting via Shortcode
- First reported
- Sources
- Wordfence, seen
Where this comes from
We collect these reports from public security sources and rewrite them in plain words. Each problem shows its sources and the date we first saw it. This page never says whether your own site is affected: only a check of your site’s versions can tell.
Get an email when your site is affected.
Install Watchfox AI once. It checks your plugins and themes against this list every day, for free.
Install Watchfox AI (free)