WebberZone Top 10 — Popular Posts: known security problems
11 known security problems reported for this WordPress plugin, with the affected versions, the fix and what to do.
Updated
In short
There are 11 known security problems on this page. Each one has a fixed version. Updating to version 4.5.3 or newer covers every fixed problem listed here.
Based on public reports. Check the plugin’s changelog. Watchfox AI may be wrong.
Get an email when your site is affected: install Watchfox AI (free)
Someone with a contributor account on your site could plant harmful code that runs for your visitors or admins (up to and including 4.5.2)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 4.5.2
- Fixed in
- 4.5.3
- What to do
- If your site has an affected version, update WebberZone Top 10 — Popular Posts to version 4.5.3 or newer.
- Official ID
- CVE-2026-110290
- Report title
- WebberZone Top 10 <= 4.5.2 - Authenticated (Contributor+) Stored Cross-Site Scripting via 'other_attributes' Block Attribute
- First reported
- Sources
- Wordfence, seen
Someone with a contributor account on your site could plant harmful code that runs for your visitors or admins (up to and including 4.1.0)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 4.1.0
- Fixed in
- 4.1.1
- What to do
- If your site has an affected version, update WebberZone Top 10 — Popular Posts to version 4.1.1 or newer.
- Official ID
- CVE-2025-47509
- Report title
- Top 10 <= 4.1.0 - Authenticated (Contributor+) Stored Cross-Site Scripting
- First reported
- Sources
- Wordfence, seen
Someone could trick a logged-in admin into changing settings without knowing (up to and including 3.3.2)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 3.3.2
- Fixed in
- 3.3.3
- What to do
- If your site has an affected version, update WebberZone Top 10 — Popular Posts to version 3.3.3 or newer.
- Official ID
- CVE-2023-47238
- Report title
- Top 10 <= 3.3.2 - Cross-Site Request Forgery via edit_count_ajax
- First reported
- Sources
- Wordfence, seen
Someone could do things on your site they should not be allowed to (up to and including 3.2.4)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 3.2.4
- Fixed in
- 3.2.5
- What to do
- If your site has an affected version, update WebberZone Top 10 — Popular Posts to version 3.2.5 or newer.
- Report title
- Top 10 – Popular posts plugin for WordPress <= 3.2.4 - Missing Authorization on tptn_chart_data
- First reported
- Sources
- Wordfence, seen
Someone could plant harmful code that runs for your visitors or admins (up to and including 3.2.4)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 3.2.4
- Fixed in
- 3.2.5
- What to do
- If your site has an affected version, update WebberZone Top 10 — Popular Posts to version 3.2.5 or newer.
- Official ID
- CVE-2023-26008
- Report title
- Top 10 – Popular posts plugin - <= 3.2.4 - Authenticated(Admin+) Stored Cross-Site Scripting
- First reported
- Sources
- Wordfence, seen
Someone could do things on your site they should not be allowed to (up to and including 3.2.3)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 3.2.3
- Fixed in
- 3.2.4
- What to do
- If your site has an affected version, update WebberZone Top 10 — Popular Posts to version 3.2.4 or newer.
- Official ID
- CVE-2023-25993
- Report title
- Top 10 – Popular posts plugin for WordPress <= 3.2.3 - Missing Authorization on tptn_ajax_clearcache
- First reported
- Sources
- Wordfence, seen
Someone could trick a logged-in admin into changing settings without knowing (up to and including 3.2.3)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 3.2.3
- Fixed in
- 3.2.4
- What to do
- If your site has an affected version, update WebberZone Top 10 — Popular Posts to version 3.2.4 or newer.
- Report title
- Top 10 – Popular posts plugin for WordPress <= 3.2.3 - Cross-Site Request Forgery via tptn_ajax_clearcache
- First reported
- Sources
- Wordfence, seen
Someone with a contributor account on your site could plant harmful code that runs for your visitors or admins (up to and including 3.2.2)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 3.2.2
- Fixed in
- 3.2.3
- What to do
- If your site has an affected version, update WebberZone Top 10 — Popular Posts to version 3.2.3 or newer.
- Official ID
- CVE-2022-4570
- Report title
- Top 10 – Popular posts plugin for WordPress <= 3.2.2 - Authenticated (Contributor+) Stored Cross-Site Scripting via Blocks
- First reported
- Sources
- Wordfence, seen
Someone could trick a logged-in admin into changing settings without knowing (before 2.9.5)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Before 2.9.5
- Fixed in
- 2.9.5
- What to do
- If your site has an affected version, update WebberZone Top 10 — Popular Posts to version 2.9.5 or newer.
- Official ID
- CVE-2020-36761
- Report title
- Top 10 <= 2.9.4 - Cross-Site Request Forgery Bypass
- First reported
- Sources
- Wordfence, seen
Someone could read or change the data in your site’s database
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Before 2.4.4
- Fixed in
- 2.4.4
- What to do
- If your site has an affected version, update WebberZone Top 10 — Popular Posts to version 2.4.4 or newer.
- Report title
- Top 10 – Popular posts plugin for WordPress <= 2.4.3 - SQL Injection
- First reported
- Sources
- Wordfence, seen
Someone could plant harmful code that runs for your visitors or admins (before 2.3.1)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Before 2.3.1
- Fixed in
- 2.3.1
- What to do
- If your site has an affected version, update WebberZone Top 10 — Popular Posts to version 2.3.1 or newer.
- Report title
- Top 10 – Popular posts plugin for WordPress < 2.3.1 - Cross-Site Scripting
- First reported
- Sources
- Wordfence, seen
Where this comes from
We collect these reports from public security sources and rewrite them in plain words. Each problem shows its sources and the date we first saw it. This page never says whether your own site is affected: only a check of your site’s versions can tell.
Get an email when your site is affected.
Install Watchfox AI once. It checks your plugins and themes against this list every day, for free.
Install Watchfox AI (free)