Ultimate Post Kit: known security problems
7 known security problems reported for this WordPress plugin, with the affected versions, the fix and what to do.
Updated
In short
There are 7 known security problems on this page. Each one has a fixed version. Updating to version 4.5.6 or newer covers every fixed problem listed here.
Based on public reports. Check the plugin’s changelog. Watchfox AI may be wrong.
Get an email when your site is affected: install Watchfox AI (free)
Someone could do things on your site they should not be allowed to (up to and including 4.5.5)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 4.5.5
- Fixed in
- 4.5.6
- What to do
- If your site has an affected version, update Ultimate Post Kit to version 4.5.6 or newer.
- Official ID
- CVE-2026-105886
- Report title
- Ultimate Post Kit – Elementor Post Grid, Post Carousel, Post Slider & Blog Layout Widgets <= 4.5.5 - Missing Authorization
- First reported
- Sources
- Wordfence, seen
Someone could plant harmful code that runs for your visitors or admins (up to and including 4.2.0)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 4.2.0
- Fixed in
- 4.2.1
- What to do
- If your site has an affected version, update Ultimate Post Kit to version 4.2.1 or newer.
- Official ID
- CVE-2026-92991
- Report title
- Biggopti Library (Various Versions) - Cross-Site Scripting via display_id from Sigmative API
- First reported
- Sources
- Wordfence, seen
Someone could do things on your site they should not be allowed to (up to and including 4.0.21)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 4.0.21
- Fixed in
- 4.0.22
- What to do
- If your site has an affected version, update Ultimate Post Kit to version 4.0.22 or newer.
- Official ID
- CVE-2026-24362
- Report title
- Ultimate Post Kit Addons for Elementor <= 4.0.21 - Missing Authorization
- First reported
- Sources
- Wordfence, seen
A stranger could use it to harm your site
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 4.0.15
- Fixed in
- 4.0.16
- What to do
- If your site has an affected version, update Ultimate Post Kit to version 4.0.16 or newer.
- Official ID
- CVE-2025-14434
- Report title
- Ultimate Post Kit <= 4.0.15 - Unauthenticated Information Disclosure
- First reported
- Sources
- Wordfence, seen
Someone with a contributor account on your site could plant harmful code that runs for your visitors or admins
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 3.11.7
- Fixed in
- 3.11.8
- What to do
- If your site has an affected version, update Ultimate Post Kit to version 3.11.8 or newer.
- Official ID
- CVE-2024-5662
- Report title
- Ultimate Post Kit Addons For Elementor – (Post Grid, Post Carousel, Post Slider, Category List, Post Tabs, Timeline, Post Ticker, Tag Cloud) <= 3.11.7 - Authenticated (Contributor+) Stored Cross-Site Scripting via Social Count (Static) Widget
- First reported
- Sources
- Wordfence, seen
Someone could plant harmful code that runs for your visitors or admins (up to and including 3.6.3)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 3.6.3
- Fixed in
- 3.6.4
- What to do
- If your site has an affected version, update Ultimate Post Kit to version 3.6.4 or newer.
- Official ID
- CVE-2023-33999
- Report title
- Freemius SDK <= 2.5.9 - Reflected Cross-Site Scripting via fs_request_get
- First reported
- Sources
- Wordfence, seen
Someone could do things on your site they should not be allowed to (before 2.9.1)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Before 2.9.1
- Fixed in
- 2.9.1
- What to do
- If your site has an affected version, update Ultimate Post Kit to version 2.9.1 or newer.
- Official ID
- CVE-2022-4974
- Report title
- Freemius SDK <= 2.4.2 - Missing Authorization Checks
- First reported
- Sources
- Wordfence, seen
Where this comes from
We collect these reports from public security sources and rewrite them in plain words. Each problem shows its sources and the date we first saw it. This page never says whether your own site is affected: only a check of your site’s versions can tell.
Get an email when your site is affected.
Install Watchfox AI once. It checks your plugins and themes against this list every day, for free.
Install Watchfox AI (free)