Under Construction: known security problems
5 known security problems reported for this WordPress plugin, with the affected versions, the fix and what to do.
Updated
In short
There are 5 known security problems on this page. Each one has a fixed version. Updating to version 5.83 or newer covers every fixed problem listed here.
Based on public reports. Check the plugin’s changelog. Watchfox AI may be wrong.
Get an email when your site is affected: install Watchfox AI (free)
A stranger could plant harmful code that runs for your visitors or admins
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 5.82
- Fixed in
- 5.83
- What to do
- If your site has an affected version, update Under Construction to version 5.83 or newer.
- Official ID
- CVE-2026-81295
- Report title
- Under Construction <= 5.82 - Unauthenticated Stored Cross-Site Scripting
- First reported
- Sources
- Wordfence, seen
Anyone with an account on your site, even a basic one could read or delete private files on your server
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 5.76
- Fixed in
- 5.81
- What to do
- If your site has an affected version, update Under Construction to version 5.81 or newer.
- Official ID
- CVE-2026-11426
- Report title
- UnderConstructionPage PRO <= 5.76 - Authenticated (Subscriber+) Arbitrary File Read via template_thumbnail Parameter
- First reported
- Sources
- Wordfence, seen
Someone could trick a logged-in admin into changing settings without knowing (up to and including 3.96)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 3.96
- Fixed in
- 3.97
- What to do
- If your site has an affected version, update Under Construction to version 3.97 or newer.
- Official ID
- CVE-2023-0831
- Report title
- Under Construction <= 3.96 - Cross-Site Request Forgery via admin_action_ucp_dismiss_notice
- First reported
- Sources
- Wordfence, seen
Someone could trick a logged-in admin into changing settings without knowing (up to and including 3.96) (2)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 3.96
- Fixed in
- 3.97
- What to do
- If your site has an affected version, update Under Construction to version 3.97 or newer.
- Official ID
- CVE-2023-0832
- Report title
- Under Construction <= 3.96 - Cross-Site Request Forgery via admin_action_install_weglot
- First reported
- Sources
- Wordfence, seen
Someone could plant harmful code that runs for your visitors or admins
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 3.85
- Fixed in
- 3.86
- What to do
- If your site has an affected version, update Under Construction to version 3.86 or newer.
- Report title
- Under Construction <= 3.85 - Authenticated Stored Cross-Site Scripting
- First reported
- Sources
- Wordfence, seen
Where this comes from
We collect these reports from public security sources and rewrite them in plain words. Each problem shows its sources and the date we first saw it. This page never says whether your own site is affected: only a check of your site’s versions can tell.
Get an email when your site is affected.
Install Watchfox AI once. It checks your plugins and themes against this list every day, for free.
Install Watchfox AI (free)