EN ES
Start free

URL Shortify: known security problems

13 known security problems reported for this WordPress plugin, with the affected versions, the fix and what to do.

Updated

In short

There are 13 known security problems on this page. Each one has a fixed version. Updating to version 2.5.1 or newer covers every fixed problem listed here.

Based on public reports. Check the plugin’s changelog. Watchfox AI may be wrong.

Get an email when your site is affected: install Watchfox AI (free)

This week

A stranger could plant harmful code that runs for your visitors or admins (up to and including 2.5.0)

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 2.5.0
Fixed in
2.5.1
What to do
If your site has an affected version, update URL Shortify to version 2.5.1 or newer.
Official ID
CVE-2026-73362
Report title
URL Shortify – Simple and Easy URL Shortener <= 2.5.0 - Unauthenticated Stored Cross-Site Scripting
First reported
Sources
This week

Someone could plant harmful code that runs for your visitors or admins (up to and including 1.10.4)

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 1.10.4
Fixed in
1.10.5.1
What to do
If your site has an affected version, update URL Shortify to version 1.10.5.1 or newer.
Official ID
CVE-2024-13362
Report title
Freemius <= 2.10.1 - Reflected DOM-Based Cross-Site Scripting via url Parameter
First reported
Sources
This week

Someone with an author account on your site could make your server visit other addresses on their behalf

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 1.12.3
Fixed in
1.12.4
What to do
If your site has an affected version, update URL Shortify to version 1.12.4 or newer.
Official ID
CVE-2026-25385
Report title
URL Shortify <= 1.12.3 - Authenticated (Author+) Server-Side Request Forgery
First reported
Sources
This week

A stranger could send your visitors from your site to a harmful site

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 1.12.1
Fixed in
1.12.2
What to do
If your site has an affected version, update URL Shortify to version 1.12.2 or newer.
Official ID
CVE-2026-1277
Report title
URL Shortify <= 1.12.1 - Unauthenticated Open Redirect via 'redirect_to' Parameter
First reported
Sources
This week

Someone could plant harmful code that runs for your visitors or admins (up to and including 1.11.3)

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 1.11.3
Fixed in
1.11.4
What to do
If your site has an affected version, update URL Shortify to version 1.11.4 or newer.
Official ID
CVE-2025-13355
Report title
URL Shortify <= 1.11.3 - Reflected Cross-Site Scripting
First reported
Sources
This week

Someone could plant harmful code that runs for your visitors or admins (up to and including 1.11.2)

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 1.11.2
Fixed in
1.11.3
What to do
If your site has an affected version, update URL Shortify to version 1.11.3 or newer.
Official ID
CVE-2025-12684
Report title
URL Shortify <= 1.11.2 - Reflected Cross-Site Scripting
First reported
Sources
This week

Someone who already has an admin account could plant harmful code that runs for your visitors or admins

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 1.10.5.1
Fixed in
1.10.6
What to do
If your site has an affected version, update URL Shortify to version 1.10.6 or newer.
Official ID
CVE-2025-32134
Report title
URL Shortify <= 1.10.5.1 - Authenticated (Administrator+) Stored Cross-Site Scripting
First reported
Sources
This week

Someone could plant harmful code that runs for your visitors or admins (up to and including 1.7.9)

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 1.7.9
Fixed in
1.7.9.1
What to do
If your site has an affected version, update URL Shortify to version 1.7.9.1 or newer.
Official ID
CVE-2023-5605
Report title
URL Shortify <= 1.7.9 - Authenticated (Admin+) Stored Cross-Site Scripting
First reported
Sources
This week

A stranger could plant harmful code that runs for your visitors or admins (up to and including 1.7.5)

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 1.7.5
Fixed in
1.7.6
What to do
If your site has an affected version, update URL Shortify to version 1.7.6 or newer.
Official ID
CVE-2023-4294
Report title
URL Shortify <= 1.7.5 - Unauthenticated Stored Cross-Site Scripting via Referrer Header
First reported
Sources
This week

Someone could plant harmful code that runs for your visitors or admins (from 1.0.1 up to and including 1.7.2)

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • From 1.0.1 up to and including 1.7.2
Fixed in
1.7.3
What to do
If your site has an affected version, update URL Shortify to version 1.7.3 or newer.
Official ID
CVE-2023-33999
Report title
Freemius SDK <= 2.5.9 - Reflected Cross-Site Scripting via fs_request_get
First reported
Sources
This week

Someone could plant harmful code that runs for your visitors or admins (before 1.7.0)

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Before 1.7.0
Fixed in
1.7.0
What to do
If your site has an affected version, update URL Shortify to version 1.7.0 or newer.
Official ID
CVE-2023-3129
Report title
URL Shortify – Simple, Powerful and Easy URL Shortener Plugin For WordPress <= 1.6.5 - Authenticated (Admin+) Stored Cross-Site Scripting
First reported
Sources
This week

Someone could do things on your site they should not be allowed to

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Before 1.5.11
Fixed in
1.5.11
What to do
If your site has an affected version, update URL Shortify to version 1.5.11 or newer.
Official ID
CVE-2022-4974
Report title
Freemius SDK <= 2.4.2 - Missing Authorization Checks
First reported
Sources
This week

Someone could trick a logged-in admin into changing settings without knowing

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 1.5.0
Fixed in
1.5.1
What to do
If your site has an affected version, update URL Shortify to version 1.5.1 or newer.
Official ID
CVE-2021-24749
Report title
URL Shortify <= 1.5.0 - Cross-Site Request Forgery
First reported
Sources

Where this comes from

We collect these reports from public security sources and rewrite them in plain words. Each problem shows its sources and the date we first saw it. This page never says whether your own site is affected: only a check of your site’s versions can tell.

All plugins and themes

Get an email when your site is affected.

Install Watchfox AI once. It checks your plugins and themes against this list every day, for free.

Install Watchfox AI (free)