User Access Manager: known security problems
8 known security problems reported for this WordPress plugin, with the affected versions, the fix and what to do.
Updated
In short
There are 8 known security problems on this page. Each one has a fixed version. Updating to version 2.3.19 or newer covers every fixed problem listed here.
Based on public reports. Check the plugin’s changelog. Watchfox AI may be wrong.
Get an email when your site is affected: install Watchfox AI (free)
Someone could plant harmful code that runs for your visitors or admins (up to and including 2.3.18)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.3.18
- Fixed in
- 2.3.19
- What to do
- If your site has an affected version, update User Access Manager to version 2.3.19 or newer.
- Official ID
- CVE-2026-19797
- Report title
- User Access Manager <= 2.3.18 - Reflected Cross-Site Scripting via 'tab_group_section' Parameter
- First reported
- Sources
- Wordfence, seen
Someone could do things on your site they should not be allowed to
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.3.14
- Fixed in
- 2.3.15
- What to do
- If your site has an affected version, update User Access Manager to version 2.3.15 or newer.
- Official ID
- CVE-2026-18035
- Report title
- User Access Manager <= 2.3.14 - Missing Authorization
- First reported
- Sources
- Wordfence, seen
Anyone with an account on your site, even a basic one could read or change the data in your site’s database
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.3.12
- Fixed in
- 2.3.13
- What to do
- If your site has an affected version, update User Access Manager to version 2.3.13 or newer.
- Official ID
- CVE-2026-15281
- Report title
- User Access Manager <= 2.3.12 - Authenticated (Subscriber+) SQL Injection
- First reported
- Sources
- Wordfence, seen
A stranger could read or delete private files on your server
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.3.15
- Fixed in
- 2.3.16
- What to do
- If your site has an affected version, update User Access Manager to version 2.3.16 or newer.
- Official ID
- CVE-2026-18352
- Report title
- User Access Manager <= 2.3.15 - Unauthenticated Arbitrary File Read via 'uamgetfile' Parameter
- First reported
- Sources
- Wordfence, seen
Someone could use it to harm your site
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.2.16
- Fixed in
- 2.2.18
- What to do
- If your site has an affected version, update User Access Manager to version 2.2.18 or newer.
- Official ID
- CVE-2022-1601
- Report title
- User Access Manager <= 2.2.16 - IP Spoofing
- First reported
- Sources
- Wordfence, seen
Someone could plant harmful code that runs for your visitors or admins (up to and including 1.2.14)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 1.2.14
- Fixed in
- 2.0.0
- What to do
- If your site has an affected version, update User Access Manager to version 2.0.0 or newer.
- Report title
- User Access Manager <= 1.2.14 - Reflected Cross-Site Scripting
- First reported
- Sources
- Wordfence, seen
Someone could plant harmful code that runs for your visitors or admins (before 2.0.9)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Before 2.0.9
- Fixed in
- 2.0.9
- What to do
- If your site has an affected version, update User Access Manager to version 2.0.9 or newer.
- Report title
- User Access Manager <= 2.0.8 - Reflected Cross-Site Scripting
- First reported
- Sources
- Wordfence, seen
Someone could trick a logged-in admin into changing settings without knowing
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Before 1.2
- Fixed in
- 1.2
- What to do
- If your site has an affected version, update User Access Manager to version 1.2 or newer.
- Official ID
- CVE-2011-5328
- Report title
- User Access Manager < 1.2 - Cross-Site Request Forgery
- First reported
- Sources
- Wordfence, seen
Where this comes from
We collect these reports from public security sources and rewrite them in plain words. Each problem shows its sources and the date we first saw it. This page never says whether your own site is affected: only a check of your site’s versions can tell.
Get an email when your site is affected.
Install Watchfox AI once. It checks your plugins and themes against this list every day, for free.
Install Watchfox AI (free)