EN ES
Start free

VK All in One Expansion Unit: known security problems

12 known security problems reported for this WordPress plugin, with the affected versions, the fix and what to do.

Updated

In short

There are 12 known security problems on this page. Each one has a fixed version. Updating to version 9.119.0 or newer covers every fixed problem listed here.

Based on public reports. Check the plugin’s changelog. Watchfox AI may be wrong.

Get an email when your site is affected: install Watchfox AI (free)

This week

Someone with an author account on your site could plant harmful code that runs for your visitors or admins

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 9.118.0
Fixed in
9.119.0
What to do
If your site has an affected version, update VK All in One Expansion Unit to version 9.119.0 or newer.
Official ID
CVE-2026-17586
Report title
VK All in One Expansion Unit <= 9.118.0 - Authenticated (Author+) Stored Cross-Site Scripting via 'vkExUnit_cta_img_position' Post Meta
First reported
Sources
This week

Someone with a contributor account on your site could plant harmful code that runs for your visitors or admins (up to and including 9.113.3)

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 9.113.3
Fixed in
9.113.4
What to do
If your site has an affected version, update VK All in One Expansion Unit to version 9.113.4 or newer.
Official ID
CVE-2026-39483
Report title
VK All in One Expansion Unit <= 9.113.3 - Authenticated (Contributor+) Stored Cross-Site Scripting
First reported
Sources
This week

Someone with a contributor account on your site could plant harmful code that runs for your visitors or admins (up to and including 9.112.3)

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 9.112.3
Fixed in
9.112.4
What to do
If your site has an affected version, update VK All in One Expansion Unit to version 9.112.4 or newer.
Official ID
CVE-2025-11737
Report title
VK All in One Expansion Unit <= 9.112.3 - Authenticated (Contributor+) Stored Cross-Site Scripting via SNS Title
First reported
Sources
This week

Someone with a contributor account on your site could plant harmful code that runs for your visitors or admins (up to and including 9.112.1)

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 9.112.1
Fixed in
9.112.2
What to do
If your site has an affected version, update VK All in One Expansion Unit to version 9.112.2 or newer.
Official ID
CVE-2025-11267
Report title
VK All in One Expansion Unit <= 9.112.1 - Authenticated (Contributor+) Stored Cross-Site Scripting
First reported
Sources
This week

Someone with a contributor account on your site could plant harmful code that runs for your visitors or admins (up to and including 9.112.1) (2)

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 9.112.1
Fixed in
9.112.2
What to do
If your site has an affected version, update VK All in One Expansion Unit to version 9.112.2 or newer.
Official ID
CVE-2025-11265
Report title
VK All in One Expansion Unit <= 9.112.1 - Authenticated (Contributor+) Stored Cross-Site Scripting
First reported
Sources
This week

Someone with a contributor account on your site could plant harmful code that runs for your visitors or admins (up to and including 9.99.1.0)

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 9.99.1.0
Fixed in
9.99.2.0
What to do
If your site has an affected version, update VK All in One Expansion Unit to version 9.99.2.0 or newer.
Official ID
CVE-2024-37956
Report title
VK All in One Expansion Unit <= 9.99.1.0 - Authenticated (Contributor+) Stored Cross-Site Scripting
First reported
Sources
This week

Someone could use it to harm your site

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 9.95.0.1
Fixed in
9.96.0.0
What to do
If your site has an affected version, update VK All in One Expansion Unit to version 9.96.0.0 or newer.
Official ID
CVE-2024-2093
Report title
VK All in One Expansion Unit <= 9.95.0.1 - Information Exposure
First reported
Sources
This week

Someone with a contributor account on your site could plant harmful code that runs for your visitors or admins (up to and including 9.96.0.1)

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 9.96.0.1
Fixed in
9.97.0.0
What to do
If your site has an affected version, update VK All in One Expansion Unit to version 9.97.0.0 or newer.
Official ID
CVE-2024-2170
Report title
VK All in One Expansion Unit <= 9.96.0.1 - Authenticated (Contributor+) Stored Cross-Site Scripting via className
First reported
Sources
This week

Someone with a contributor account on your site could plant harmful code that runs for your visitors or admins (up to and including 9.88.1.0)

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 9.88.1.0
Fixed in
9.88.2.0
What to do
If your site has an affected version, update VK All in One Expansion Unit to version 9.88.2.0 or newer.
Official ID
CVE-2023-28367
Report title
VK All in One Expansion Unit <= 9.88.1.0 - Stored (Contributor+) Cross-Site Scripting in CTA Post
First reported
Sources
This week

Someone with a contributor account on your site could plant harmful code that runs for your visitors or admins (up to and including 9.88.1.0) (2)

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 9.88.1.0
Fixed in
9.88.2.0
What to do
If your site has an affected version, update VK All in One Expansion Unit to version 9.88.2.0 or newer.
Official ID
CVE-2023-27926
Report title
VK All in One Expansion Unit <= 9.88.1.0 - Stored (Contributor+) Cross-Site Scripting in Profile Setting
First reported
Sources
This week

Someone could plant harmful code that runs for your visitors or admins

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 9.87.0.1
Fixed in
9.87.1.0
What to do
If your site has an affected version, update VK All in One Expansion Unit to version 9.87.1.0 or newer.
Official ID
CVE-2023-0937
Report title
VK All in One Expansion Unit <= 9.87.0.1 - Reflected Cross-Site Scripting via REQUEST_URI
First reported
Sources
This week

Someone with a contributor account on your site could plant harmful code that runs for your visitors or admins (up to and including 9.85.0.1)

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 9.85.0.1
Fixed in
9.86.0.0
What to do
If your site has an affected version, update VK All in One Expansion Unit to version 9.86.0.0 or newer.
Official ID
CVE-2023-0230
Report title
VK All in One Expansion Unit <= 9.85.0.1 - Authenticated (Contributor+) Stored Cross-Site Scripting via Shortcode
First reported
Sources

Where this comes from

We collect these reports from public security sources and rewrite them in plain words. Each problem shows its sources and the date we first saw it. This page never says whether your own site is affected: only a check of your site’s versions can tell.

All plugins and themes

Get an email when your site is affected.

Install Watchfox AI once. It checks your plugins and themes against this list every day, for free.

Install Watchfox AI (free)