EN ES
Start free

VK Blocks: known security problems

7 known security problems reported for this WordPress plugin, with the affected versions, the fix and what to do.

Updated

In short

There are 7 known security problems on this page. Each one has a fixed version. Updating to version 1.126.2 or newer covers every fixed problem listed here.

Based on public reports. Check the plugin’s changelog. Watchfox AI may be wrong.

Get an email when your site is affected: install Watchfox AI (free)

This week

Someone with a contributor account on your site could plant harmful code that runs for your visitors or admins (up to and including 1.126.1)

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 1.126.1
Fixed in
1.126.2
What to do
If your site has an affected version, update VK Blocks to version 1.126.2 or newer.
Official ID
CVE-2026-78087
Report title
VK Blocks <= 1.126.1 - Authenticated (Contributor+) Stored Cross-Site Scripting via Group Block 'linkToPost' Feature
First reported
Sources
This week

Someone could see private information they should not see

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 1.94.2.2
Fixed in
1.95.0.3
What to do
If your site has an affected version, update VK Blocks to version 1.95.0.3 or newer.
Official ID
CVE-2024-13635
Report title
VK Blocks <= 1.94.2.2 - Missing Authorization to Sensitive Information Exposure
First reported
Sources
This week

Someone with a contributor account on your site could plant harmful code that runs for your visitors or admins (up to and including 1.63.0.1)

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 1.63.0.1
Fixed in
1.64.0.0
What to do
If your site has an affected version, update VK Blocks to version 1.64.0.0 or newer.
Official ID
CVE-2023-5706
Report title
VK Blocks <= 1.63.0.1 - Authenticated (Contributor+) Stored Cross-Site Scripting via Block
First reported
Sources
This week

Someone with a contributor account on your site could use it to harm your site (up to and including 1.57.0.5)

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 1.57.0.5
Fixed in
1.57.0.10
What to do
If your site has an affected version, update VK Blocks to version 1.57.0.10 or newer.
Official ID
CVE-2023-0583
Report title
VK Blocks <= 1.57.0.5 - Authenticated(Contributor+) Settings Update
First reported
Sources
This week

Someone with a contributor account on your site could use it to harm your site (up to and including 1.57.0.5) (2)

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 1.57.0.5
Fixed in
1.58.0.0
What to do
If your site has an affected version, update VK Blocks to version 1.58.0.0 or newer.
Official ID
CVE-2023-0584
Report title
VK Blocks <= 1.57.0.5 - Authenticated(Contributor+) Settings Update
First reported
Sources
This week

Someone with a contributor account on your site could plant harmful code that runs for your visitors or admins (up to and including 1.53.0.1)

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 1.53.0.1
Fixed in
1.54.0
What to do
If your site has an affected version, update VK Blocks to version 1.54.0 or newer.
Official ID
CVE-2023-27925
Report title
VK Blocks <= 1.53.0.1 - Stored (Contributor+) Cross-Site Scripting in Post
First reported
Sources
This week

Someone with a contributor account on your site could plant harmful code that runs for your visitors or admins (up to and including 1.53.0.1) (2)

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 1.53.0.1
Fixed in
1.54.0
What to do
If your site has an affected version, update VK Blocks to version 1.54.0 or newer.
Official ID
CVE-2023-27923
Report title
VK Blocks <= 1.53.0.1 - Stored (Contributor+) Cross-Site Scripting in Tag Edit
First reported
Sources

Where this comes from

We collect these reports from public security sources and rewrite them in plain words. Each problem shows its sources and the date we first saw it. This page never says whether your own site is affected: only a check of your site’s versions can tell.

All plugins and themes

Get an email when your site is affected.

Install Watchfox AI once. It checks your plugins and themes against this list every day, for free.

Install Watchfox AI (free)