EN ES
Start free

Widget Options – Advanced Conditional Visibility for Gutenberg Blocks & Classic Widgets: known security problems

9 known security problems reported for this WordPress plugin, with the affected versions, the fix and what to do.

Updated

In short

There are 9 known security problems on this page. Each one has a fixed version. Updating to version 4.2.4 or newer covers every fixed problem listed here.

Based on public reports. Check the plugin’s changelog. Watchfox AI may be wrong.

Get an email when your site is affected: install Watchfox AI (free)

This week

Someone with a contributor account on your site could run their own code on your site and take it over (up to and including 4.2.3)

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 4.2.3
Fixed in
4.2.4
What to do
If your site has an affected version, update Widget Options – Advanced Conditional Visibility for Gutenberg Blocks & Classic Widgets to version 4.2.4 or newer.
Official ID
CVE-2026-54823
Report title
Widget Options – Advanced Conditional Visibility for Gutenberg Blocks & Classic Widgets <= 4.2.3 - Authenticated (Contributor+) Remote Code Execution
First reported
Sources
This week

Someone with a contributor account on your site could run their own code on your site and take it over (up to and including 4.2.2)

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 4.2.2
Fixed in
4.2.3
What to do
If your site has an affected version, update Widget Options – Advanced Conditional Visibility for Gutenberg Blocks & Classic Widgets to version 4.2.3 or newer.
Official ID
CVE-2026-2052
Report title
Widget Options <= 4.2.2 - Authenticated (Contributor+) Remote Code Execution via Display Logic
First reported
Sources
This week

Someone with a contributor account on your site could run their own code on your site and take it over (up to and including 4.1.3)

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 4.1.3
Fixed in
4.2.0
What to do
If your site has an affected version, update Widget Options – Advanced Conditional Visibility for Gutenberg Blocks & Classic Widgets to version 4.2.0 or newer.
Official ID
CVE-2026-27984
Report title
Widget Options – Advanced Conditional Visibility for Gutenberg Blocks & Classic Widgets <= 4.1.3 - Authenticated (Contributor+) Remote Code Execution
First reported
Sources
This week

Someone with a contributor account on your site could plant harmful code that runs for your visitors or admins

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 4.1.2
Fixed in
4.1.3
What to do
If your site has an affected version, update Widget Options – Advanced Conditional Visibility for Gutenberg Blocks & Classic Widgets to version 4.1.3 or newer.
Official ID
CVE-2025-10580
Report title
Widget Options – The #1 WordPress Widget & Block Control Plugin <= 4.1.2 - Authenticated (Contributor+) Stored Cross-Site Scripting
First reported
Sources
This week

Someone with a contributor account on your site could run their own code on your site and take it over (up to and including 4.1.0)

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 4.1.0
Fixed in
4.1.1
What to do
If your site has an affected version, update Widget Options – Advanced Conditional Visibility for Gutenberg Blocks & Classic Widgets to version 4.1.1 or newer.
Official ID
CVE-2025-22630
Report title
Widget Options <= 4.1.0 - Authenticated (Contributor+) Remote Code Execution
First reported
Sources
This week

Someone could do things on your site they should not be allowed to (up to and including 4.0.8)

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 4.0.8
Fixed in
4.0.9
What to do
If your site has an affected version, update Widget Options – Advanced Conditional Visibility for Gutenberg Blocks & Classic Widgets to version 4.0.9 or newer.
Official ID
CVE-2025-22722
Report title
Widget Options <= 4.0.8 - Missing Authorization to Notice Dismissal
First reported
Sources
This week

Someone could do things on your site they should not be allowed to (up to and including 4.0.6.1)

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 4.0.6.1
Fixed in
4.0.8
What to do
If your site has an affected version, update Widget Options – Advanced Conditional Visibility for Gutenberg Blocks & Classic Widgets to version 4.0.8 or newer.
Official ID
CVE-2024-56219
Report title
Widget Options <= 4.0.6.1 - Missing Authorization
First reported
Sources
This week

Someone with a contributor account on your site could run their own code on your site and take it over (up to and including 4.0.7)

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 4.0.7
Fixed in
4.0.8
What to do
If your site has an affected version, update Widget Options – Advanced Conditional Visibility for Gutenberg Blocks & Classic Widgets to version 4.0.8 or newer.
Official ID
CVE-2024-8672
Report title
Widget Options – The #1 WordPress Widget & Block Control Plugin <= 4.0.7 - Authenticated (Contributor+) Remote Code Execution
First reported
Sources
This week

Anyone with an account on your site, even a basic one could use it to harm your site

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 4.0.1
Fixed in
4.0.2
What to do
If your site has an affected version, update Widget Options – Advanced Conditional Visibility for Gutenberg Blocks & Classic Widgets to version 4.0.2 or newer.
Official ID
CVE-2024-35691
Report title
Widget Options - Extended <= 5.1.0 & Widget Options <= 4.0.1 - Authenticated (Subscriber+) Information Disclosure
First reported
Sources

Where this comes from

We collect these reports from public security sources and rewrite them in plain words. Each problem shows its sources and the date we first saw it. This page never says whether your own site is affected: only a check of your site’s versions can tell.

All plugins and themes

Get an email when your site is affected.

Install Watchfox AI once. It checks your plugins and themes against this list every day, for free.

Install Watchfox AI (free)