EN ES
Start free

CURCY – Multi Currency for WooCommerce: known security problems

9 known security problems reported for this WordPress plugin, with the affected versions, the fix and what to do.

Updated

In short

There are 9 known security problems on this page. Each one has a fixed version. Updating to version 2.2.19 or newer covers every fixed problem listed here.

Based on public reports. Check the plugin’s changelog. Watchfox AI may be wrong.

Get an email when your site is affected: install Watchfox AI (free)

This week

Someone could do things on your site they should not be allowed to (up to and including 2.2.17)

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 2.2.17
Fixed in
2.2.18
What to do
If your site has an affected version, update CURCY – Multi Currency for WooCommerce to version 2.2.18 or newer.
Official ID
CVE-2026-97071
Report title
CURCY – Multi Currency for WooCommerce <= 2.2.17 - Missing Authorization
First reported
Sources
This week

A stranger could plant harmful code that runs for your visitors or admins

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • From 2.2.18 up to and including 2.2.18
Fixed in
2.2.19
What to do
If your site has an affected version, update CURCY – Multi Currency for WooCommerce to version 2.2.19 or newer.
Official ID
CVE-2026-94171
Report title
CURCY – Multi Currency for WooCommerce 2.2.18 - Unauthenticated Stored Cross-Site Scripting
First reported
Sources
This week

A stranger could use it to harm your site (up to and including 2.2.14)

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 2.2.14
Fixed in
2.2.15
What to do
If your site has an affected version, update CURCY – Multi Currency for WooCommerce to version 2.2.15 or newer.
Official ID
CVE-2026-11778
Report title
CURCY <= 2.2.14 - Unauthenticated Arbitrary Shortcode Execution via 'exchange' Parameter
First reported
Sources
This week

A stranger could use it to harm your site (up to and including 2.2.5)

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 2.2.5
Fixed in
2.2.6
What to do
If your site has an affected version, update CURCY – Multi Currency for WooCommerce to version 2.2.6 or newer.
Official ID
CVE-2024-13487
Report title
CURCY – Multi Currency for WooCommerce <= 2.2.5 - Unauthenticated Arbitrary Shortcode Execution via get_products_price Function
First reported
Sources
This week

Someone could plant harmful code that runs for your visitors or admins (up to and including 2.2.3)

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 2.2.3
Fixed in
2.2.4
What to do
If your site has an affected version, update CURCY – Multi Currency for WooCommerce to version 2.2.4 or newer.
Official ID
CVE-2024-49283
Report title
CURCY <= 2.2.3 - Reflected Cross-Site Scripting
First reported
Sources
This week

Someone with a contributor account on your site could plant harmful code that runs for your visitors or admins

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 2.2.0.1
Fixed in
2.2.1
What to do
If your site has an affected version, update CURCY – Multi Currency for WooCommerce to version 2.2.1 or newer.
Official ID
CVE-2023-50831
Report title
CURCY – Multi Currency for WooCommerce <= 2.2.0.1 - Authenticated (Contributor+) Stored Cross-Site Scripting
First reported
Sources
This week

Someone could do things on your site they should not be allowed to (up to and including 2.1.25)

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 2.1.25
Fixed in
2.1.26
What to do
If your site has an affected version, update CURCY – Multi Currency for WooCommerce to version 2.1.26 or newer.
Official ID
CVE-2022-46796
Report title
CURCY <= 2.1.25 - Missing Authorization to Currency Exchange Retrieval
First reported
Sources
This week

Someone could plant harmful code that runs for your visitors or admins (up to and including 2.1.17)

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 2.1.17
Fixed in
2.1.18
What to do
If your site has an affected version, update CURCY – Multi Currency for WooCommerce to version 2.1.18 or newer.
Report title
CURCY <= 2.1.17 - Reflected Cross-Site Scripting
First reported
Sources
This week

Someone could do things on your site they should not be allowed to (up to and including 2.1.17)

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 2.1.17
Fixed in
2.1.18
What to do
If your site has an affected version, update CURCY – Multi Currency for WooCommerce to version 2.1.18 or newer.
Official ID
CVE-2021-4376
Report title
WooCommerce Multi Currency <= 2.1.17 - Missing Authorization
First reported
Sources

Where this comes from

We collect these reports from public security sources and rewrite them in plain words. Each problem shows its sources and the date we first saw it. This page never says whether your own site is affected: only a check of your site’s versions can tell.

All plugins and themes

Get an email when your site is affected.

Install Watchfox AI once. It checks your plugins and themes against this list every day, for free.

Install Watchfox AI (free)