WPC Smart Quick View for WooCommerce: known security problems
5 known security problems reported for this WordPress plugin, with the affected versions, the fix and what to do.
Updated
In short
There are 5 known security problems on this page. Each one has a fixed version. Updating to version 4.4.1 or newer covers every fixed problem listed here.
Based on public reports. Check the plugin’s changelog. Watchfox AI may be wrong.
Get an email when your site is affected: install Watchfox AI (free)
Someone could plant harmful code that runs for your visitors or admins
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 4.4.0
- Fixed in
- 4.4.1
- What to do
- If your site has an affected version, update WPC Smart Quick View for WooCommerce to version 4.4.1 or newer.
- Official ID
- CVE-2026-103888
- Report title
- WPC Smart Quick View for WooCommerce <= 4.4.0 - Reflected Cross-Site Scripting via 'woosq-redirect' Parameter
- First reported
- Sources
- Wordfence, seen
A stranger could use it to harm your site
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 4.2.5
- Fixed in
- 4.2.6
- What to do
- If your site has an affected version, update WPC Smart Quick View for WooCommerce to version 4.2.6 or newer.
- Official ID
- CVE-2025-11741
- Report title
- WPC Smart Quick View for WooCommerce <= 4.2.5 - Insecure Direct Object Reference to Unauthenticated Private Product Exposure
- First reported
- Sources
- Wordfence, seen
Someone with a contributor account on your site could plant harmful code that runs for your visitors or admins (up to and including 4.2.1)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 4.2.1
- Fixed in
- 4.2.2
- What to do
- If your site has an affected version, update WPC Smart Quick View for WooCommerce to version 4.2.2 or newer.
- Official ID
- CVE-2025-8618
- Report title
- WPC Smart Quick View for WooCommerce <= 4.2.1 - Authenticated (Contributor+) Stored Cross-Site Scripting via woosq_btn Shortcode
- First reported
- Sources
- Wordfence, seen
Someone with a contributor account on your site could plant harmful code that runs for your visitors or admins (up to and including 4.1.1)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 4.1.1
- Fixed in
- 4.1.2
- What to do
- If your site has an affected version, update WPC Smart Quick View for WooCommerce to version 4.1.2 or newer.
- Official ID
- CVE-2024-5020
- Report title
- Multiple Plugins <= (Various Versions) - Authenticated (Contributor+) Stored DOM-Based Cross-Site Scripting via FancyBox JavaScript Library
- First reported
- Sources
- Wordfence, seen
Someone who already has an admin account could plant harmful code that runs for your visitors or admins
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 4.0.2
- Fixed in
- 4.0.3
- What to do
- If your site has an affected version, update WPC Smart Quick View for WooCommerce to version 4.0.3 or newer.
- Official ID
- CVE-2023-6494
- Report title
- WPC Smart Quick View for WooCommerce <= 4.0.2 - Authenticated (Administrator+) Stored Cross-Site Scripting
- First reported
- Sources
- Wordfence, seen
Where this comes from
We collect these reports from public security sources and rewrite them in plain words. Each problem shows its sources and the date we first saw it. This page never says whether your own site is affected: only a check of your site’s versions can tell.
Get an email when your site is affected.
Install Watchfox AI once. It checks your plugins and themes against this list every day, for free.
Install Watchfox AI (free)