EN ES
Start free

Payment Plugins for Stripe WooCommerce: known security problems

4 known security problems reported for this WordPress plugin, with the affected versions, the fix and what to do.

Updated

In short

There are 4 known security problems on this page. Each one has a fixed version. Updating to version 4.0.18 or newer covers every fixed problem listed here.

Based on public reports. Check the plugin’s changelog. Watchfox AI may be wrong.

Get an email when your site is affected: install Watchfox AI (free)

This week

Someone could plant harmful code that runs for your visitors or admins

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 4.0.17
Fixed in
4.0.18
What to do
If your site has an affected version, update Payment Plugins for Stripe WooCommerce to version 4.0.18 or newer.
Official ID
CVE-2026-89100
Report title
Payment Plugins for Stripe WooCommerce <= 4.0.17 - Reflected DOM-Based Cross-Site Scripting via '#response' URL Fragment
First reported
Sources
This week

A stranger could use it to harm your site

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 4.0.11
Fixed in
4.0.12
What to do
If your site has an affected version, update Payment Plugins for Stripe WooCommerce to version 4.0.12 or newer.
Official ID
CVE-2026-80339
Report title
Payment Plugins for Stripe WooCommerce <= 4.0.11 - Unauthenticated Information Exposure
First reported
Sources
This week

A stranger could do things on your site they should not be allowed to

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 4.0.7
Fixed in
4.0.8
What to do
If your site has an affected version, update Payment Plugins for Stripe WooCommerce to version 4.0.8 or newer.
Official ID
CVE-2026-12654
Report title
Payment Plugins for Stripe WooCommerce <= 4.0.7 - Missing Authorization to Unauthenticated Arbitrary Order Status Modification via Empty Webhook Secret
First reported
Sources
This week

Someone could do things on your site they should not be allowed to

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 4.0.7
Fixed in
4.0.8
What to do
If your site has an affected version, update Payment Plugins for Stripe WooCommerce to version 4.0.8 or newer.
Official ID
CVE-2026-59530
Report title
Payment Plugins for Stripe WooCommerce <= 4.0.7 - Missing Authorization
First reported
Sources

Where this comes from

We collect these reports from public security sources and rewrite them in plain words. Each problem shows its sources and the date we first saw it. This page never says whether your own site is affected: only a check of your site’s versions can tell.

All plugins and themes

Get an email when your site is affected.

Install Watchfox AI once. It checks your plugins and themes against this list every day, for free.

Install Watchfox AI (free)