NextMove Lite: known security problems
9 known security problems reported for this WordPress plugin, with the affected versions, the fix and what to do.
Updated
In short
There are 9 known security problems on this page. 8 of them have a fixed version. Updating to version 2.24.0 or newer covers every fixed problem listed here.
Based on public reports. Check the plugin’s changelog. Watchfox AI may be wrong.
Get an email when your site is affected: install Watchfox AI (free)
Someone with a contributor account on your site could plant harmful code that runs for your visitors or admins (up to and including 2.23.0)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.23.0
- Fixed in
- 2.24.0
- What to do
- If your site has an affected version, update NextMove Lite to version 2.24.0 or newer.
- Official ID
- CVE-2026-0703
- Report title
- NextMove Lite - Thank You Page for WooCommerce <= 2.23.0 - Authenticated (Contributor+) Stored Cross-Site Scripting via 'xlwcty_current_date' Shortcode
- First reported
- Sources
- Wordfence, seen
Someone could do things on your site they should not be allowed to
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.23.0
- Fixed in
- 2.24.0
- What to do
- If your site has an affected version, update NextMove Lite to version 2.24.0 or newer.
- Official ID
- CVE-2025-68048
- Report title
- NextMove Lite <= 2.23.0 - Missing Authorization
- First reported
- Sources
- Wordfence, seen
A stranger could use it to harm your site
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.23.0
- Fixed in
- 2.24.0
- What to do
- If your site has an affected version, update NextMove Lite to version 2.24.0 or newer.
- Official ID
- CVE-2026-24599
- Report title
- NextMove Lite <= 2.23.0 - Unauthenticated Insecure Direct Object Reference
- First reported
- Sources
- Wordfence, seen
Someone with a contributor account on your site could plant harmful code that runs for your visitors or admins (up to and including 2.23.0) (2)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.23.0
- Fixed in
- 2.24.0
- What to do
- If your site has an affected version, update NextMove Lite to version 2.24.0 or newer.
- Official ID
- CVE-2025-62969
- Report title
- NextMove Lite <= 2.23.0 - Authenticated (Contributor+) Stored Cross-Site Scripting
- First reported
- Sources
- Wordfence, seen
Someone could plant harmful code that runs for your visitors or admins
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.21.0
- Fixed in
- No fixed version yet
- What to do
- There is no fixed version yet. If your site uses it, think about turning it off or replacing it until a fix comes out.
- Official ID
- CVE-2025-52735
- Report title
- NextMove Lite <= 2.21.0 - Reflected Cross-Site Scripting
- First reported
- Sources
- Wordfence, seen
Anyone with an account on your site, even a basic one could do things on your site they should not be allowed to (up to and including 2.19.0)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.19.0
- Fixed in
- 2.20.0
- What to do
- If your site has an affected version, update NextMove Lite to version 2.20.0 or newer.
- Official ID
- CVE-2024-10860
- Report title
- NextMove Lite – Thank You Page for WooCommerce <= 2.19.0 - Missing Authorization to Authenticated (Subscriber+) Deactivation Reason Submission
- First reported
- Sources
- Wordfence, seen
Someone could trick a logged-in admin into changing settings without knowing
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.18.1
- Fixed in
- 2.18.2
- What to do
- If your site has an affected version, update NextMove Lite to version 2.18.2 or newer.
- Official ID
- CVE-2024-32104
- Report title
- NextMove Lite <= 2.18.1 - Cross-Site Request Forgery
- First reported
- Sources
- Wordfence, seen
A stranger could do things on your site they should not be allowed to
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.18.0
- Fixed in
- 2.18.1
- What to do
- If your site has an affected version, update NextMove Lite to version 2.18.1 or newer.
- Official ID
- CVE-2024-1120
- Report title
- NextMove Lite – Thank You Page for WooCommerce & Finale Lite – Sales Countdown Timer & Discount for WooCommerce <= 2.17.0 - Missing Authorization to Unauthenticated System Information Disclosure
- First reported
- Sources
- Wordfence, seen
Anyone with an account on your site, even a basic one could do things on your site they should not be allowed to (up to and including 2.17.0)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.17.0
- Fixed in
- 2.18.0
- What to do
- If your site has an affected version, update NextMove Lite to version 2.18.0 or newer.
- Official ID
- CVE-2024-25092
- Report title
- NextMove Lite <= 2.17.0 - Missing Authorization to Authenticated(Subscriber+) Plugin Activation
- First reported
- Sources
- Wordfence, seen
Where this comes from
We collect these reports from public security sources and rewrite them in plain words. Each problem shows its sources and the date we first saw it. This page never says whether your own site is affected: only a check of your site’s versions can tell.
Get an email when your site is affected.
Install Watchfox AI once. It checks your plugins and themes against this list every day, for free.
Install Watchfox AI (free)