Wallet for WooCommerce: known security problems
10 known security problems reported for this WordPress plugin, with the affected versions, the fix and what to do.
Updated
In short
There are 10 known security problems on this page. Each one has a fixed version. Updating to version 1.6.10 or newer covers every fixed problem listed here.
Based on public reports. Check the plugin’s changelog. Watchfox AI may be wrong.
Get an email when your site is affected: install Watchfox AI (free)
Anyone with an account on your site, even a basic one could do things on your site they should not be allowed to (up to and including 1.6.9)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 1.6.9
- Fixed in
- 1.6.10
- What to do
- If your site has an affected version, update Wallet for WooCommerce to version 1.6.10 or newer.
- Official ID
- CVE-2026-16538
- Report title
- TeraWallet - Wallet for WooCommerce <= 1.6.9 - Missing Authorization to Authenticated (Subscriber+) Wallet Balance Inflation
- First reported
- Sources
- Wordfence, seen
Anyone with an account on your site, even a basic one could do things on your site they should not be allowed to (up to and including 1.6.4)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 1.6.4
- Fixed in
- 1.6.5
- What to do
- If your site has an affected version, update Wallet for WooCommerce to version 1.6.5 or newer.
- Official ID
- CVE-2026-12103
- Report title
- Wallet for WooCommerce <= 1.6.4 - Missing Authorization to Authenticated (Subscriber+) User/Email Enumeration via terawallet_export_user_search AJAX Action
- First reported
- Sources
- Wordfence, seen
Anyone with an account on your site, even a basic one could use it to harm your site (up to and including 1.5.15)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 1.5.15
- Fixed in
- 1.5.16
- What to do
- If your site has an affected version, update Wallet for WooCommerce to version 1.5.16 or newer.
- Official ID
- CVE-2026-32398
- Report title
- TeraWallet – For WooCommerce <= 1.5.15 - Authenticated (Customer+) Race Condition
- First reported
- Sources
- Wordfence, seen
Anyone with an account on your site, even a basic one could use it to harm your site (up to and including 1.5.6)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 1.5.6
- Fixed in
- 1.5.7
- What to do
- If your site has an affected version, update Wallet for WooCommerce to version 1.5.7 or newer.
- Official ID
- CVE-2024-7747
- Report title
- Wallet for WooCommerce <= 1.5.6 - Authenticated (Subscriber+) Incorrect Conversion between Numeric Types
- First reported
- Sources
- Wordfence, seen
Anyone with an account on your site, even a basic one could read or change the data in your site’s database
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 1.5.4
- Fixed in
- 1.5.5
- What to do
- If your site has an affected version, update Wallet for WooCommerce to version 1.5.5 or newer.
- Official ID
- CVE-2024-6353
- Report title
- Wallet for WooCommerce <= 1.5.4 - Authenticated (Subscriber+) SQL Injection via 'search[value]'
- First reported
- Sources
- Wordfence, seen
Someone with a shop manager account on your site could plant harmful code that runs for your visitors or admins
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 1.5.0
- Fixed in
- 1.5.1
- What to do
- If your site has an affected version, update Wallet for WooCommerce to version 1.5.1 or newer.
- Official ID
- CVE-2024-32584
- Report title
- TeraWallet – Best WooCommerce Wallet System With Cashback Rewards, Partial Payment, Wallet Refunds <= 1.5.0 - Authenticated (Shop Manager+) Stored Cross-Site Scripting
- First reported
- Sources
- Wordfence, seen
Anyone with an account on your site, even a basic one could do things on your site they should not be allowed to (up to and including 1.4.10)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 1.4.10
- Fixed in
- 1.4.11
- What to do
- If your site has an affected version, update Wallet for WooCommerce to version 1.4.11 or newer.
- Official ID
- CVE-2024-1690
- Report title
- TeraWallet – Best WooCommerce Wallet System With Cashback Rewards, Partial Payment, Wallet Refunds <= 1.4.10 - Missing Authorization to Authenticated (Subscriber+) User Email Export
- First reported
- Sources
- Wordfence, seen
Someone could trick a logged-in admin into changing settings without knowing (up to and including 1.3.24)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 1.3.24
- Fixed in
- 1.4.0
- What to do
- If your site has an affected version, update Wallet for WooCommerce to version 1.4.0 or newer.
- Official ID
- CVE-2022-40198
- Report title
- TeraWallet – For WooCommerce <= 1.3.24 - Cross-Site Request Forgery via admin_options
- First reported
- Sources
- Wordfence, seen
Someone could use it to harm your site
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 1.4.3
- Fixed in
- 1.4.4
- What to do
- If your site has an affected version, update Wallet for WooCommerce to version 1.4.4 or newer.
- Official ID
- CVE-2022-3995
- Report title
- TeraWallet – For WooCommerce <= 1.4.3 - Insecure Direct Object Reference
- First reported
- Sources
- Wordfence, seen
Someone could trick a logged-in admin into changing settings without knowing (up to and including 1.3.24) (2)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 1.3.24
- Fixed in
- 1.4.0
- What to do
- If your site has an affected version, update Wallet for WooCommerce to version 1.4.0 or newer.
- Official ID
- CVE-2022-36401
- Report title
- TeraWallet – For WooCommerce <= 1.3.24 - Cross-Site Request Forgery via lock_unlock_terawallet
- First reported
- Sources
- Wordfence, seen
Where this comes from
We collect these reports from public security sources and rewrite them in plain words. Each problem shows its sources and the date we first saw it. This page never says whether your own site is affected: only a check of your site’s versions can tell.
Get an email when your site is affected.
Install Watchfox AI once. It checks your plugins and themes against this list every day, for free.
Install Watchfox AI (free)