EN ES
Start free

Advanced AJAX Product Filters: known security problems

5 known security problems reported for this WordPress plugin, with the affected versions, the fix and what to do.

Updated

In short

There are 5 known security problems on this page. Each one has a fixed version. Updating to version 3.2.1 or newer covers every fixed problem listed here.

Based on public reports. Check the plugin’s changelog. Watchfox AI may be wrong.

Get an email when your site is affected: install Watchfox AI (free)

This week

A stranger could plant harmful code that runs for your visitors or admins

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 3.2.0.3
Fixed in
3.2.1
What to do
If your site has an affected version, update Advanced AJAX Product Filters to version 3.2.1 or newer.
Official ID
CVE-2026-66439
Report title
Advanced AJAX Product Filters <= 3.2.0.3 - Unauthenticated Stored Cross-Site Scripting
First reported
Sources
This week

Someone with an author account on your site could in some setups, take over your site

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 3.1.9.6
Fixed in
3.1.9.7
What to do
If your site has an affected version, update Advanced AJAX Product Filters to version 3.1.9.7 or newer.
Official ID
CVE-2026-1426
Report title
Advanced AJAX Product Filters <= 3.1.9.6 - Authenticated (Author+) PHP Object Injection via Live Composer Compatibility
First reported
Sources
This week

Someone could plant harmful code that runs for your visitors or admins (up to and including 1.6.8.1)

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 1.6.8.1
Fixed in
1.6.8.2
What to do
If your site has an affected version, update Advanced AJAX Product Filters to version 1.6.8.2 or newer.
Official ID
CVE-2025-1505
Report title
Advanced AJAX Product Filters <= 1.6.8.1 - Reflected Cross-Site Scripting
First reported
Sources
This week

Someone could plant harmful code that runs for your visitors or admins (up to and including 1.5.4.6)

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 1.5.4.6
Fixed in
1.5.4.7
What to do
If your site has an affected version, update Advanced AJAX Product Filters to version 1.5.4.7 or newer.
Official ID
CVE-2021-24432
Report title
Advanced AJAX Product Filters <= 1.5.4.6 - Reflected Cross-Site Scripting
First reported
Sources
This week

Someone could use it to harm your site

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Before 1.3.7
Fixed in
1.3.7
What to do
If your site has an affected version, update Advanced AJAX Product Filters to version 1.3.7 or newer.
Report title
WooCommerce AJAX Product Filters <= 1.3.6 - Arbitrary Settings Update
First reported
Sources

Where this comes from

We collect these reports from public security sources and rewrite them in plain words. Each problem shows its sources and the date we first saw it. This page never says whether your own site is affected: only a check of your site’s versions can tell.

All plugins and themes

Get an email when your site is affected.

Install Watchfox AI once. It checks your plugins and themes against this list every day, for free.

Install Watchfox AI (free)