WooCommerce Stripe Payment Gateway: known security problems
5 known security problems reported for this WordPress plugin, with the affected versions, the fix and what to do.
Updated
In short
There are 5 known security problems on this page. Each one has a fixed version. Updating to version 10.8.0 or newer covers every fixed problem listed here.
Based on public reports. Check the plugin’s changelog. Watchfox AI may be wrong.
Get an email when your site is affected: install Watchfox AI (free)
A stranger could do things on your site they should not be allowed to
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 10.7.0
- Fixed in
- 10.8.0
- What to do
- If your site has an affected version, update WooCommerce Stripe Payment Gateway to version 10.8.0 or newer.
- Official ID
- CVE-2026-2381
- Report title
- WooCommerce Stripe Payment Gateway <= 10.7.0 - Missing Authorization to Unauthenticated Order Status Manipulation via 'order' Parameter
- First reported
- Sources
- Wordfence, seen
Someone could use it to harm your site
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 7.6.1
- Fixed in
- 7.6.2
- What to do
- If your site has an affected version, update WooCommerce Stripe Payment Gateway to version 7.6.2 or newer.
- Official ID
- CVE-2023-51502
- Report title
- WooCommerce Stripe Payment Gateway <= 7.6.1 - Insecure Direct Object Reference via update_payment_intent_ajax
- First reported
- Sources
- Wordfence, seen
Someone could trick a logged-in admin into changing settings without knowing
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Before 7.6.1
- Fixed in
- 7.6.1
- What to do
- If your site has an affected version, update WooCommerce Stripe Payment Gateway to version 7.6.1 or newer.
- Official ID
- CVE-2023-44999
- Report title
- Stripe Gateway <= 7.6.0 - Cross-Site Request Forgery
- First reported
- Sources
- Wordfence, seen
Someone could do things on your site they should not be allowed to
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 7.4.0
- Fixed in
- 7.4.1
- What to do
- If your site has an affected version, update WooCommerce Stripe Payment Gateway to version 7.4.1 or newer.
- Official ID
- CVE-2023-35049
- Report title
- WooCommerce Stripe Payment Gateway <= 7.4.0 - Missing Authorization
- First reported
- Sources
- Wordfence, seen
A stranger could use it to harm your site
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 5.5.0
- From 5.5.0 up to, but not including, 5.5.1
- From 5.6.0 up to, but not including, 5.6.3
- From 5.7.0 up to, but not including, 5.7.1
- From 5.8.0 up to, but not including, 5.8.2
- From 5.9.0 up to, but not including, 5.9.1
- From 6.0.0 up to, but not including, 6.0.1
- From 6.1.0 up to, but not including, 6.1.1
- From 6.2.0 up to, but not including, 6.2.1
- From 6.3.0 up to, but not including, 6.3.1
- From 6.4.0 up to, but not including, 6.4.4
- From 6.5.0 up to, but not including, 6.5.2
- From 6.6.0 up to, but not including, 6.6.1
- From 6.7.0 up to, but not including, 6.7.1
- From 6.8.0 up to, but not including, 6.8.1
- From 6.9.0 up to, but not including, 6.9.1
- From 7.0.0 up to, but not including, 7.0.3
- From 7.1.0 up to, but not including, 7.1.1
- From 7.2.0 up to, but not including, 7.2.1
- From 7.3.0 up to, but not including, 7.3.1
- From 7.4.0 up to and including 7.4.0
- Fixed in
- 5.5.1, 5.6.3, 5.7.1, 5.8.2, 5.9.1, 6.0.1, 6.1.1, 6.2.1, 6.3.1, 6.4.4, 6.5.2, 6.6.1, 6.7.1, 6.8.1, 6.9.1, 7.0.3, 7.1.1, 7.2.1, 7.3.1, 7.4.1
- What to do
- If your site has an affected version, update WooCommerce Stripe Payment Gateway to version 7.4.1 or newer.
- Official ID
- CVE-2023-34000
- Report title
- WooCommerce Stripe Payment Gateway <= 7.4.0 - Unauthenticated Insecure Direct Object Reference to Sensitive Information Disclosure
- First reported
- Sources
- Wordfence, seen
Where this comes from
We collect these reports from public security sources and rewrite them in plain words. Each problem shows its sources and the date we first saw it. This page never says whether your own site is affected: only a check of your site’s versions can tell.
Get an email when your site is affected.
Install Watchfox AI once. It checks your plugins and themes against this list every day, for free.
Install Watchfox AI (free)