WPML Multilingual & Multicurrency for WooCommerce: known security problems
8 known security problems reported for this WordPress plugin, with the affected versions, the fix and what to do.
Updated
In short
There are 8 known security problems on this page. Each one has a fixed version. Updating to version 5.6.3 or newer covers every fixed problem listed here.
Based on public reports. Check the plugin’s changelog. Watchfox AI may be wrong.
Get an email when your site is affected: install Watchfox AI (free)
Someone with a shop manager account on your site could in some setups, take over your site
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 5.5.8
- Fixed in
- 5.6.3
- What to do
- If your site has an affected version, update WPML Multilingual & Multicurrency for WooCommerce to version 5.6.3 or newer.
- Official ID
- CVE-2026-62130
- Report title
- WPML Multilingual & Multicurrency for WooCommerce <= 5.5.8 - Authenticated (Shop Manager+) PHP Object Injection
- First reported
- Sources
- Wordfence, seen
Someone with a shop manager account on your site could read or change the data in your site’s database (up to and including 5.5.7)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 5.5.7
- Fixed in
- 5.5.8
- What to do
- If your site has an affected version, update WPML Multilingual & Multicurrency for WooCommerce to version 5.5.8 or newer.
- Report title
- WPML Multilingual & Multicurrency for WooCommerce <= 5.5.7 - Authenticated (Shop Manager+) SQL Injection via Exchange Rate Field
- First reported
- Sources
- Wordfence, seen
Anyone with an account on your site, even a basic one could plant harmful code that runs for your visitors or admins
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 5.5.6
- Fixed in
- 5.5.7
- What to do
- If your site has an affected version, update WPML Multilingual & Multicurrency for WooCommerce to version 5.5.7 or newer.
- Official ID
- CVE-2026-66711
- Report title
- WPML Multilingual & Multicurrency for WooCommerce <= 5.5.6 - Authenticated (Subscriber+) Stored Cross-Site Scripting
- First reported
- Sources
- Wordfence, seen
Someone could do things on your site they should not be allowed to (up to and including 5.3.8)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 5.3.8
- Fixed in
- 5.3.9
- What to do
- If your site has an affected version, update WPML Multilingual & Multicurrency for WooCommerce to version 5.3.9 or newer.
- Official ID
- CVE-2025-26888
- Report title
- WooCommerce Multilingual & Multicurrency <= 5.3.8 - Missing Authorization
- First reported
- Sources
- Wordfence, seen
Someone could plant harmful code that runs for your visitors or admins
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 5.3.7
- Fixed in
- 5.3.8
- What to do
- If your site has an affected version, update WPML Multilingual & Multicurrency for WooCommerce to version 5.3.8 or newer.
- Official ID
- CVE-2024-8629
- Report title
- WooCommerce Multilingual & Multicurrency with WPML <= 5.3.7 - Reflected Cross-Site Scripting
- First reported
- Sources
- Wordfence, seen
Someone could do things on your site they should not be allowed to (up to and including 5.3.6)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 5.3.6
- Fixed in
- 5.3.7
- What to do
- If your site has an affected version, update WPML Multilingual & Multicurrency for WooCommerce to version 5.3.7 or newer.
- Official ID
- CVE-2024-44006
- Report title
- WooCommerce Multilingual & Multicurrency <= 5.3.6 - Missing Authorization
- First reported
- Sources
- Wordfence, seen
Someone with a shop manager account on your site could read or change the data in your site’s database (up to and including 5.3.3.1)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 5.3.3.1
- Fixed in
- 5.3.4
- What to do
- If your site has an affected version, update WPML Multilingual & Multicurrency for WooCommerce to version 5.3.4 or newer.
- Official ID
- CVE-2024-32602
- Report title
- WooCommerce Multilingual & Multicurrency with WPML <= 5.3.3.1 - Authenticated (Shop Manager+) SQL Injection
- First reported
- Sources
- Wordfence, seen
Someone could do things on your site they should not be allowed to (up to and including 5.3.4)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 5.3.4
- Fixed in
- 5.3.5
- What to do
- If your site has an affected version, update WPML Multilingual & Multicurrency for WooCommerce to version 5.3.5 or newer.
- Official ID
- CVE-2024-30466
- Report title
- WooCommerce Multilingual & Multicurrency <= 5.3.4 - Missing Authorization
- First reported
- Sources
- Wordfence, seen
Where this comes from
We collect these reports from public security sources and rewrite them in plain words. Each problem shows its sources and the date we first saw it. This page never says whether your own site is affected: only a check of your site’s versions can tell.
Get an email when your site is affected.
Install Watchfox AI once. It checks your plugins and themes against this list every day, for free.
Install Watchfox AI (free)