WooPayments: Integrated WooCommerce Payments: known security problems
7 known security problems reported for this WordPress plugin, with the affected versions, the fix and what to do.
Updated
In short
There are 7 known security problems on this page. Each one has a fixed version. Updating to version 10.6.0 or newer covers every fixed problem listed here.
Based on public reports. Check the plugin’s changelog. Watchfox AI may be wrong.
Get an email when your site is affected: install Watchfox AI (free)
A stranger could do things on your site they should not be allowed to
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 10.5.1
- Fixed in
- 10.6.0
- What to do
- If your site has an affected version, update WooPayments: Integrated WooCommerce Payments to version 10.6.0 or newer.
- Official ID
- CVE-2026-1710
- Report title
- WooPayments <= 10.5.1 - Missing Authorization to Unauthenticated Plugin Settings Update via save_upe_appearance_ajax
- First reported
- Sources
- Wordfence, seen
A stranger could use it to harm your site
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 6.6.2
- Fixed in
- 6.7.0
- What to do
- If your site has an affected version, update WooPayments: Integrated WooCommerce Payments to version 6.7.0 or newer.
- Official ID
- CVE-2023-51503
- Report title
- WooPayments – Fully Integrated Solution Built and Supported by Woo <= 6.6.2 - Unauthenticated Insecure Direct Object Reference
- First reported
- Sources
- Wordfence, seen
Someone with a contributor account on your site could plant harmful code that runs for your visitors or admins
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 6.4.2
- Fixed in
- 6.5.0
- What to do
- If your site has an affected version, update WooPayments: Integrated WooCommerce Payments to version 6.5.0 or newer.
- Official ID
- CVE-2023-49828
- Report title
- WooCommerce Payments <= 6.4.2 - Authenticated (Contributor+) Stored Cross-Site Scripting
- First reported
- Sources
- Wordfence, seen
Someone with a shop manager account on your site could read or change the data in your site’s database
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 5.9.0
- Fixed in
- 5.9.1
- What to do
- If your site has an affected version, update WooPayments: Integrated WooCommerce Payments to version 5.9.1 or newer.
- Official ID
- CVE-2023-35915
- Report title
- WooCommerce Payments <= 5.9.0 - Authenticated (Shop manager+) SQL Injection via currency parameters
- First reported
- Sources
- Wordfence, seen
Someone could do things on your site they should not be allowed to
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 5.9.0
- Fixed in
- 5.9.1
- What to do
- If your site has an affected version, update WooPayments: Integrated WooCommerce Payments to version 5.9.1 or newer.
- Official ID
- CVE-2023-35916
- Report title
- WooCommerce Payments <= 5.9.0 - Missing Authorization via redirect_pay_for_order_to_update_payment_method
- First reported
- Sources
- Wordfence, seen
Someone could take over your site as an admin
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- From 4.8.0 up to and including 5.6.1
- Fixed in
- 5.6.2
- What to do
- If your site has an affected version, update WooPayments: Integrated WooCommerce Payments to version 5.6.2 or newer.
- Official ID
- CVE-2023-28121
- Report title
- WooCommerce Payments 4.8.0 - 5.6.1 Authentication Bypass and Privilege Escalation
- First reported
- Sources
- Wordfence, seen
Someone could use it to harm your site
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- From 3.9.0 up to, but not including, 3.9.4
- From 4.0.0 up to, but not including, 4.0.3
- From 4.1.0 up to, but not including, 4.1.1
- From 4.2.0 up to, but not including, 4.2.2
- From 4.3.0 up to, but not including, 4.3.1
- From 4.4.0 up to, but not including, 4.4.1
- From 4.5.0 up to and including 4.5.0
- Fixed in
- 3.9.4, 4.0.3, 4.1.1, 4.2.2, 4.3.1, 4.4.1, 4.5.1
- What to do
- If your site has an affected version, update WooPayments: Integrated WooCommerce Payments to version 4.5.1 or newer.
- Report title
- WooCommerce Payments <= 4.5.0 - Payment Bypass
- First reported
- Sources
- Wordfence, seen
Where this comes from
We collect these reports from public security sources and rewrite them in plain words. Each problem shows its sources and the date we first saw it. This page never says whether your own site is affected: only a check of your site’s versions can tell.
Get an email when your site is affected.
Install Watchfox AI once. It checks your plugins and themes against this list every day, for free.
Install Watchfox AI (free)