EN ES
Start free

Stock Manager for WooCommerce: known security problems

4 known security problems reported for this WordPress plugin, with the affected versions, the fix and what to do.

Updated

In short

There are 4 known security problems on this page. Each one has a fixed version. Updating to version 3.6.0 or newer covers every fixed problem listed here.

Based on public reports. Check the plugin’s changelog. Watchfox AI may be wrong.

Get an email when your site is affected: install Watchfox AI (free)

This week

Someone could trick a logged-in admin into changing settings without knowing (before 3.6.0)

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Before 3.6.0
Fixed in
3.6.0
What to do
If your site has an affected version, update Stock Manager for WooCommerce to version 3.6.0 or newer.
Official ID
CVE-2026-24365
Report title
Stock Manager for WooCommerce < 3.6.0 - Cross-Site Request Forgery
First reported
Sources
This week

Someone could trick a logged-in admin into changing settings without knowing (before 2.11.0)

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Before 2.11.0
Fixed in
2.11.0
What to do
If your site has an affected version, update Stock Manager for WooCommerce to version 2.11.0 or newer.
Official ID
CVE-2023-35091
Report title
Stock Manager for WooCommerce <= 2.10.0 - Cross-Site Request Forgery
First reported
Sources
This week

Someone could run their own code on your site and take it over

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 2.5.7
Fixed in
2.6.0
What to do
If your site has an affected version, update Stock Manager for WooCommerce to version 2.6.0 or newer.
Official ID
CVE-2021-34619
Report title
WooCommerce Stock Manager <= 2.5.7 - Cross-Site Request Forgery to Arbitrary File Upload
First reported
Sources
This week

Someone could use it to harm your site

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 1.0.7
Fixed in
1.0.8
What to do
If your site has an affected version, update Stock Manager for WooCommerce to version 1.0.8 or newer.
Report title
WooCommerce Stock Manager < 1.0.9 - Authorization Bypass
First reported
Sources

Where this comes from

We collect these reports from public security sources and rewrite them in plain words. Each problem shows its sources and the date we first saw it. This page never says whether your own site is affected: only a check of your site’s versions can tell.

All plugins and themes

Get an email when your site is affected.

Install Watchfox AI once. It checks your plugins and themes against this list every day, for free.

Install Watchfox AI (free)