EN ES
Start free

Wholesale Suite: known security problems

6 known security problems reported for this WordPress plugin, with the affected versions, the fix and what to do.

Updated

In short

There are 6 known security problems on this page. Each one has a fixed version. Updating to version 2.2.7 or newer covers every fixed problem listed here.

Based on public reports. Check the plugin’s changelog. Watchfox AI may be wrong.

Get an email when your site is affected: install Watchfox AI (free)

This week

Someone could take over your site as an admin

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 2.2.6
Fixed in
2.2.7
What to do
If your site has an affected version, update Wholesale Suite to version 2.2.7 or newer.
Official ID
CVE-2026-27541
Report title
Wholesale Suite <= 2.2.6 - Authenticated (Shop Manager) Privilege Escalation
First reported
Sources
This week

Someone with a shop manager account on your site could take over your site as an admin

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 2.2.4.2
Fixed in
2.2.5
What to do
If your site has an affected version, update Wholesale Suite to version 2.2.5 or newer.
Official ID
CVE-2025-49924
Report title
Wholesale Suite <= 2.2.4.2 - Authenticated (Shop Manager+) Privilege Escalation
First reported
Sources
This week

Someone could do things on your site they should not be allowed to (up to and including 2.1.12)

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 2.1.12
Fixed in
2.2.0
What to do
If your site has an affected version, update Wholesale Suite to version 2.2.0 or newer.
Official ID
CVE-2024-38745
Report title
Wholesale Suite <= 2.1.12 - Missing Authorization
First reported
Sources
This week

Someone could do things on your site they should not be allowed to (up to and including 2.1.5)

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 2.1.5
Fixed in
2.1.6
What to do
If your site has an affected version, update Wholesale Suite to version 2.1.6 or newer.
Official ID
CVE-2022-34344
Report title
Wholesale Suite <= 2.1.5 - Missing Authorization to Plugin Settings Change
First reported
Sources
This week

Anyone with an account on your site, even a basic one could plant harmful code that runs for your visitors or admins

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 2.1.5
Fixed in
2.1.5.1
What to do
If your site has an affected version, update Wholesale Suite to version 2.1.5.1 or newer.
Official ID
CVE-2022-41640
Report title
Wholesale Suite <= 2.1.5 - Authenticated (Subscriber+) Cross-Site Scripting
First reported
Sources
This week

Someone could trick a logged-in admin into changing settings without knowing

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 2.1.5
Fixed in
2.1.5.1
What to do
If your site has an affected version, update Wholesale Suite to version 2.1.5.1 or newer.
Report title
Wholesale Suite <= 2.1.5 - Cross-Site Request Forgery
First reported
Sources

Where this comes from

We collect these reports from public security sources and rewrite them in plain words. Each problem shows its sources and the date we first saw it. This page never says whether your own site is affected: only a check of your site’s versions can tell.

All plugins and themes

Get an email when your site is affected.

Install Watchfox AI once. It checks your plugins and themes against this list every day, for free.

Install Watchfox AI (free)