EN ES
Start free

Woostify Sites Library: known security problems

4 known security problems reported for this WordPress plugin, with the affected versions, the fix and what to do.

Updated

In short

There are 4 known security problems on this page. 3 of them have a fixed version. Updating to version 1.4.8 or newer covers every fixed problem listed here.

Based on public reports. Check the plugin’s changelog. Watchfox AI may be wrong.

Get an email when your site is affected: install Watchfox AI (free)

This week

Someone could do things on your site they should not be allowed to (up to and including 1.6.2)

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 1.6.2
Fixed in
No fixed version yet
What to do
There is no fixed version yet. If your site uses it, think about turning it off or replacing it until a fix comes out.
Official ID
CVE-2025-66076
Report title
Woostify Sites Library <= 1.6.2 - Missing Authorization
First reported
Sources
This week

Anyone with an account on your site, even a basic one could do things on your site they should not be allowed to

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 1.4.7
Fixed in
1.4.8
What to do
If your site has an affected version, update Woostify Sites Library to version 1.4.8 or newer.
Official ID
CVE-2023-6279
Report title
Woostify Sites Library <= 1.4.7 - Missing Authorization to Authenticated (Subscriber+) Limited Options Update
First reported
Sources
This week

Someone could do things on your site they should not be allowed to (up to and including 1.4.3)

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 1.4.3
Fixed in
1.4.4
What to do
If your site has an affected version, update Woostify Sites Library to version 1.4.4 or newer.
Report title
Appsero <= 1.2.1 - Missing Authorization
First reported
Sources
This week

Someone could trick a logged-in admin into changing settings without knowing

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 1.4.3
Fixed in
1.4.4
What to do
If your site has an affected version, update Woostify Sites Library to version 1.4.4 or newer.
Official ID
CVE-2022-47150
Report title
Appsero <= 1.2.0 - Cross-Site Request Forgery
First reported
Sources

Where this comes from

We collect these reports from public security sources and rewrite them in plain words. Each problem shows its sources and the date we first saw it. This page never says whether your own site is affected: only a check of your site’s versions can tell.

All plugins and themes

Get an email when your site is affected.

Install Watchfox AI once. It checks your plugins and themes against this list every day, for free.

Install Watchfox AI (free)