EN ES
Start free

WP Popular Posts: known security problems

8 known security problems reported for this WordPress plugin, with the affected versions, the fix and what to do.

Updated

In short

There are 8 known security problems on this page. Each one has a fixed version. Updating to version 7.4.3 or newer covers every fixed problem listed here.

Based on public reports. Check the plugin’s changelog. Watchfox AI may be wrong.

Get an email when your site is affected: install Watchfox AI (free)

This week

A stranger could use it to harm your site (up to and including 7.4.2)

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 7.4.2
Fixed in
7.4.3
What to do
If your site has an affected version, update WP Popular Posts to version 7.4.3 or newer.
Official ID
CVE-2026-92548
Report title
WP Popular Posts <= 7.4.2 - Unauthenticated Information Disclosure in 'post_type' and 'context' Parameters
First reported
Sources
This week

A stranger could use it to harm your site (up to and including 7.1.0)

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 7.1.0
Fixed in
7.2.0
What to do
If your site has an affected version, update WP Popular Posts to version 7.2.0 or newer.
Official ID
CVE-2024-11733
Report title
WordPress Popular Posts <= 7.1.0 - Unauthenticated Arbitrary Shortcode Execution
First reported
Sources
This week

Someone with a contributor account on your site could plant harmful code that runs for your visitors or admins

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Before 6.3.3
Fixed in
6.3.3
What to do
If your site has an affected version, update WP Popular Posts to version 6.3.3 or newer.
Official ID
CVE-2023-45607
Report title
WordPress Popular Posts <= 6.3.2 - Authenticated (Contributor+) Stored Cross-Site Scripting via Shortcode
First reported
Sources
This week

A stranger could use it to harm your site (up to and including 6.0.5)

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 6.0.5
Fixed in
6.1.0
What to do
If your site has an affected version, update WP Popular Posts to version 6.1.0 or newer.
Official ID
CVE-2022-43468
Report title
WordPress Popular Posts <= 6.0.5 - Unauthenticated Views Changes
First reported
Sources
This week

Someone could plant harmful code that runs for your visitors or admins (up to and including 5.5.1)

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 5.5.1
Fixed in
6.0.0
What to do
If your site has an affected version, update WP Popular Posts to version 6.0.0 or newer.
Report title
WordPress Popular Posts <= 5.5.1 - Reflected Cross-Site Scripting
First reported
Sources
This week

Someone could run their own code on your site and take it over

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 5.3.2
Fixed in
5.3.3
What to do
If your site has an affected version, update WP Popular Posts to version 5.3.3 or newer.
Official ID
CVE-2021-42362
Report title
WordPress Popular Posts <= 5.3.2 - Authenticated Arbitrary File Upload
First reported
Sources
This week

Someone could plant harmful code that runs for your visitors or admins (up to and including 5.3.3)

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 5.3.3
Fixed in
5.3.4
What to do
If your site has an affected version, update WP Popular Posts to version 5.3.4 or newer.
Official ID
CVE-2021-36872
Report title
WordPress Popular Posts <= 5.3.3 - Authenticated (Admin+) Stored Cross-Site Scripting
First reported
Sources
This week

Someone could plant harmful code that runs for your visitors or admins (before 5.3.3)

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Before 5.3.3
Fixed in
5.3.3
What to do
If your site has an affected version, update WP Popular Posts to version 5.3.3 or newer.
Official ID
CVE-2021-20746
Report title
WordPress Popular Posts <= 5.3.2 - Authenticated Cross-Site Scripting
First reported
Sources

Where this comes from

We collect these reports from public security sources and rewrite them in plain words. Each problem shows its sources and the date we first saw it. This page never says whether your own site is affected: only a check of your site’s versions can tell.

All plugins and themes

Get an email when your site is affected.

Install Watchfox AI once. It checks your plugins and themes against this list every day, for free.

Install Watchfox AI (free)