WP 2FA: known security problems
14 known security problems reported for this WordPress plugin, with the affected versions, the fix and what to do.
Updated
In short
There are 14 known security problems on this page. Each one has a fixed version. Updating to version 4.2.0 or newer covers every fixed problem listed here.
Based on public reports. Check the plugin’s changelog. Watchfox AI may be wrong.
Get an email when your site is affected: install Watchfox AI (free)
Someone who already has an admin account could use it to harm your site
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Before 4.2.0
- Fixed in
- 4.2.0
- What to do
- If your site has an affected version, update WP 2FA to version 4.2.0 or newer.
- Official ID
- CVE-2026-108066
- Report title
- WP 2FA – Two-factor authentication for WordPress < 4.2.0 - Authenticated (Administrator+) Insecure Direct Object Reference
- First reported
- Sources
- Wordfence, seen
Someone could trick a logged-in admin into changing settings without knowing (up to and including 4.1.0)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 4.1.0
- Fixed in
- 4.2.0
- What to do
- If your site has an affected version, update WP 2FA to version 4.2.0 or newer.
- Official ID
- CVE-2026-62142
- Report title
- WP 2FA – Two-factor authentication for WordPress <= 4.1.0 - Cross-Site Request Forgery
- First reported
- Sources
- Wordfence, seen
A stranger could take over your site as an admin
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 4.0.0
- Fixed in
- 4.1.0
- What to do
- If your site has an affected version, update WP 2FA to version 4.1.0 or newer.
- Official ID
- CVE-2026-103514
- Report title
- 2FA <= 4.0.0 - Unauthenticated Two-Factor Authentication Bypass
- First reported
- Sources
- Wordfence, seen
Someone could take over your site as an admin (up to and including 4.0.0)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 4.0.0
- Fixed in
- 4.1.0
- What to do
- If your site has an affected version, update WP 2FA to version 4.1.0 or newer.
- Official ID
- CVE-2026-15372
- Report title
- 2FA <= 4.0.0 - Two-Factor Authentication Bypass
- First reported
- Sources
- Wordfence, seen
Anyone with an account on your site, even a basic one could take over your site as an admin
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 3.1.1.1
- Fixed in
- 3.1.1.2
- What to do
- If your site has an affected version, update WP 2FA to version 3.1.1.2 or newer.
- Official ID
- CVE-2026-12988
- Report title
- WP 2FA <= 3.1.1.1 - Authenticated (Subscriber+) Account Takeover
- First reported
- Sources
- Wordfence, seen
Someone could take over your site as an admin (up to and including 2.9.3)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.9.3
- Fixed in
- 3.0.0
- What to do
- If your site has an affected version, update WP 2FA to version 3.0.0 or newer.
- Official ID
- CVE-2025-12628
- Report title
- WP 2FA – Two-factor authentication for WordPress <= 2.9.3 - 2-Factor Authentication Bypass
- First reported
- Sources
- Wordfence, seen
A stranger could use it to harm your site
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.6.3
- Fixed in
- 2.6.4
- What to do
- If your site has an affected version, update WP 2FA to version 2.6.4 or newer.
- Official ID
- CVE-2022-44587
- Report title
- WP 2FA <= 2.6.3 - Unauthenticated Information Exposure via Log File
- First reported
- Sources
- Wordfence, seen
Someone could plant harmful code that runs for your visitors or admins (up to and including 2.6.2)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.6.2
- Fixed in
- 2.6.3
- What to do
- If your site has an affected version, update WP 2FA to version 2.6.3 or newer.
- Official ID
- CVE-2024-32568
- Report title
- WP 2FA – Two-factor authentication for WordPress <= 2.6.2 - Reflected Cross-Site Scripting
- First reported
- Sources
- Wordfence, seen
Someone could trick a logged-in admin into changing settings without knowing (up to and including 2.5.0)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.5.0
- Fixed in
- 2.6.0
- What to do
- If your site has an affected version, update WP 2FA to version 2.6.0 or newer.
- Official ID
- CVE-2023-6520
- Report title
- WP 2FA – Two-factor authentication for WordPress <= 2.5.0 - Cross-Site Request Forgery
- First reported
- Sources
- Wordfence, seen
Someone could use it to harm your site (up to and including 2.5.0)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.5.0
- Fixed in
- 2.6.0
- What to do
- If your site has an affected version, update WP 2FA to version 2.6.0 or newer.
- Official ID
- CVE-2023-6506
- Report title
- WP 2FA <= 2.5.0 - Insecure Direct Object Reference to Arbitrary Email Sending
- First reported
- Sources
- Wordfence, seen
Someone could do things on your site they should not be allowed to
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.2.0
- Fixed in
- 2.2.1
- What to do
- If your site has an affected version, update WP 2FA to version 2.2.1 or newer.
- Official ID
- CVE-2022-44595
- Report title
- WP 2FA – Two-factor authentication for WordPress <= 2.2.0 - Missing Authorization
- First reported
- Sources
- Wordfence, seen
Someone could see private information they should not see
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.2.1
- Fixed in
- 2.3.0
- What to do
- If your site has an affected version, update WP 2FA to version 2.3.0 or newer.
- Official ID
- CVE-2022-2891
- Report title
- WP 2FA <= 2.2.1 - Time-Based TOTP attack to Sensitive Information Exposure
- First reported
- Sources
- Wordfence, seen
Someone could plant harmful code that runs for your visitors or admins (up to and including 2.2.0)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.2.0
- Fixed in
- 2.2.1
- What to do
- If your site has an affected version, update WP 2FA to version 2.2.1 or newer.
- Official ID
- CVE-2022-1527
- Report title
- WP 2FA – Two-factor authentication for WordPress <= 2.2.0 - Reflected Cross-Site Scripting
- First reported
- Sources
- Wordfence, seen
Someone could use it to harm your site (up to and including 2.1.0)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.1.0
- Fixed in
- 2.2.0
- What to do
- If your site has an affected version, update WP 2FA to version 2.2.0 or newer.
- Report title
- WP 2FA – Two-factor authentication for WordPress <= 2.1.0 - Insecure Direct Object Reference
- First reported
- Sources
- Wordfence, seen
Where this comes from
We collect these reports from public security sources and rewrite them in plain words. Each problem shows its sources and the date we first saw it. This page never says whether your own site is affected: only a check of your site’s versions can tell.
Get an email when your site is affected.
Install Watchfox AI once. It checks your plugins and themes against this list every day, for free.
Install Watchfox AI (free)