AI-Powered Carousel, Slider, Video & Photo Gallery Blocks by WP Carousel: known security problems
7 known security problems reported for this WordPress plugin, with the affected versions, the fix and what to do.
Updated
In short
There are 7 known security problems on this page. Each one has a fixed version. Updating to version 2.7.11 or newer covers every fixed problem listed here.
Based on public reports. Check the plugin’s changelog. Watchfox AI may be wrong.
Get an email when your site is affected: install Watchfox AI (free)
Someone with a contributor account on your site could plant harmful code that runs for your visitors or admins (up to and including 2.7.10)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.7.10
- Fixed in
- 2.7.11
- What to do
- If your site has an affected version, update AI-Powered Carousel, Slider, Video & Photo Gallery Blocks by WP Carousel to version 2.7.11 or newer.
- Official ID
- CVE-2026-4665
- Report title
- WP Carousel Free <= 2.7.10 - Authenticated (Contributor+) Stored Cross-Site Scripting via 'data-caption' Attribute
- First reported
- Sources
- Wordfence, seen
Someone could plant harmful code that runs for your visitors or admins
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.7.3
- Fixed in
- 2.7.4
- What to do
- If your site has an affected version, update AI-Powered Carousel, Slider, Video & Photo Gallery Blocks by WP Carousel to version 2.7.4 or newer.
- Official ID
- CVE-2024-13314
- Report title
- Carousel, Slider, Gallery by WP Carousel <= 2.7.3 - Authenticated (Admin+) Stored Cross-Site Scripting
- First reported
- Sources
- Wordfence, seen
Someone with a contributor account on your site could plant harmful code that runs for your visitors or admins (up to and including 2.6.8)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.6.8
- Fixed in
- 2.6.9
- What to do
- If your site has an affected version, update AI-Powered Carousel, Slider, Video & Photo Gallery Blocks by WP Carousel to version 2.6.9 or newer.
- Official ID
- CVE-2024-5020
- Report title
- Multiple Plugins <= (Various Versions) - Authenticated (Contributor+) Stored DOM-Based Cross-Site Scripting via FancyBox JavaScript Library
- First reported
- Sources
- Wordfence, seen
Someone with an editor account on your site could plant harmful code that runs for your visitors or admins
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.6.8
- Fixed in
- 2.6.9
- What to do
- If your site has an affected version, update AI-Powered Carousel, Slider, Video & Photo Gallery Blocks by WP Carousel to version 2.6.9 or newer.
- Official ID
- CVE-2024-4002
- Report title
- Carousel, Slider, Gallery by WP Carousel <= 2.6.8 - Authenticated (Editor+) Stored Cross-Site Scripting
- First reported
- Sources
- Wordfence, seen
Someone could in some setups, take over your site
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.6.3
- Fixed in
- 2.6.4
- What to do
- If your site has an affected version, update AI-Powered Carousel, Slider, Video & Photo Gallery Blocks by WP Carousel to version 2.6.4 or newer.
- Official ID
- CVE-2024-3020
- Report title
- Carousel, Slider, Gallery by WP Carousel – Image Carousel & Photo Gallery, Post Carousel & Post Grid, Product Carousel & Product Grid for WooCommerce <= 2.6.3 - Authenticated (Admin+) PHP Object Injection
- First reported
- Sources
- Wordfence, seen
Someone with a contributor account on your site could plant harmful code that runs for your visitors or admins (up to and including 2.6.3)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.6.3
- Fixed in
- 2.6.4
- What to do
- If your site has an affected version, update AI-Powered Carousel, Slider, Video & Photo Gallery Blocks by WP Carousel to version 2.6.4 or newer.
- Official ID
- CVE-2024-2949
- Report title
- Carousel, Slider, Gallery by WP Carousel – Image Carousel & Photo Gallery, Post Carousel & Post Grid, Product Carousel & Product Grid for WooCommerce <= 2.6.3 - Authenticated (Contributor+) Stored Cross-Site Scripting via 'sp_wp_carousel_shortcode'
- First reported
- Sources
- Wordfence, seen
Someone with a contributor account on your site could plant harmful code that runs for your visitors or admins (up to and including 2.5.2)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.5.2
- Fixed in
- 2.5.3
- What to do
- If your site has an affected version, update AI-Powered Carousel, Slider, Video & Photo Gallery Blocks by WP Carousel to version 2.5.3 or newer.
- Official ID
- CVE-2022-4482
- Report title
- Carousel, Slider, Gallery by WP Carousel <= 2.5.2 - Authenticated (Contributor+) Stored Cross-Site Scripting via Shortcode
- First reported
- Sources
- Wordfence, seen
Where this comes from
We collect these reports from public security sources and rewrite them in plain words. Each problem shows its sources and the date we first saw it. This page never says whether your own site is affected: only a check of your site’s versions can tell.
Get an email when your site is affected.
Install Watchfox AI once. It checks your plugins and themes against this list every day, for free.
Install Watchfox AI (free)