WP Database Backup: known security problems
14 known security problems reported for this WordPress plugin, with the affected versions, the fix and what to do.
Updated
In short
There are 14 known security problems on this page. Each one has a fixed version. Updating to version 7.12 or newer covers every fixed problem listed here.
Based on public reports. Check the plugin’s changelog. Watchfox AI may be wrong.
Get an email when your site is affected: install Watchfox AI (free)
Someone who already has an admin account could use it to harm your site
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 7.11
- Fixed in
- 7.12
- What to do
- If your site has an affected version, update WP Database Backup to version 7.12 or newer.
- Official ID
- CVE-2026-9834
- Report title
- WP Database Backup <= 7.11 - Authenticated (Administrator+) OS Command Injection via 'wp_db_exclude_table' Parameter
- First reported
- Sources
- Wordfence, seen
A stranger could use it to harm your site (up to and including 7.3)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 7.3
- Fixed in
- 7.4
- What to do
- If your site has an affected version, update WP Database Backup to version 7.4 or newer.
- Official ID
- CVE-2024-12330
- Report title
- WP Database Backup – Unlimited Database & Files Backup by Backup for WP <= 7.3 - Unauthenticated Database Back-Up Exposure
- First reported
- Sources
- Wordfence, seen
Someone could plant harmful code that runs for your visitors or admins (up to and including 5.8.3)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 5.8.3
- Fixed in
- 5.9
- What to do
- If your site has an affected version, update WP Database Backup to version 5.9 or newer.
- Official ID
- CVE-2022-2271
- Report title
- WP Database Backup <= 5.8.3 - Authenticated (Admin+) Stored Cross-Site Scripting
- First reported
- Sources
- Wordfence, seen
Someone could plant harmful code that runs for your visitors or admins (up to and including 5.8)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 5.8
- Fixed in
- 5.9
- What to do
- If your site has an affected version, update WP Database Backup to version 5.9 or newer.
- Report title
- WP Database Backup <= 5.9 - Authenticated (Admin+) Stored Cross-Site Scripting
- First reported
- Sources
- Wordfence, seen
A stranger could use it to harm your site (up to and including 5.5)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 5.5
- Fixed in
- 5.5.1
- What to do
- If your site has an affected version, update WP Database Backup to version 5.5.1 or newer.
- Official ID
- CVE-2020-7241
- Report title
- WP Database Backup <= 5.5 - Unauthenticated Information Disclosure
- First reported
- Sources
- Wordfence, seen
A stranger could use it to harm your site (before 5.2)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Before 5.2
- Fixed in
- 5.2
- What to do
- If your site has an affected version, update WP Database Backup to version 5.2 or newer.
- Official ID
- CVE-2019-25224
- Report title
- WP Database Backup < 5.2 - Unauthenticated OS Command Injection
- First reported
- Sources
- Wordfence, seen
Someone could plant harmful code that runs for your visitors or admins (up to and including 5.1.1)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 5.1.1
- Fixed in
- 5.1.2
- What to do
- If your site has an affected version, update WP Database Backup to version 5.1.2 or newer.
- Official ID
- CVE-2019-14949
- Report title
- WP Database Backup <= 5.1.1 - Cross-Site Scripting
- First reported
- Sources
- Wordfence, seen
A stranger could run their own code on your site and take it over
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 5.1.2
- Fixed in
- 5.1.3
- What to do
- If your site has an affected version, update WP Database Backup to version 5.1.3 or newer.
- Report title
- WP Database Backup <= 5.1.2 - Unauthenticated Settings Update to Remote Code Execution
- First reported
- Sources
- Wordfence, seen
Someone could trick a logged-in admin into changing settings without knowing (before 4.3.6)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Before 4.3.6
- Fixed in
- 4.3.6
- What to do
- If your site has an affected version, update WP Database Backup to version 4.3.6 or newer.
- Report title
- WP Database Backup <= 4.3.5 - Cross-Site Request Forgery
- First reported
- Sources
- Wordfence, seen
Someone could trick a logged-in admin into changing settings without knowing (before 4.3.3)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Before 4.3.3
- Fixed in
- 4.3.3
- What to do
- If your site has an affected version, update WP Database Backup to version 4.3.3 or newer.
- Official ID
- CVE-2016-10874
- Report title
- WP Database Backup <= 4.3.2 - Cross-Site Request Forgery
- First reported
- Sources
- Wordfence, seen
Someone could plant harmful code that runs for your visitors or admins (before 4.3.3)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Before 4.3.3
- Fixed in
- 4.3.3
- What to do
- If your site has an affected version, update WP Database Backup to version 4.3.3 or newer.
- Official ID
- CVE-2016-10873
- Report title
- WP Database Backup <= 4.3.2 - Cross-Site Scripting
- First reported
- Sources
- Wordfence, seen
Someone could plant harmful code that runs for your visitors or admins (before 4.3.1)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Before 4.3.1
- Fixed in
- 4.3.1
- What to do
- If your site has an affected version, update WP Database Backup to version 4.3.1 or newer.
- Official ID
- CVE-2016-10875
- Report title
- WP Database Backup <= 4.3 - Cross-Site Scripting
- First reported
- Sources
- Wordfence, seen
Someone could trick a logged-in admin into changing settings without knowing (up to and including 4.3)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 4.3
- Fixed in
- 4.3.1
- What to do
- If your site has an affected version, update WP Database Backup to version 4.3.1 or newer.
- Official ID
- CVE-2016-10876
- Report title
- WP Database Backup <= 4.3 - Cross-Site Request Forgery
- First reported
- Sources
- Wordfence, seen
Someone could plant harmful code that runs for your visitors or admins (before 3.4)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Before 3.4
- Fixed in
- 3.4
- What to do
- If your site has an affected version, update WP Database Backup to version 3.4 or newer.
- Report title
- WP Database Backup < 3.4 - Authenticated Stored Cross-Site Scripting
- First reported
- Sources
- Wordfence, seen
Where this comes from
We collect these reports from public security sources and rewrite them in plain words. Each problem shows its sources and the date we first saw it. This page never says whether your own site is affected: only a check of your site’s versions can tell.
Get an email when your site is affected.
Install Watchfox AI once. It checks your plugins and themes against this list every day, for free.
Install Watchfox AI (free)