WP Editor: known security problems
10 known security problems reported for this WordPress plugin, with the affected versions, the fix and what to do.
Updated
In short
There are 10 known security problems on this page. Each one has a fixed version. Updating to version 1.2.9.3 or newer covers every fixed problem listed here.
Based on public reports. Check the plugin’s changelog. Watchfox AI may be wrong.
Get an email when your site is affected: install Watchfox AI (free)
Someone could run their own code on your site and take it over
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 1.2.9.2
- Fixed in
- 1.2.9.3
- What to do
- If your site has an affected version, update WP Editor to version 1.2.9.3 or newer.
- Official ID
- CVE-2026-3772
- Report title
- WP Editor <= 1.2.9.2 - Cross-Site Request Forgery to Remote Code Execution via Plugin and Theme File Editor
- First reported
- Sources
- Wordfence, seen
Someone who already has an admin account could read or delete private files on your server
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 1.2.9.1
- Fixed in
- 1.2.9.2
- What to do
- If your site has an affected version, update WP Editor to version 1.2.9.2 or newer.
- Official ID
- CVE-2025-3295
- Report title
- WP Editor <= 1.2.9.1 - Authenticated (Administrator+) Directory Traversal to Arbitrary File Read
- First reported
- Sources
- Wordfence, seen
Someone who already has an admin account could use it to harm your site
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 1.2.9.1
- Fixed in
- 1.2.9.2
- What to do
- If your site has an affected version, update WP Editor to version 1.2.9.2 or newer.
- Official ID
- CVE-2025-3294
- Report title
- WP Editor <= 1.2.9.1 - Authenticated (Administrator+) Directory Traversal to Arbitrary File Update
- First reported
- Sources
- Wordfence, seen
Someone could use it to harm your site (up to and including 1.2.9)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 1.2.9
- Fixed in
- 1.2.9.1
- What to do
- If your site has an affected version, update WP Editor to version 1.2.9.1 or newer.
- Official ID
- CVE-2022-2446
- Report title
- WP Editor <= 1.2.9 - Authenticated (Admin+) PHAR Deserialization
- First reported
- Sources
- Wordfence, seen
Someone could plant harmful code that runs for your visitors or admins (up to and including 1.2.8)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 1.2.8
- Fixed in
- 1.2.9
- What to do
- If your site has an affected version, update WP Editor to version 1.2.9 or newer.
- Official ID
- CVE-2024-24700
- Report title
- WP Editor <= 1.2.8 - Reflected Cross-Site Scripting
- First reported
- Sources
- Wordfence, seen
Someone could see private information they should not see
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 1.2.7
- Fixed in
- 1.2.8
- What to do
- If your site has an affected version, update WP Editor to version 1.2.8 or newer.
- Official ID
- CVE-2024-25591
- Report title
- WP Editor <= 1.2.7 - Sensitive Information Exposure via log file
- First reported
- Sources
- Wordfence, seen
Someone could read or change the data in your site’s database
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 1.2.6.3
- Fixed in
- 1.2.7
- What to do
- If your site has an affected version, update WP Editor to version 1.2.7 or newer.
- Official ID
- CVE-2021-24151
- Report title
- WP Editor <= 1.2.6.3 - Authenticated (Admin+) SQL injection
- First reported
- Sources
- Wordfence, seen
Someone could use it to harm your site (before 1.2.6)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Before 1.2.6
- Fixed in
- 1.2.6
- What to do
- If your site has an affected version, update WP Editor to version 1.2.6 or newer.
- Official ID
- CVE-2016-10886
- Report title
- WP Editor < 1.2.6 - Incorrect Permission Assignment or Protection
- First reported
- Sources
- Wordfence, seen
Someone could plant harmful code that runs for your visitors or admins (before 1.2.6.3)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Before 1.2.6.3
- Fixed in
- 1.2.6.3
- What to do
- If your site has an affected version, update WP Editor to version 1.2.6.3 or newer.
- Official ID
- CVE-2016-10877
- Report title
- WP Editor <= 1.2.6.2 - Cross-Site Scripting
- First reported
- Sources
- Wordfence, seen
Someone could trick a logged-in admin into changing settings without knowing
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Before 1.2.6
- Fixed in
- 1.2.6
- What to do
- If your site has an affected version, update WP Editor to version 1.2.6 or newer.
- Official ID
- CVE-2016-10885
- Report title
- WP Editor < 1.2.6 - Cross-Site Request Forgery
- First reported
- Sources
- Wordfence, seen
Where this comes from
We collect these reports from public security sources and rewrite them in plain words. Each problem shows its sources and the date we first saw it. This page never says whether your own site is affected: only a check of your site’s versions can tell.
Get an email when your site is affected.
Install Watchfox AI once. It checks your plugins and themes against this list every day, for free.
Install Watchfox AI (free)