Nested Pages: known security problems
12 known security problems reported for this WordPress plugin, with the affected versions, the fix and what to do.
Updated
In short
There are 12 known security problems on this page. Each one has a fixed version. Updating to version 3.3.3 or newer covers every fixed problem listed here.
Based on public reports. Check the plugin’s changelog. Watchfox AI may be wrong.
Get an email when your site is affected: install Watchfox AI (free)
Someone with a contributor account on your site could in some setups, take over your site
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 3.3.2
- Fixed in
- 3.3.3
- What to do
- If your site has an affected version, update Nested Pages to version 3.3.3 or newer.
- Official ID
- CVE-2026-100512
- Report title
- Nested Pages <= 3.3.2 - Authenticated (Contributor+) PHP Object Injection
- First reported
- Sources
- Wordfence, seen
Someone with an editor account on your site could plant harmful code that runs for your visitors or admins (up to and including 3.2.14)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 3.2.14
- Fixed in
- 3.2.15
- What to do
- If your site has an affected version, update Nested Pages to version 3.2.15 or newer.
- Official ID
- CVE-2026-15233
- Report title
- Nested Pages <= 3.2.14 - Authenticated (Editor+) Stored Cross-Site Scripting
- First reported
- Sources
- Wordfence, seen
Someone with a contributor account on your site could plant harmful code that runs for your visitors or admins
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 3.2.12
- Fixed in
- 3.2.13
- What to do
- If your site has an affected version, update Nested Pages to version 3.2.13 or newer.
- Official ID
- CVE-2025-0718
- Report title
- Nested Pages <= 3.2.12 - Authenticated (Contributor+) Stored Cross-Site Scripting
- First reported
- Sources
- Wordfence, seen
Someone who already has an admin account could plant harmful code that runs for your visitors or admins (up to and including 3.2.9)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 3.2.9
- Fixed in
- 3.2.10
- What to do
- If your site has an affected version, update Nested Pages to version 3.2.10 or newer.
- Official ID
- CVE-2025-24579
- Report title
- Nested Pages <= 3.2.9 - Authenticated (Administrator+) Stored Cross-Site Scripting
- First reported
- Sources
- Wordfence, seen
Someone with an editor account on your site could plant harmful code that runs for your visitors or admins (up to and including 3.2.8)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 3.2.8
- Fixed in
- 3.2.9
- What to do
- If your site has an affected version, update Nested Pages to version 3.2.9 or newer.
- Official ID
- CVE-2024-8759
- Report title
- Nested Pages <= 3.2.8 - Authenticated (Editor+) Stored Cross-Site Scripting
- First reported
- Sources
- Wordfence, seen
Someone could read or delete private files on your server
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 3.2.7
- Fixed in
- 3.2.8
- What to do
- If your site has an affected version, update Nested Pages to version 3.2.8 or newer.
- Official ID
- CVE-2024-5943
- Report title
- Nested Pages <= 3.2.7 - Cross-Site Request Forgery to Local File Inclusion
- First reported
- Sources
- Wordfence, seen
Someone who already has an admin account could plant harmful code that runs for your visitors or admins (up to and including 3.2.6)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 3.2.6
- Fixed in
- 3.2.7
- What to do
- If your site has an affected version, update Nested Pages to version 3.2.7 or newer.
- Official ID
- CVE-2023-49195
- Report title
- Nested Pages <= 3.2.6 - Authenticated (Administrator+) Stored Cross-Site Scripting
- First reported
- Sources
- Wordfence, seen
Someone with an editor account on your site could do things on your site they should not be allowed to
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 3.2.3
- Fixed in
- 3.2.4
- What to do
- If your site has an affected version, update Nested Pages to version 3.2.4 or newer.
- Official ID
- CVE-2023-2434
- Report title
- Nested Pages <= 3.2.3 - Missing Authorization to Authenticated (Editor+) Plugin Settings Reset
- First reported
- Sources
- Wordfence, seen
Someone could plant harmful code that runs for your visitors or admins
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Before 3.1.21
- Fixed in
- 3.1.21
- What to do
- If your site has an affected version, update Nested Pages to version 3.1.21 or newer.
- Official ID
- CVE-2022-1990
- Report title
- Nested Pages <= 3.1.20 - Stored Cross-Site Scripting
- First reported
- Sources
- Wordfence, seen
Someone could send your visitors from your site to a harmful site
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 3.1.15
- Fixed in
- 3.1.16
- What to do
- If your site has an affected version, update Nested Pages to version 3.1.16 or newer.
- Official ID
- CVE-2021-38343
- Report title
- Nested Pages <= 3.1.15 - Open Redirect
- First reported
- Sources
- Wordfence, seen
Someone could trick a logged-in admin into changing settings without knowing
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 3.1.15
- Fixed in
- 3.1.16
- What to do
- If your site has an affected version, update Nested Pages to version 3.1.16 or newer.
- Official ID
- CVE-2021-38342
- Report title
- Nested Pages <= 3.1.15 - Cross-Site Request Forgery to Arbitrary Post Deletion and Modification
- First reported
- Sources
- Wordfence, seen
Someone could do things on your site they should not be allowed to
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 3.0.7
- Fixed in
- 3.0.8
- What to do
- If your site has an affected version, update Nested Pages to version 3.0.8 or newer.
- Report title
- Nested Pages <= 3.0.7 - Missing Authorization
- First reported
- Sources
- Wordfence, seen
Where this comes from
We collect these reports from public security sources and rewrite them in plain words. Each problem shows its sources and the date we first saw it. This page never says whether your own site is affected: only a check of your site’s versions can tell.
Get an email when your site is affected.
Install Watchfox AI once. It checks your plugins and themes against this list every day, for free.
Install Watchfox AI (free)