Widgets for Google Reviews: known security problems
6 known security problems reported for this WordPress plugin, with the affected versions, the fix and what to do.
Updated
In short
There are 6 known security problems on this page. Each one has a fixed version. Updating to version 13.3.1 or newer covers every fixed problem listed here.
Based on public reports. Check the plugin’s changelog. Watchfox AI may be wrong.
Get an email when your site is affected: install Watchfox AI (free)
Someone with an editor account on your site could plant harmful code that runs for your visitors or admins
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 13.3
- Fixed in
- 13.3.1
- What to do
- If your site has an affected version, update Widgets for Google Reviews to version 13.3.1 or newer.
- Official ID
- CVE-2026-11591
- Report title
- Widgets for Google Reviews <= 13.3 - Authenticated (Editor+) Stored Cross-Site Scripting via 'fomo-title' and 'fomo-text' Parameters
- First reported
- Sources
- Wordfence, seen
Someone with a contributor account on your site could plant harmful code that runs for your visitors or admins
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 13.2.1
- Fixed in
- 13.2.2
- What to do
- If your site has an affected version, update Widgets for Google Reviews to version 13.2.2 or newer.
- Official ID
- CVE-2025-9436
- Report title
- Widgets for Google Reviews <= 13.2.1 - Authenticated (Contributor+) Stored Cross-Site Scripting via trustindex Shortcode
- First reported
- Sources
- Wordfence, seen
A stranger could plant harmful code that runs for your visitors or admins
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 13.2.4
- Fixed in
- 13.2.5
- What to do
- If your site has an affected version, update Widgets for Google Reviews to version 13.2.5 or newer.
- Official ID
- CVE-2025-12510
- Report title
- Widgets for Google Reviews <= 13.2.4 - Unauthenticated Stored Cross-Site Scripting via Google Reviews
- First reported
- Sources
- Wordfence, seen
Someone with an editor account on your site could run their own code on your site and take it over
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 11.0.2
- Fixed in
- 11.1
- What to do
- If your site has an affected version, update Widgets for Google Reviews to version 11.1 or newer.
- Official ID
- CVE-2023-48275
- Report title
- Multiple Plugins by Trustindex.io <= (Various Versions)- Authenticated (Editor+) Arbitrary File Upload
- First reported
- Sources
- Wordfence, seen
Someone could trick a logged-in admin into changing settings without knowing
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 10.9
- Fixed in
- 10.9.1
- What to do
- If your site has an affected version, update Widgets for Google Reviews to version 10.9.1 or newer.
- Official ID
- CVE-2023-3254
- Report title
- Widgets for Google Reviews <= 10.9 - Cross-Site Request Forgery to Plugin Settings Reset
- First reported
- Sources
- Wordfence, seen
Someone with a contributor account on your site could use it to harm your site
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 9.7.1
- Fixed in
- 9.8
- What to do
- If your site has an affected version, update Widgets for Google Reviews to version 9.8 or newer.
- Official ID
- CVE-2022-4470
- Report title
- Widgets for Google Reviews < 9.8 - Authenticated (Contributor+) Stored XSS
- First reported
- Sources
- Wordfence, seen
Where this comes from
We collect these reports from public security sources and rewrite them in plain words. Each problem shows its sources and the date we first saw it. This page never says whether your own site is affected: only a check of your site’s versions can tell.
Get an email when your site is affected.
Install Watchfox AI once. It checks your plugins and themes against this list every day, for free.
Install Watchfox AI (free)