Shield Security: known security problems
12 known security problems reported for this WordPress plugin, with the affected versions, the fix and what to do.
Updated
In short
There are 12 known security problems on this page. Each one has a fixed version. Updating to version 22.3.4 or newer covers every fixed problem listed here.
Based on public reports. Check the plugin’s changelog. Watchfox AI may be wrong.
Get an email when your site is affected: install Watchfox AI (free)
A stranger could plant harmful code that runs for your visitors or admins (up to and including 22.3.2)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 22.3.2
- Fixed in
- 22.3.4
- What to do
- If your site has an affected version, update Shield Security to version 22.3.4 or newer.
- Official ID
- CVE-2026-118057
- Report title
- Shield Security <= 22.3.2 - Unauthenticated Stored Cross-Site Scripting via Request Path (REQUEST_URI) in Traffic Log
- First reported
- Sources
- Wordfence, seen
Someone could read or change the data in your site’s database
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 21.0.8
- Fixed in
- 21.0.10
- What to do
- If your site has an affected version, update Shield Security to version 21.0.10 or newer.
- Official ID
- CVE-2026-0722
- Report title
- Shield Security <= 21.0.8 - Cross-Site Request Forgery to SQL Injection
- First reported
- Sources
- Wordfence, seen
A stranger could plant harmful code that runs for your visitors or admins (up to and including 21.0.8)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 21.0.8
- Fixed in
- 21.0.10
- What to do
- If your site has an affected version, update Shield Security to version 21.0.10 or newer.
- Official ID
- CVE-2026-0561
- Report title
- Shield Security <= 21.0.8 - Unauthenticated Reflected Cross-Site Scripting via 'message' Parameter
- First reported
- Sources
- Wordfence, seen
Anyone with an account on your site, even a basic one could do things on your site they should not be allowed to
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 21.0.9
- Fixed in
- 21.0.10
- What to do
- If your site has an affected version, update Shield Security to version 21.0.10 or newer.
- Official ID
- CVE-2025-14427
- Report title
- Shield Security: Blocks Bots, Protects Users, and Prevents Security Breaches <= 21.0.9 - Missing Authorization to Authenticated (Subscriber+) Email MFA Update
- First reported
- Sources
- Wordfence, seen
Anyone with an account on your site, even a basic one could use it to harm your site
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 21.0.9
- Fixed in
- 21.0.10
- What to do
- If your site has an affected version, update Shield Security to version 21.0.10 or newer.
- Official ID
- CVE-2025-15370
- Report title
- Shield Security <= 21.0.9 - Authenticated (Subscriber+) Insecure Direct Object Reference to Disable Google Authenticator
- First reported
- Sources
- Wordfence, seen
Someone could plant harmful code that runs for your visitors or admins (up to and including 20.0.5)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 20.0.5
- Fixed in
- 20.0.6
- What to do
- If your site has an affected version, update Shield Security to version 20.0.6 or newer.
- Official ID
- CVE-2024-7313
- Report title
- Shield Security – Smart Bot Blocking & Intrusion Prevention Security <= 20.0.5 - Reflected Cross-Site Scripting
- First reported
- Sources
- Wordfence, seen
Someone could trick a logged-in admin into changing settings without knowing
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 19.1.10
- Fixed in
- 19.1.11
- What to do
- If your site has an affected version, update Shield Security to version 19.1.11 or newer.
- Official ID
- CVE-2024-4344
- Report title
- Shield Security – Smart Bot Blocking & Intrusion Prevention Security <= 19.1.13 - Cross-Site Request Forgery
- First reported
- Sources
- Wordfence, seen
A stranger could read or delete private files on your server
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 18.5.9
- Fixed in
- 18.5.10
- What to do
- If your site has an affected version, update Shield Security to version 18.5.10 or newer.
- Official ID
- CVE-2023-6989
- Report title
- Shield Security – Smart Bot Blocking & Intrusion Prevention Security <= 18.5.9 - Unauthenticated Local File Inclusion
- First reported
- Sources
- Wordfence, seen
A stranger could plant harmful code that runs for your visitors or admins (up to and including 18.5.7)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 18.5.7
- Fixed in
- 18.5.8
- What to do
- If your site has an affected version, update Shield Security to version 18.5.8 or newer.
- Official ID
- CVE-2024-22163
- Report title
- Shield Security <= 18.5.7 - Unauthenticated Stored Cross-Site Scripting via getColumnContent_Page
- First reported
- Sources
- Wordfence, seen
A stranger could plant harmful code that runs for your visitors or admins (before 17.0.18)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Before 17.0.18
- Fixed in
- 17.0.18
- What to do
- If your site has an affected version, update Shield Security to version 17.0.18 or newer.
- Official ID
- CVE-2023-0992
- Report title
- Shield Security <= 17.0.17 - Unauthenticated Stored Cross-Site Scripting
- First reported
- Sources
- Wordfence, seen
Someone could do things on your site they should not be allowed to
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Before 17.0.18
- Fixed in
- 17.0.18
- What to do
- If your site has an affected version, update Shield Security to version 17.0.18 or newer.
- Official ID
- CVE-2023-0993
- Report title
- Shield Security <= 17.0.17 - Missing Authorization
- First reported
- Sources
- Wordfence, seen
Someone could plant harmful code that runs for your visitors or admins (up to and including 13.0.5)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 13.0.5
- Fixed in
- 13.0.6
- What to do
- If your site has an affected version, update Shield Security to version 13.0.6 or newer.
- Official ID
- CVE-2022-0211
- Report title
- Shield Security <= 13.0.5 - Admin+ Stored Cross-Site Scripting
- First reported
- Sources
- Wordfence, seen
Where this comes from
We collect these reports from public security sources and rewrite them in plain words. Each problem shows its sources and the date we first saw it. This page never says whether your own site is affected: only a check of your site’s versions can tell.
Get an email when your site is affected.
Install Watchfox AI once. It checks your plugins and themes against this list every day, for free.
Install Watchfox AI (free)