EN ES
Start free

WP Store Locator: known security problems

4 known security problems reported for this WordPress plugin, with the affected versions, the fix and what to do.

Updated

In short

There are 4 known security problems on this page. Each one has a fixed version. Updating to version 3.1.0 or newer covers every fixed problem listed here.

Based on public reports. Check the plugin’s changelog. Watchfox AI may be wrong.

Get an email when your site is affected: install Watchfox AI (free)

This week

Someone with a contributor account on your site could plant harmful code that runs for your visitors or admins (up to and including 3.0.3)

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 3.0.3
Fixed in
3.1.0
What to do
If your site has an affected version, update WP Store Locator to version 3.1.0 or newer.
Official ID
CVE-2026-105078
Report title
WP Store Locator <= 3.0.3 - Authenticated (Contributor+) Stored Cross-Site Scripting
First reported
Sources
This week

A stranger could slow down or crash your site

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Before 3.0.0
Fixed in
3.0.0
What to do
If your site has an affected version, update WP Store Locator to version 3.0.0 or newer.
Official ID
CVE-2026-94681
Report title
WP Store Locator < 3.0.0 - Unauthenticated Denial of Service
First reported
Sources
This week

Someone with a contributor account on your site could plant harmful code that runs for your visitors or admins (up to and including 2.2.261)

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 2.2.261
Fixed in
2.3.0
What to do
If your site has an affected version, update WP Store Locator to version 2.3.0 or newer.
Official ID
CVE-2026-3361
Report title
WP Store Locator <= 2.2.261 - Authenticated (Contributor+) Stored Cross-Site Scripting via 'wpsl_address' Post Meta
First reported
Sources
This week

Someone with a contributor account on your site could in some setups, take over your site

A trusted security source confirmed it. If your site has an affected version, fix it this week.

Affected versions
  • Up to and including 2.2.260
Fixed in
2.2.261
What to do
If your site has an affected version, update WP Store Locator to version 2.2.261 or newer.
Official ID
CVE-2025-52737
Report title
Store Locator <= 2.2.260 - Authenticated (Contributor+) PHP Object Injection
First reported
Sources

Where this comes from

We collect these reports from public security sources and rewrite them in plain words. Each problem shows its sources and the date we first saw it. This page never says whether your own site is affected: only a check of your site’s versions can tell.

All plugins and themes

Get an email when your site is affected.

Install Watchfox AI once. It checks your plugins and themes against this list every day, for free.

Install Watchfox AI (free)