WPIDE – File Manager & Code Editor: known security problems
8 known security problems reported for this WordPress plugin, with the affected versions, the fix and what to do.
Updated
In short
There are 8 known security problems on this page. Each one has a fixed version. Updating to version 3.5.8 or newer covers every fixed problem listed here.
Based on public reports. Check the plugin’s changelog. Watchfox AI may be wrong.
Get an email when your site is affected: install Watchfox AI (free)
A stranger could plant harmful code that runs for your visitors or admins
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 3.5.7
- Fixed in
- 3.5.8
- What to do
- If your site has an affected version, update WPIDE – File Manager & Code Editor to version 3.5.8 or newer.
- Official ID
- CVE-2026-66440
- Report title
- WPIDE – File Manager & Code Editor <= 3.5.7 - Unauthenticated Stored Cross-Site Scripting
- First reported
- Sources
- Wordfence, seen
Someone could trick a logged-in admin into changing settings without knowing
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 3.5.6
- Fixed in
- 3.5.7
- What to do
- If your site has an affected version, update WPIDE – File Manager & Code Editor to version 3.5.7 or newer.
- Official ID
- CVE-2026-57766
- Report title
- WPIDE – File Manager & Code Editor <= 3.5.6 - Cross-Site Request Forgery
- First reported
- Sources
- Wordfence, seen
Someone could plant harmful code that runs for your visitors or admins (up to and including 3.5.1)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 3.5.1
- Fixed in
- 3.5.2
- What to do
- If your site has an affected version, update WPIDE – File Manager & Code Editor to version 3.5.2 or newer.
- Official ID
- CVE-2024-13362
- Report title
- Freemius <= 2.10.1 - Reflected DOM-Based Cross-Site Scripting via url Parameter
- First reported
- Sources
- Wordfence, seen
A stranger could use it to harm your site
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 3.4.9
- Fixed in
- 3.5.0
- What to do
- If your site has an affected version, update WPIDE – File Manager & Code Editor to version 3.5.0 or newer.
- Official ID
- CVE-2024-9546
- Report title
- WPIDE <= 3.4.9 - Unauthenticated Full Path Dislcosure
- First reported
- Sources
- Wordfence, seen
Someone could plant harmful code that runs for your visitors or admins (from 3.0 up to and including 3.4.6)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- From 3.0 up to and including 3.4.6
- Fixed in
- 3.4.7
- What to do
- If your site has an affected version, update WPIDE – File Manager & Code Editor to version 3.4.7 or newer.
- Official ID
- CVE-2023-33999
- Report title
- Freemius SDK <= 2.5.9 - Reflected Cross-Site Scripting via fs_request_get
- First reported
- Sources
- Wordfence, seen
Someone who already has an admin account could read or delete private files on your server
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.6
- Fixed in
- 3.0
- What to do
- If your site has an affected version, update WPIDE – File Manager & Code Editor to version 3.0 or newer.
- Official ID
- CVE-2022-35235
- Report title
- WPide <= 2.6 - Authenticated (Administrator+) Arbitrary File Read
- First reported
- Sources
- Wordfence, seen
Someone who already has an admin account could run their own code on your site and take it over
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.6
- Fixed in
- 3.0
- What to do
- If your site has an affected version, update WPIDE – File Manager & Code Editor to version 3.0 or newer.
- Official ID
- CVE-2022-40217
- Report title
- WPide <= 2.6 - Authenticated (Administrator+) Arbitrary File Upload
- First reported
- Sources
- Wordfence, seen
Someone could read or delete private files on your server
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.6
- Fixed in
- 3.0
- What to do
- If your site has an affected version, update WPIDE – File Manager & Code Editor to version 3.0 or newer.
- Official ID
- CVE-2022-2261
- Report title
- WPIDE – File Manager & Code Editor <= 2.6 - Authenticated (Admininstrator+) Local File Inclusion
- First reported
- Sources
- Wordfence, seen
Where this comes from
We collect these reports from public security sources and rewrite them in plain words. Each problem shows its sources and the date we first saw it. This page never says whether your own site is affected: only a check of your site’s versions can tell.
Get an email when your site is affected.
Install Watchfox AI once. It checks your plugins and themes against this list every day, for free.
Install Watchfox AI (free)