YASR – Yet Another Star Rating Plugin for WordPress: known security problems
9 known security problems reported for this WordPress plugin, with the affected versions, the fix and what to do.
Updated
In short
There are 9 known security problems on this page. Each one has a fixed version. Updating to version 3.4.15 or newer covers every fixed problem listed here.
Based on public reports. Check the plugin’s changelog. Watchfox AI may be wrong.
Get an email when your site is affected: install Watchfox AI (free)
Someone could plant harmful code that runs for your visitors or admins (up to and including 3.4.12)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 3.4.12
- Fixed in
- 3.4.15
- What to do
- If your site has an affected version, update YASR – Yet Another Star Rating Plugin for WordPress to version 3.4.15 or newer.
- Official ID
- CVE-2024-13362
- Report title
- Freemius <= 2.10.1 - Reflected DOM-Based Cross-Site Scripting via url Parameter
- First reported
- Sources
- Wordfence, seen
Someone could do things on your site they should not be allowed to (up to and including 3.4.3)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 3.4.3
- Fixed in
- 3.4.4
- What to do
- If your site has an affected version, update YASR – Yet Another Star Rating Plugin for WordPress to version 3.4.4 or newer.
- Official ID
- CVE-2023-39305
- Report title
- Yet Another Stars Rating <= 3.4.3 - Missing Authorization via init
- First reported
- Sources
- Wordfence, seen
Someone could plant harmful code that runs for your visitors or admins (from 1.4.4 up to and including 3.4.1)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- From 1.4.4 up to and including 3.4.1
- Fixed in
- 3.4.2
- What to do
- If your site has an affected version, update YASR – Yet Another Star Rating Plugin for WordPress to version 3.4.2 or newer.
- Official ID
- CVE-2023-33999
- Report title
- Freemius SDK <= 2.5.9 - Reflected Cross-Site Scripting via fs_request_get
- First reported
- Sources
- Wordfence, seen
Someone could do things on your site they should not be allowed to (up to and including 3.3.8)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 3.3.8
- Fixed in
- 3.3.9
- What to do
- If your site has an affected version, update YASR – Yet Another Star Rating Plugin for WordPress to version 3.3.9 or newer.
- Official ID
- CVE-2023-37867
- Report title
- Yet Another Stars Rating <= 3.3.8 - Missing Authorization to Vote Tampering
- First reported
- Sources
- Wordfence, seen
Anyone with an account on your site, even a basic one could plant harmful code that runs for your visitors or admins
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 3.1.2
- Fixed in
- 3.1.3
- What to do
- If your site has an affected version, update YASR – Yet Another Star Rating Plugin for WordPress to version 3.1.3 or newer.
- Official ID
- CVE-2022-40699
- Report title
- Yet Another Stars Rating <= 3.1.2 - Authenticated (Subscriber+) Cross-Site Scripting via Shortcodes
- First reported
- Sources
- Wordfence, seen
Someone could do things on your site they should not be allowed to (before 2.0.2)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Before 2.0.2
- Fixed in
- 2.0.2
- What to do
- If your site has an affected version, update YASR – Yet Another Star Rating Plugin for WordPress to version 2.0.2 or newer.
- Official ID
- CVE-2022-4974
- Report title
- Freemius SDK <= 2.4.2 - Missing Authorization Checks
- First reported
- Sources
- Wordfence, seen
Someone could plant harmful code that runs for your visitors or admins (up to and including 2.9.9)
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 2.9.9
- Fixed in
- 3.0.0
- What to do
- If your site has an affected version, update YASR – Yet Another Star Rating Plugin for WordPress to version 3.0.0 or newer.
- Official ID
- CVE-2022-23980
- Report title
- Yasr – Yet Another Stars Rating <= 2.9.9 - Cross-Site Scripting via source
- First reported
- Sources
- Wordfence, seen
A stranger could in some setups, take over your site
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Up to and including 1.8.6
- Fixed in
- 1.8.7
- What to do
- If your site has an affected version, update YASR – Yet Another Star Rating Plugin for WordPress to version 1.8.7 or newer.
- Report title
- Yet Another Stars Rating <= 1.8.6 - Unauthenticated PHP Object Injection
- First reported
- Sources
- Wordfence, seen
Someone could read or change the data in your site’s database
A trusted security source confirmed it. If your site has an affected version, fix it this week.
- Affected versions
- Before 0.9.1
- Fixed in
- 0.9.1
- What to do
- If your site has an affected version, update YASR – Yet Another Star Rating Plugin for WordPress to version 0.9.1 or newer.
- Official ID
- CVE-2015-9465
- Report title
- Yasr – Yet Another Stars Rating < 0.9.1 - Authenticated SQL Injection
- First reported
- Sources
- Wordfence, seen
Where this comes from
We collect these reports from public security sources and rewrite them in plain words. Each problem shows its sources and the date we first saw it. This page never says whether your own site is affected: only a check of your site’s versions can tell.
Get an email when your site is affected.
Install Watchfox AI once. It checks your plugins and themes against this list every day, for free.
Install Watchfox AI (free)